none
email 附件變成亂碼(VISTA 搭 Outlook2003 不合嘛?!) RRS feed

  • 一般討論

  •  

    電腦A (Vista Sp1+Office outlook2003 Sp3)   mail server 為 Hinet 主機

    傳送一封郵件 含 powerpoint附件 

    電腦B(Windows XP sp3 + Office Outlook 2003 Sp3) mail Server 為 MS Exchange 2007 SP1(windows 2003 企中 64bit)

    郵件 本文主旨 皆正常  但 powerpoint 附件 是亂碼

     

    經測試

    1.直接轉寄 ----> 亂碼

    2.建立新信件 再附加檔案  ----->  亂碼

    3.檔案>右鍵>傳送到郵件收件者  -------> 正常

    4.webmail  方式寄送 ------ > 正常

    5.電腦C(Cwin 2K + Office outlook 2000)  以上面方式 傳送 皆正常

     

    再確認email raw data  有問題的信件 在附件的編碼上 少了定義編碼方式

    例-----------------------------------------------------------------------------------------------------------

    ------=_NextPart_000_0000_01C940FC.F250D610
    Content-Type: application/vnd.ms-powerpoint;
    name="=?big5?B?taaypLd8xLOz+KdpruamoS5wcHQ=?="
    Content-Disposition: attachment;
    filename="=?big5?B?taaypLd8xLOz+KdpruamoS5wcHQ=?="
                                                        <------無定義編碼方式

    ---------------------------------------------------------------------------------------------------------------

    ------=_NextPart_000_0005_01C940FC.FFE31C20
    Content-Type: application/vnd.ms-powerpoint;
    name="=?big5?B?taaypLd8xLOz+KdpruamoS5wcHQ=?="
    Content-Disposition: attachment;
    filename="=?big5?B?taaypLd8xLOz+KdpruamoS5wcHQ=?="
    Content-Transfer-Encoding: base64 <------有定義編碼方式

     

    這可能是 VISTA 跟 OUTLOOK 2003  相容的問題嗎?!

    有其他人遇到類似狀況嗎?! 

     

     

     

     

     

    2008年11月7日 上午 10:26