locked
Windows 7 家用進階版突然無法上網 RRS feed

  • 問題

  • 各位好,

    近期小弟在做完 Windows Update 後, Win 7 就突然無法上網.

    IP 可以抓到, LAN 也會通, 但就是出 Internet 時就掛了.
    ping gateway 沒回應, 但 DNS 解析正常.
    (其它 XP 的電腦都很正常...就 Win 7 不行...)

    華碩客服告知的網卡 Driver 重裝也無效.

    route print 時, Gateway 會出現 On-link, 且下方沒有顯示 Default Gateway.

    這有可能是中毒還是 Windows Update 造成的呢?

    不曉得那位大大可以告知如何處理呢?

    先謝謝囉.
    2011年12月26日 上午 10:21

解答

  • 您好!

    理論上做Windows Update是不會發生這種問題的,另外請您注意一下,看看是否有更新到網卡Driver。

    建議您Recovery後,先在執行完整的Windows Update,更新到沒新的Hotfix為止,若有狀況在回報一下囉。

    2011年12月27日 下午 12:33

所有回覆

  • 你是否有安裝防毒軟體?假如有的話建議你先移除後再試試看?另外你可以測試一下安全模式含網路功能的狀況下網路是否正常

    假如有時間的話也可以測試先將DHCP改成自訂IP與Gateway還有Dns再來進行測試看看。


    小白技術沒關係 金錢的力量 決定服務的高低
    2011年12月26日 上午 10:47
  • 2011年12月26日 下午 12:47
  • 我嘗試的步驟如下:

    1. 系統還原至較早的時間點 --> 無法還原.

    2. 移除網卡 Driver 再重新安裝 --> 一樣無法上網.

    3. 以安全模式 (含網路功能) 進 Win 7 -->  一樣無法上網.

    4. 移除防毒軟體後再進行系統系統還原至較早的時間點 --> 雖然還原成功, 但一樣無法上網.

    5. 承上, 在無防毒軟體的狀況下手動設定 IP , subnet mask, gateway, DNS --> 一樣無法上網.

    6. route print 後, 一堆設定都怪怪的, 如 gateway 變成 On-link, Metric 不是 20 或一般常見的數字, 都變成 3XX .

    明明是 Atheros 的 Onboard 有線網路卡,  但居然可以找到一台叫 WPS 的 AP, 詭異的是我們並沒有 AP 是叫 WPS 的.

    2011年12月26日 下午 01:18
  • 有試, 但無法解決....

    只顯示 "您的網路設定似乎正常, 但 www.microsoft.com 沒有反饋 " (印象中所顯示的文字, 應該有些出入)

    2011年12月26日 下午 01:19
  • 您好!

    看一下hosts裡面有沒有被寫入什麼東西

    用記事本打開C:\Windows\System32\drivers\etc\hosts


    • 已編輯 Andy Chen 2011年12月26日 下午 01:57
    2011年12月26日 下午 01:55
  • 沒有怪東西, 只有一行我自己加的主機設定.

    ps: 其它行的都是以 # 開頭的註解.

    • 已編輯 Ck10011 2011年12月27日 上午 12:13
    2011年12月27日 上午 12:12
  • 您好!

    如果先把您設定的那一段Mark起來,重開機後試呢?

    另外請教,這一台是NB還是PC

    2011年12月27日 上午 12:16
  • 一樣耶.....網卡會顯示無法辨識的網路.

    這一台是 ASUS 的 V3-PH5 直立式 PC.

    另一台也是 ASUS 的 PC , 但型號為 CM5675

    兩台都是同一天做完 Windows Update 後就網卡異常.

    2011年12月27日 上午 12:34
  • 您好!

    可以先回復驅動程式嗎?

    2011年12月27日 上午 12:36
  • 和您的圖示一樣是灰色, 無法執行.

    Orz...

    2011年12月27日 上午 12:44
  • 您好!

    先移除Driver,試一下這一個Driver看看。或使用主機所附的光碟驅動。

    內建的Atheros L1網卡,之前也是有些狀況,如果有其他網卡的話,可先將內建的網卡從BIOS停用,在試另外接的網卡測試

    Atheros L1 Gigabit Ethernet

    2011年12月27日 上午 12:56
  • 您好,

    您提供的那一個 Driver 無法安裝於 Win 7 64bit 的 OS 上.

     

    在 BIOS 停用網卡後, 主板一樣抓不到新裝的螃蟹卡...而且兩台都一樣抓不到.

    但那片螃蟹卡裝到其它 XP 的 PC 又 ok...

    Orz....

    2011年12月27日 上午 02:21
  • 不知道你手邊是否有多的硬碟與Windows 7安裝光碟,假如有的話建議你可以換一個硬碟然後重新安裝作業系統然後先不要安裝其他的軟體直接更新到畫面出現無可用新的更新為止再測試網路功能看看是否會出現一樣的狀況。


    小白技術沒關係 金錢的力量 決定服務的高低
    2011年12月27日 上午 03:02
  • 您好, 

    我手邊雖有 HDD, 但 OS 都是買ASUS 的隨機版....

    它是存於 HDD 中的其中一個區塊, 所以沒有一般的安裝光碟可用.

    2011年12月27日 上午 03:28
  • 你可以先到這裡下載試用版進行測試有90天的測試時間應該夠了,假如有問題的話就真的一翻兩瞪眼了
    小白技術沒關係 金錢的力量 決定服務的高低
    2011年12月27日 上午 06:07
  • 我的電腦已經在 Standby .....準備 Recovery 到出廠狀態....

    因為第一台 CM5675 正在還原當中.....到時便知道了....

    先謝謝各位大大....

    ^_^

    ps: 就算我還原完, 還是有點不敢做太多次的 Windows Update.....Orz....

    2011年12月27日 上午 06:54
  • 您好!

    理論上做Windows Update是不會發生這種問題的,另外請您注意一下,看看是否有更新到網卡Driver。

    建議您Recovery後,先在執行完整的Windows Update,更新到沒新的Hotfix為止,若有狀況在回報一下囉。

    2011年12月27日 下午 12:33
  • 該做的還是要做,要是你現在不做以後出問題這樣子不就更麻煩,所以還是建議先做完更新吧,另外再更新前你也可以先將系統還原的設定打開然後再做更新,因為要是出問題的話至少你還可以使用系統還原


    小白技術沒關係 金錢的力量 決定服務的高低
    • 已編輯 Kill Apple 2011年12月28日 上午 03:51
    2011年12月28日 上午 03:50
  • 謝謝各位大大...

    目前已重新安裝系統, 並取消勾選 QoS 及 IPv6 等項目.....

    之後就可以正常使用...

    ps: 應該是網卡的 Driver 被覆蓋掉了.....先前有台 XP 的 NB 也有類似的狀況, 用光碟安裝後網卡正常, 但一裝完 Windows Update 的網卡 Driver 就掛了....好像也是 Atheros 的網卡....

    2011年12月28日 上午 07:39