none
0x8004010F RRS feed

  • 問題

  • 各位前輩大家好,小弟知道問題已經是老梗了
    但小弟還是遇到了問題,所以還請各位前輩能指點一下
    前陣子小弟的公司因為要用outlook anywhere,所以努力的試了一下,總算讓這功能可以使用,同時離線通訊錄也能正確下載
    可是後來安裝記憶體重新開機後,下載離線通訊錄就會出現0x8004010F的訊息…

    小弟有檢查了幾個地方:
    1.DNS有Autodiscover的記錄,也ping的到
    2.IIS上面有Autodiscover的網站,不過直接連線autodiscover.xml沒有顯示任何網頁
    3.outlook anywhere在外部同樣可以正常使用,OWA也正常
    4.有試過重新建立離線通訊錄,結果還是一樣
    不知道接下來還能做什麼測試或是調整?
    請各位前輩指點一下,謝謝

    忘了說,環境是2003 AD+Ex2007 x64
    • 已編輯 Cftzeng 2009年10月27日 上午 01:36
    2009年10月26日 上午 09:08

解答

  • 目前的狀態看來是正常了

    小弟是到伺服器組態\信箱下的資料庫管理,確定每個資料庫上的用戶端設定裡的離線通訊錄都指向設定好的離線通訊錄(之前都是空白)

    再測試就可以正常下載了

    給有問題的版友參考一下

    • 已標示為解答 Cftzeng 2010年4月8日 上午 06:29
    2010年4月7日 上午 05:15

所有回覆

  • 小弟也幫不上忙~上來幫推一下,
    因為我也遇到相同的問題。
    OFFICE 2003的USER會出現0x8004010F這個錯誤訊息(在同步問題的LOG裡面有看到這個錯誤訊息)。
    OFFICE 2007的USER就傳送接收超久的(滑鼠移到EXCHANGE會出現下載離線通訊錄的訊息)。
    因為似乎沒找到,所以過一會EXCHANGE自動在同步時,又會出現一個,所以過一個小時後,傳送接收那邊就會看到很多EXCHANGE接收的訊息。
    我是移轉EXCHANGE 2003到新的EXCHANGE 2007 上,有在DNS 設了Autodiscover的RECORD。
    順便請問一下,我看到有人說Autodiscover在DNS 上設A RECORD指到MAIL SERVER即可(有離線通訊錄的)。
    可是有看到一篇講要設SRV RECORD http://support.microsoft.com/kb/940881 
    請問是兩個都要設嗎?謝謝

    2009年10月26日 下午 03:00
  • 離線通訊錄建立時要指定主要的郵件Server不是DC,設定是在主要郵件SERVER上的郵件信箱儲存區內容選項
    之前我設定好的時候過了一天就不會有這個問題(設好好像不會馬上生效)
    2009年10月27日 上午 04:15
  • 是在那邊設定沒錯,但我已經設定好好幾天了,還是不斷的有錯誤訊息出現
    還有什麼地方可以讓小弟調整或測試的嗎?
    2009年10月27日 上午 06:45
  • 1.開啟「Exchange 系統管理員」。
    2.展開「收件者」。
    3.點選「離線通訊清單」。
    4.於右方窗格中,於「預設離線通訊清單」上按一下滑鼠右鍵,選擇「內容」。
    5.在「一般」標籤中,確認伺服器和通訊清單是否正確設定。注意預設值應該是「預設全域通訊清單」。
    6.按下「確定」按鈕。
    7.於右方窗格的「預設離線通訊清單」上按一下滑鼠右鍵,選擇「設為新預設」。
    8.再於右方窗格的「預設離線通訊清單」上按一下滑鼠右鍵,選擇「重建」。
    我是用這些方式就解決了

    2009年10月27日 上午 06:55
  • 感謝回覆,但我重建離線通訊錄就是依上述步驟建立的…
    2009年10月27日 上午 08:22
  • 你要確定離線通訊錄的主機是目前的"主要郵件主機",不是備援主機
    信箱儲存區是目前使用中的才是,如果裡面都沒有帳號就不是那個
    確認一下
    2009年10月27日 上午 10:03
  • 我們只有一台郵件主機,所以應該不會選錯
    信箱儲存區也是全部都有選到新的離線通訊錄
    2009年10月29日 上午 03:36
  • 今天再測試電子郵件自動設定,發現許多的錯誤訊息
    Autoconfiguration was unable to determine your settings!
    Autodiscover to https://autodiscover.mail.abc.com/Autodiscover/Autodiscover.xml FAILED (0x80004005)
    可否請各位前輩指點一下
    2009年10月30日 上午 01:01
  • 尚未下載離線通訊錄檔。找不到伺服器 (URL)
    這是後來出現的問題
    google了一下,應該是找不到autodiscover的record所致
    但小弟已經在dns上設定了該record對應的ip(到mail server)
    不知道還能朝什麼方向來檢查呢?
    2009年11月3日 上午 05:26
  • https://www.testexchangeconnectivity.com

    先測試一下autodiscover service 是否正常運作


    Johnny_Yao
    2009年11月4日 上午 02:09
  • 因為小弟的mail address是類似mail.abc.com
    但公司網域是abc.com
    所以去找autodiscover.mail.abc.com會找不到
    請問這樣的情況該怎麼調整呢?
    2009年11月6日 上午 12:50
  • 因為小弟的mail address是類似mail.abc.com
    但公司網域是abc.com
    所以去找autodiscover.mail.abc.com會找不到
    請問這樣的情況該怎麼調整呢?

    是用Email domain 來查

    您上面的討論loop 沒有看的很仔細, 若您對於其他人的建議都已確認過, 

    1. 那建議您先在outlook Icon 上 執行CTRL+Right Click  run Test E-Mail AutoConfiguration看看分別的rpc & http 的各項設定如何

    2. 也可看OAB 的路徑上有沒有folder 產生, 當您update OAB 時, C:\Program Files\Microsoft\Exchange Server\ClientAccess\OAB 會有更新的folder 

    3. [ps] test-outlookwebservices | fl 可明確看出autodiscover 是否正常連通

    Johnny_Yao
    2009年11月6日 上午 01:29
  • 在run Test E-Mail AutoConfiguration就出現
    autoconfiguration was unable to determine your settings

    在C:\Program Files\Microsoft\Exchange Server\ClientAccess\OAB是有產生資料夾

    所以看來是autodiscover有問題

    請問這該怎麼解呢?
    2009年11月6日 上午 04:51
  • 試了好久,總算找到相關的資料
    http://technet.microsoft.com/zh-tw/library/aa997633.aspx
    然後,修改內部autodiscover的url
    Set-ClientAccessServer -Identity "mailsrv" -AutodiscoverServiceInternalURI "https://mailsrv.abc.com/autodiscover/autodiscover.xml"
    經過測試已經不會再出現錯誤訊息了

    --------------
    11/30經過一晚再測試,問題還是沒解決…
    2009年11月28日 上午 07:46
  • 請問您的Exchange 架構有做CCR嗎? 類似這樣的問題通常都是發生在CCR 架構上哦。
    我也是有發生過這樣的問題,主機伺服器跑到第二台上去了,所以用戶端Outlook讀不到
    離線通訊錄,將第二台設上離線通訊錄後就解決囉。
    2009年12月10日 上午 02:12
  • 感謝sam的回覆
    我們公司只有一台Exchange Server,所以應該不太可能
    2009年12月10日 上午 05:08
  • 目前的狀態看來是正常了

    小弟是到伺服器組態\信箱下的資料庫管理,確定每個資料庫上的用戶端設定裡的離線通訊錄都指向設定好的離線通訊錄(之前都是空白)

    再測試就可以正常下載了

    給有問題的版友參考一下

    • 已標示為解答 Cftzeng 2010年4月8日 上午 06:29
    2010年4月7日 上午 05:15