none
Exch2k7 Edge & HUB 問題 RRS feed

  • 問題

  • 目前建立 exchange 2k7 測試環境, 遇到幾個問題請幫忙看看:

    1. subscribed edge & edge sync 後, 在 hub 上有錯誤訊息
      1. Source: MSExchange EdgeSync
        Category: Synchronizatio
        Event ID: 10102
        Description: Faild to synchronize to CN=Message Classifications, CN=Transport Settings,CN=First organization,CN=Microsoft Exchange,CN=Services,CN=Configuration,CN={4533B8D-619D-46F3-BF8E-06E8F36BD6AA} because object already exists
      2. Source: MSExchange EdgeSync
        Category: Topology
        Event ID: 1024
        Description: Edge locking server server2.mydomain.com generated exception System.DirectoryServices.Protocols.LdapException: The supplied credential is invalid. at System.DirectoryServices.Protocols.LdapConnection.BindHelper (NetworkCredential newCredential,Boolean needSetCredential).........
    2. 在 HUB 上下 start-EdgeSynchronization 時
      1. Type 為 Recipient 顯示成功
      2. Type 為 Configuration 顯示 Incomplete
    3. 在 Edge 上則遇到 AD 問題
      1. Source: DnsApi
        Category: NONE
        Event ID: 11166
        Description: The system failed to register host (A) resource records (RRs) for network adapter.....

    環境說明:

    Single forest, single domain

    Server roles

    Server 1: mailbox server, client access, hub transport, unified messaging

    Server 2: Edge servr

    Edge 沒有 Join domain, 但有加 DNS suffix
    2007年5月3日 上午 08:46

解答

  • 老哥,你一開始應該就要先說明你是在Beta2的版本,不然很容易雞同鴉講耶

    個人認為現在看不出有任何理由還必需要繼續使用Beta 2作測試耶

    建議您下載RTM的測試版本再說

    2007年5月4日 上午 04:00

所有回覆

  • 首先,請確認你的Edge擁有FQDN Name而不是只有Host Namw

    再來你的Hub與Edge Server間要能夠相互解析得到名稱及正確的IP

    Edge 不需要Join Domain也不需要加DNS Suffix只要能夠正確解析得到Hub IP即可

    你可以在Hub上使用Test-Edgesyn cmdlet來做確認

    2007年5月3日 上午 09:11
  • 奇怪, 為什麼我的 cmdlet 沒有

    Code Snippet
    Test-EdgeSynchronization

     的指令? 我的 monad 版本是 50727

    Edge & hub 都有正確註冊 A 記錄以及 MX (edge) 記錄, 也可以查詢沒問題. 請問還需要檢查什麼地方嗎?

    http://www.microsoft.com/technet/prodtechnol/exchange/E2k7/ZH-TW/Help/ExchHelp/517bf47c-9e40-4a34-8278-42690a7d0a1f.mspx?mfr=true

    2007年5月3日 上午 10:00
  • Sorry,Test-EdgeSynchronization才是正確的
    2007年5月3日 下午 01:50
  • 羅老師請問, 為什麼我的 hub 上找不到 test-edgesynchronization? 是不是版本問題?

    ps. 我所安裝的是 x86 的 exch2k7

    2007年5月4日 上午 01:32
  • 應該要有這個cmdlet才對耶

    不管是x86 or x64都會有的

    你可以先打Test-E然後再按Tab鍵看會不會出來

    2007年5月4日 上午 02:04
  • 老師, 我這 test cmdlet 只有以下這些; 但就沒有 EdgeSynchronization. 

     

     

    Test-ExchangeConfigEncryption

    Test-ExchangeSearch

    Test-IPAllowListProvider

    Test-IPBlockListProvider

    Test-MAPIConnectivity

    Test-MobileSyncConnectivity

    Test-OutlookWebServices

    Test-Path

    Test-SenderId

    Test-ServiceHealth

    Test-SystemHealth

    Test-UMConnectivity

    Test-WebServicesConnectivity

    2007年5月4日 上午 02:42
  • 你確定你是在你的hun Transport server上試的嗎?

    我的有耶,即使是全新安裝沒有訂閱EdgeSync的HTS也會有該指令

    2007年5月4日 上午 03:30
  • 是在 hub 上試的, 跟 exch 的版本有關嗎? 我安裝的是 exch2k7 beta 2 trial
    2007年5月4日 上午 03:55
  • 老哥,你一開始應該就要先說明你是在Beta2的版本,不然很容易雞同鴉講耶

    個人認為現在看不出有任何理由還必需要繼續使用Beta 2作測試耶

    建議您下載RTM的測試版本再說

    2007年5月4日 上午 04:00
  •    因為測試環境, 且手邊只有這一版本...sorry 沒先說清楚.

    2007年5月4日 上午 05:29
  • 你可以到官方網站上下載試用版來測試。
    2007年5月4日 上午 05:46
  • Test-EdgeSynchronization 在Beta2版本中是没有的
    2007年5月30日 上午 06:49