none
最近遇到無法解決的問題... 高手幫忙一下.... RRS feed

  • 問題

  • 環境描述:

    VM Server 2005 SP1 + Win 2003 R2 Enterprise + SharePoint 2007 +IIS 6.0 + 遠端SQL 2005 SP2(另一台DB server)

     

     1. 因moss管理帳號不是用網域管理員,而是用另外新建擁有管理員權限之帳號(假設此帳號為admin)。日前發生此帳號過期,小弟已經修改過此帳號的密碼,並設為永久有效。目前登入moss系統都正常,功能也都能使用。但是事件檢視簿卻一直發現下面這兩個錯誤訊息。我爬過許多文,並試著做過下面這些處理:

        (1) 將「服務」中,Office SharePoint Server Search、Windows SharePoint Services Timer、Windows SharePoint Services Search 都修改成 我新建的admin帳號,上述服務都可以正常啟動。

       (2) 「服務」中,Windows SharePoint Services Administration 為本機服務帳號來啟動,此帳號我修改過admin,但無法正常啟動,因此我又改為本機服務帳號來啟動。

     

    2. 我一直想不透到底是那個帳號連結有問題,我也有新增過DCOM的Osearch中的帳號把他新增IIS的帳號,但發現根本沒用,後來又將IIS帳號又刪除了。

     

    3. 也直接到IIS上修改,應用程式集區→ xxx(moss應用程式集)→身份識別;全都修改成 admin的帳號,這些程式集也都正常無錯誤的啟動中。

     

    4. 爬過許多文,但獲得資訊甚少,請教各位高手,我是否還疑漏了哪些地方沒有注意呢?!

     

    錯誤訊息如下:

    事件類型: 錯誤
    事件來源: Office SharePoint Server
    事件類別目錄: Office Server 共用服務
    事件識別碼: 6482
    日期:  2008/7/21
    時間:  上午 10:45:15
    使用者:  N/A
    電腦: XXXX
    描述:
    服務執行個體 Microsoft.Office.Server.Search.Administration.SearchServiceInstance (2b24effe-c712-4a87-94bd-6c7c911f2c66) 的應用程式伺服器管理工作失敗。

    原因: 登入失敗: 不明的使用者名稱或錯誤密碼。

    技術支援詳細資料:
    System.ComponentModel.Win32Exception: 登入失敗: 不明的使用者名稱或錯誤密碼。
       於 Microsoft.Office.Server.Search.Administration.SearchServiceInstance.SynchronizeDefaultContentSource(IDictionary applications)
       於 Microsoft.Office.Server.Search.Administration.SearchServiceInstance.Synchronize()
       於 Microsoft.Office.Server.Administration.ApplicationServerJob.ProvisionLocalSharedServiceInstances(Boolean isAdministrationServiceJob)

    請在 http://go.microsoft.com/fwlink/events.asp 查看說明及支援中心,以取得其他資訊。


    事件類型: 錯誤
    事件來源: Office SharePoint Server
    事件類別目錄: Office Server 共用服務
    事件識別碼: 6641
    日期:  2008/7/21
    時間:  上午 10:45:20
    使用者:  N/A
    電腦: XXXX
    描述:
    未執行 SSP 計時器工作 通訊群組清單匯入工作。

    原因: 登入失敗: 不明的使用者名稱或錯誤密碼。

    技術支援詳細資料:
    System.ComponentModel.Win32Exception: 登入失敗: 不明的使用者名稱或錯誤密碼。
       於 Microsoft.Office.Server.Utilities.WindowsSecurity.GetUserTokenFromCredentials(String userDomainName, String password, LogonType logonType)
       於 Microsoft.Office.Server.Utilities.WindowsSecurity.GetUserTokenFromCredentials(String userDomainName, String password)
       於 Microsoft.Office.Server.Administration.JobHandler.Execute(Object state, Boolean timedOut)

    請在 http://go.microsoft.com/fwlink/events.asp 查看說明及支援中心,以取得其他資訊。

    2008年7月21日 上午 03:11

解答

  •  

    第二問題點解決....

     

    這幾天在解決此問題時,在想這哪個應用程式對應到哪一個網站,

    後來發現最主要的就是共用服務產生之SSP,透過此SSP 控制頂層、個人網站,加上一直出現SSP 相關error,

    所以就在想是否是共用服務產生之SSP有問題。

     

    之後在管理共用服務那個頁面,重新編輯SSP,並將連結資料庫之帳號修改為admin,之後重新啟動IIS。

     

    問題就解決啦!!

    真高興自己把他解決~~在此分享給各位。

     

    ps. 建議要修改moss 之服務帳戶,請不要在IIS底下直接修改,發現那邊修改有機會失敗或沒有與moss管理中心同步。

         建議不要輕易修改服務中啟動帳戶。

    2008年7月25日 上午 05:11

所有回覆

  • 已解決第一個問題點...

     

    因為發現問題點為Microsoft.Office.Server.Search.Administration.SearchServiceInstance ,所以我就往Search方面著手,

    首先,先進入sharepoing 管理中心,確認一下Search由哪一個應用程式控制,發現是由共用服務管理所控制,之後我進去檢查所有有關登入帳號的地方,發現不曉得或是不知為何在Search帳號部份變成由網路服務帳號代替了admin之帳號,後來我將此帳號修改為admin,我的第一個問題就解決了!!

     

    但是第二個問題目前仍舊存在,本以為應該也是在共用服務中可找到蛛絲馬跡,但發現不管我用網域管理者或是admin ,這問題仍舊困擾著我!!

    Windows SharePoint Services Timer  利用admin帳號可以正常run。

    不過我發現我的admin在每天都會被鎖定... 這也是我搞不懂的地方。

     

    目前我新增一個共用服務,來替代原先的共用服務,只能試看看,也許這個問題需要點數或是真的沒人碰過...

    只有一個一個試看看,

    也許被我瞎貓碰死耗子的解決問題....  若解決再跟各位分享囉~~~

    2008年7月25日 上午 02:20
  •  

    第二問題點解決....

     

    這幾天在解決此問題時,在想這哪個應用程式對應到哪一個網站,

    後來發現最主要的就是共用服務產生之SSP,透過此SSP 控制頂層、個人網站,加上一直出現SSP 相關error,

    所以就在想是否是共用服務產生之SSP有問題。

     

    之後在管理共用服務那個頁面,重新編輯SSP,並將連結資料庫之帳號修改為admin,之後重新啟動IIS。

     

    問題就解決啦!!

    真高興自己把他解決~~在此分享給各位。

     

    ps. 建議要修改moss 之服務帳戶,請不要在IIS底下直接修改,發現那邊修改有機會失敗或沒有與moss管理中心同步。

         建議不要輕易修改服務中啟動帳戶。

    2008年7月25日 上午 05:11
  • 謝謝分享~又學到東西了!

    2008年9月17日 上午 09:55
  •  lazy bone 寫信:

     

    第二問題點解決....

     

    這幾天在解決此問題時,在想這哪個應用程式對應到哪一個網站,

    後來發現最主要的就是共用服務產生之SSP,透過此SSP 控制頂層、個人網站,加上一直出現SSP 相關error,

    所以就在想是否是共用服務產生之SSP有問題。

     

    之後在管理共用服務那個頁面,重新編輯SSP,並將連結資料庫之帳號修改為admin,之後重新啟動IIS。

     

    問題就解決啦!!

    真高興自己把他解決~~在此分享給各位。

     

    ps. 建議要修改moss 之服務帳戶,請不要在IIS底下直接修改,發現那邊修改有機會失敗或沒有與moss管理中心同步。

         建議不要輕易修改服務中啟動帳戶。

     

    修改服務帳戶,請參考KB http://support.microsoft.com/kb/934838 

    2008年9月25日 上午 06:47