none
線路選擇 RRS feed

  • 問題

  • 各位先進小弟有一網路架設問題請問:
         我們公司申請了兩條對外的FTTB線路,並區分為兩各網段A、B網段。
    A網段:主要放置為Mail Server、Web Server。
    B網段:所有公司對外連線。使用者都使用該網段上網。

    目前遇到一個問題,由於員工上網都是使用B網段上網,所以當要接收Mail的時候,就必須由B網段繞出去,然後進入A網段收信,每當信件太大時,就會收不下來。我想說,這應該都是內部直接轉換就行了,應該不需要再繞到Internet後再繞回來。想請問一下各位先進,我要如何做才能讓這兩各網段都可以如同內部網路一樣快速。是否需要購買一台Layer 3 Switch然後設定相關的Static Route...請各問先進幫忙。謝謝
    2008年9月12日 上午 07:06

解答

  • 我不是什麼老師啦,只是也喜歡參與討論跟找答案的IT人而已

    對於能否用L3 Switch解決你的問題,

    說實話,我想不出可行的方法

     

    而且你的問題已經跳脫TechNet論壇跟這個版的討論範圍

    我會比較推薦你到vLAB Forums尋求更專業的解答

    • 已標示為解答 Bethere 2009年3月15日 上午 08:17
    2008年9月15日 上午 06:22
    版主
  •  

    Cisco RouteMap 應用
    2005-04-23 03:01
    目標說明 -
    假設對外接了多條 ISP , 又沒有專門的設備可以做 Link Controller 的話 , 可以簡單的用 Cisco 的 Layer 3 以上設備 (Switch/Router) , 靠 Route map 改掉封包的 gateway , 做到 Multi-ISP Gateway .
    以下是最基本最簡單的設法 , 還有很多的變化技可以用 ...
    環境說明 -
    假設對外有三條 ISP , 而對內則直接往 Vlan 5 送過去
    ISP1 ,
    Peer IP - 1.1.1.253/30
    Gateway IP - 1.1.1.254
    Subnet IP - 1.1.10.0/24
    ISP2 ,
    Peer IP - 2.2.2.253/30
    Gateway IP - 2.2.2.254
    Subnet IP - 2.2.20.0/24
    ISP3 ,
    Peer IP - 3.3.3.253/30
    Gateway IP - 3.3.3.254
    Subnet IP - 3.3.30.0/24
    首先在 Vlan 上 (L3 Switch) 或 Interface/Sub Interface上 (Router) 定好要跟 Gateway 溝通的 ip , 及要引入哪幾條 route-map .
    ( 當然 interface 的 Vlan 要先切好 )
    interface Vlan2
    ip address 1.1.1.253 255.255.255.252
    ip policy route-map ISP1
    !
    interface Vlan3
    ip address 2.2.2.253 255.255.255.252
    ip policy route-map ISP2
    !
    interface Vlan4
    ip address 3.3.3.253 255.255.255.252
    ip policy route-map ISP3
    然後為各 ISP 配下來的網段定好 Access List
    access-list 101 permit ip 1.1.10.0 0.0.0.255 any
    access-list 102 permit ip 2.2.20.0 0.0.0.255 any
    access-list 103 permit ip 3.3.30.0 0.0.0.255 any
    以及設定好 Routing Table
    ip classless
    ip route 1.1.10.0 255.255.255.0 Vlan 5
    ip route 2.2.20.0 255.255.255.0 Vlan 5
    ip route 3.3.30.0 255.255.255.0 Vlan 5
    最後重點就是訂 Route Map , 讓 source ip 符合 Access List 的封包改掉 Gateway
    route-map ISP1 permit 10
    match ip address 101
    set ip next-hop 1.1.1.254
    !
    route-map ISP2 permit 20
    match ip address 102
    set ip next-hop 2.2.2.254
    !
    route-map ISP3 permit 30
    match ip address 103
    set ip next-hop 3.3.3.254
    如此一來下面機器送出來的封包一 match 到 route-map 中設定的 access-list , 就會往該走的 gateway 送過去.
    檢測的方法很簡單 , 從下面的機器分別帶三條 isp 的 ip , traceroute 出去外面 , 看會不會分別走三條不同的 ISP 就知道了.
    • 已標示為解答 Bethere 2009年3月15日 上午 08:17
    2008年9月19日 上午 01:26

所有回覆

  • 請問你是MIS嗎?
    這樣大家才能知道說,要用比較貼近你的角色的用語來解說 how to do
     

    2008年9月12日 下午 12:51
  • 是阿..

    2008年9月12日 下午 04:07
  • 不知道你們公司的人數有多少??

    我會建議你至少買一台有2Wan的頻寬整合器或防火牆

    這樣就可以把Mail Server或其他對外服務的Server都放在內部或DMZ區

    而且設定上會比較簡單

    2008年9月13日 上午 08:18
    版主
  • 謝謝,主要是我手上有一台Layer3的Switch,我想這應該可以達到需求,所以才請問各位老師看是否有可以解決的方式。

    是否如Aska老師所說,一定要使用2Wan的設備呢?
    2008年9月15日 上午 01:55
  • 我不是什麼老師啦,只是也喜歡參與討論跟找答案的IT人而已

    對於能否用L3 Switch解決你的問題,

    說實話,我想不出可行的方法

     

    而且你的問題已經跳脫TechNet論壇跟這個版的討論範圍

    我會比較推薦你到vLAB Forums尋求更專業的解答

    • 已標示為解答 Bethere 2009年3月15日 上午 08:17
    2008年9月15日 上午 06:22
    版主
  • 好,謝謝....
    2008年9月15日 上午 06:26
  •  

    Cisco RouteMap 應用
    2005-04-23 03:01
    目標說明 -
    假設對外接了多條 ISP , 又沒有專門的設備可以做 Link Controller 的話 , 可以簡單的用 Cisco 的 Layer 3 以上設備 (Switch/Router) , 靠 Route map 改掉封包的 gateway , 做到 Multi-ISP Gateway .
    以下是最基本最簡單的設法 , 還有很多的變化技可以用 ...
    環境說明 -
    假設對外有三條 ISP , 而對內則直接往 Vlan 5 送過去
    ISP1 ,
    Peer IP - 1.1.1.253/30
    Gateway IP - 1.1.1.254
    Subnet IP - 1.1.10.0/24
    ISP2 ,
    Peer IP - 2.2.2.253/30
    Gateway IP - 2.2.2.254
    Subnet IP - 2.2.20.0/24
    ISP3 ,
    Peer IP - 3.3.3.253/30
    Gateway IP - 3.3.3.254
    Subnet IP - 3.3.30.0/24
    首先在 Vlan 上 (L3 Switch) 或 Interface/Sub Interface上 (Router) 定好要跟 Gateway 溝通的 ip , 及要引入哪幾條 route-map .
    ( 當然 interface 的 Vlan 要先切好 )
    interface Vlan2
    ip address 1.1.1.253 255.255.255.252
    ip policy route-map ISP1
    !
    interface Vlan3
    ip address 2.2.2.253 255.255.255.252
    ip policy route-map ISP2
    !
    interface Vlan4
    ip address 3.3.3.253 255.255.255.252
    ip policy route-map ISP3
    然後為各 ISP 配下來的網段定好 Access List
    access-list 101 permit ip 1.1.10.0 0.0.0.255 any
    access-list 102 permit ip 2.2.20.0 0.0.0.255 any
    access-list 103 permit ip 3.3.30.0 0.0.0.255 any
    以及設定好 Routing Table
    ip classless
    ip route 1.1.10.0 255.255.255.0 Vlan 5
    ip route 2.2.20.0 255.255.255.0 Vlan 5
    ip route 3.3.30.0 255.255.255.0 Vlan 5
    最後重點就是訂 Route Map , 讓 source ip 符合 Access List 的封包改掉 Gateway
    route-map ISP1 permit 10
    match ip address 101
    set ip next-hop 1.1.1.254
    !
    route-map ISP2 permit 20
    match ip address 102
    set ip next-hop 2.2.2.254
    !
    route-map ISP3 permit 30
    match ip address 103
    set ip next-hop 3.3.3.254
    如此一來下面機器送出來的封包一 match 到 route-map 中設定的 access-list , 就會往該走的 gateway 送過去.
    檢測的方法很簡單 , 從下面的機器分別帶三條 isp 的 ip , traceroute 出去外面 , 看會不會分別走三條不同的 ISP 就知道了.
    • 已標示為解答 Bethere 2009年3月15日 上午 08:17
    2008年9月19日 上午 01:26
  • 但這三個VLAN應該不能互通吧
    2015年6月9日 下午 02:49
  • 你接兩條外線的設備是甚麼?

    防火牆?

    支援備援的中高階路由器?

    Windows Server ?

    簡單一點就是內網一個 dns ,把 mail / web 設定內網 ip ,其餘參照外網 dns

    內網的 dns 都指向這台。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2015年6月9日 下午 03:30