none
無法開啟共用服務管理網站,有出現登入視窗 RRS feed

  • 問題

  • 我於管理中心選擇共用服務管理,想開啟共用服務管理網站,有出現登入視窗,但是輸入正確帳密後,卻無法驗證,三次後就跳出錯誤訊息,但是之前都是正常可用的,其他建立的Web應用程式也是一樣的情形,請問我該從何處下手?謝謝。
    2009年5月4日 上午 02:34

解答

  • 請檢查是否有下列二支安全性更新
    KB960803,KB963027

    如果有,應該就是它們在做怪....
    我照下列步驟做,就解了我的狀況:
    1.按一下 [開始],按一下 [執行],輸入 regedit,然後按一下 [確定]。
    2.找出並按一下下列子機碼:
       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3.用滑鼠右鍵按一下 [MSV1_0],指向 [新增],然後按一下 [多字串值]。
    4.輸入 BackConnectionHostNames,然後按下 ENTER。
    5.用滑鼠右鍵按一下 [BackConnectionHostNames],然後按一下 [修改]。
    6.在 [數值資料] 方塊中,輸入本機電腦上網站的主機名稱,然後按一下 [確定]。
    7.結束「登錄編輯程式」,然後重新啟動電腦。
    • 已提議為解答 花轟的挨踢 2009年5月6日 上午 05:07
    • 已標示為解答 D.H. _ 2009年5月11日 上午 03:39
    2009年5月6日 上午 05:07
  • :) 我也沒用到IPv6, 可是就是影響到了....而且還讓編目全部失敗了, 因為它認證掛掉,編目就failed
    我原先也想把這二支patches移掉,可是;看了它的內容後決定試試看,所以先用我的測試環境測過後ok,到正式環境上照做一遍解了....
    您的環境可能和我的不同, 所以影響也不太一樣, 移掉或許才是正解 :p
    • 已標示為解答 D.H. _ 2009年5月11日 上午 03:40
    2009年5月11日 上午 03:16
  • 1.移除sql2005
    2.清除sql2005 patches & registry
    3.移除.net framework 2.0 & all about it(包含.net framework 3.0)
    4.退出網域,重新開機
    5.加入網域,重新開機
    6.安裝.net framework 2.0
    7.安裝 sql2005, sp2, sp3
    8.安裝patches
    9.安裝.net framework 3.0
    10.安裝MOSS
    11.使用acronis做image

    這是我上次解完狀況後寫成的SOP, 希望對您有幫助
    • 已標示為解答 D.H. _ 2009年5月15日 上午 02:34
    2009年5月12日 上午 12:23
  • 這.....我印象中,只有在我剛從sps2003升級到moss時有發生過
    當時的解法
    1.檢查search db的檔案安全性是否可讓moss的user存取

    2.是: 到IIS裡的應用程式集區,找到ssp的應用程式,按右鍵選內容,再選"身份識別",把帳號密碼重打一次,再到服務裡,找到Office SharePoint Server Search, Windows SharePoint Services
    Search 這二個services,重打一次帳號和密碼---> 到此應該可解, 如果無解我就不知道該如何做了

    3.否: 加權限, 然後做step2
    • 已標示為解答 D.H. _ 2009年5月21日 上午 10:11
    2009年5月15日 上午 03:07

所有回覆

  • 我最近也有這個問題...不過,我是發生在search和index server上,後來有發現是這部server的認證有問題,暫時先把index改到另一部ap主機,就ok了....
    現在在重新架search server中,外國論壇也有人說這個kerberos的error需要重新加入網域來解

    不過,我有發現我的search server有event id 4, kerberos的錯誤; 不知道您或其他先進有沒有?
    內容如下:

    kerberos 用戶端從伺服器 host/xxxx.11111.com.tw 收到 KRB_AP_ERR_MODIFIED 錯誤。
    使用的目標名稱為 cifs/xxxx.11111.com.tw。這指出用來加密 kerberos 服務票證的密碼
    與目標伺服器上的不同。通常,這是因為目標領域 (11111.COM.TW) 及用戶端
    領域中的電腦帳戶名稱相同。請連絡您的系統管理員

    2009年5月5日 上午 12:55
  • 架好新search ap了....結果仍發生認證的問題.....
    強烈懷疑是最近有什麼os的更新造成ing....
    2009年5月6日 上午 02:43
  • 請檢查是否有下列二支安全性更新
    KB960803,KB963027

    如果有,應該就是它們在做怪....
    我照下列步驟做,就解了我的狀況:
    1.按一下 [開始],按一下 [執行],輸入 regedit,然後按一下 [確定]。
    2.找出並按一下下列子機碼:
       HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\MSV1_0
    3.用滑鼠右鍵按一下 [MSV1_0],指向 [新增],然後按一下 [多字串值]。
    4.輸入 BackConnectionHostNames,然後按下 ENTER。
    5.用滑鼠右鍵按一下 [BackConnectionHostNames],然後按一下 [修改]。
    6.在 [數值資料] 方塊中,輸入本機電腦上網站的主機名稱,然後按一下 [確定]。
    7.結束「登錄編輯程式」,然後重新啟動電腦。
    • 已提議為解答 花轟的挨踢 2009年5月6日 上午 05:07
    • 已標示為解答 D.H. _ 2009年5月11日 上午 03:39
    2009年5月6日 上午 05:07
  • 我的確有安裝上面兩個更新,正在按照你給的方式測試中,請問"輸入本機電腦上網站的主機名稱",就是指主機名稱的意思嗎?譬如MOSSSERVER?
    那會發生這樣的問題,是因為MOSS在認證上出了問題,而其他功能都應該是正常的,所以可以從這方面去找問題了。
    2009年5月11日 上午 01:50
  • 這麼說吧, 假設你的主機host name是mossserver, 但是你的iis 叫moss1, 那麼你要輸入 moss1
    這二支更新影響的是你的iis的virtual web sites name.
    2009年5月11日 上午 01:53
  • 我的host name跟IIS是相同的名稱mossserver,所以我應該沒有打錯,但是還是沒有解決,仍然停在登入驗證視窗,打了三次後就跳出了,請問我可以提供什麼訊息讓你參考呢?謝謝。
    2009年5月11日 上午 02:04
  • ?? 請檢查一下, 在windows\system32\drivers\etc\hosts 裡有沒有moss所加入的一行?
    因為預設值, moss會在這裡加上一行xxx.xxx.xxx.xxx mossserver.ooo.ooo.ooo #moss.....
    我的解法是看那二支patch的說明來的, 說明裡第一個就要人家在hosts裡加入, 我沒打出來是因
    為moss預設值就會在那裡加東西, 所以只要做底下的regedit就可解
    如果沒發現那一行, 那麼請手動加上去
    那如果有沒有解, 那麼我反而建議你先把那二支patches 移掉 :p
    2009年5月11日 上午 02:19
  • 這兩個更新我有去官網看看,都有提到相同的問題,但是是針對IPv6去解決,我沒有用到啊?奇怪了。
    我想先移除這兩個更新看看,實在很不想去修改到系統的參數資料(Reg/Files)。
    2009年5月11日 上午 02:50
  • :) 我也沒用到IPv6, 可是就是影響到了....而且還讓編目全部失敗了, 因為它認證掛掉,編目就failed
    我原先也想把這二支patches移掉,可是;看了它的內容後決定試試看,所以先用我的測試環境測過後ok,到正式環境上照做一遍解了....
    您的環境可能和我的不同, 所以影響也不太一樣, 移掉或許才是正解 :p
    • 已標示為解答 D.H. _ 2009年5月11日 上午 03:40
    2009年5月11日 上午 03:16
  • 目前我移除這兩個更新後,狀況就解除了,可正常登入使用,內容都沒有問題,感謝你的協助。
    1.沒想到問題出在更新上,看來也不能完全相信MS,要準備測試環境才行
    2.請問你是怎麼抓到這個問題點的呢?
    3.一定要同時移除這兩個更新嗎?

    2009年5月11日 上午 03:39
  • 1.我每天都會巡視我的server一次, 在最近發現了這個問題, 可是國內外論壇大家都無解
    2.我的架構是一部ap+db,一部search,有使用virtual web sites name, 可是我發現只有search server有這個問題
    3.我重架了一部新的search server, 架好後沒問題, 可是上了patches後就開始了
    4.所以我開始懷疑最近的更新, 因為在4月底之前, 所有的東西都運作正常
    5.每支更新都去看它的內容,發現這二支和認證有關,於是強烈懷疑是它們,而且二支內容看來差不了多少,所以我也懷疑它們是正相關
    6.開始在測試機上試,試完就解了!
    7.到正式環境上照做,問題解決

    至於是不是一定同時要移掉二支,我沒試過移除,不知....但是我個人直覺認為要,因為二支修正的東西差不了多少,為求系統穩定,還是
    選擇放棄它們比較好
    MS的更新常有這個狀況,我已經遇到太多次了,以前一開始都笨笨的,老是被老闆釘在牆上,可是敝公司有wsus,強制server都要安裝更
    新,所以後來只要系統沒做動作出問題就先做移除更新,然後在測試環境上試過給老闆看,老闆就不釘我了....o_o
    所以,我才會叫花轟的挨踢.....:D

    2009年5月11日 上午 03:55
  • 謝謝你耐心的解答。

    ss183@pchome.com.tw
    這是我的MSN,有機會再跟你請教。
    2009年5月11日 上午 05:09
  • 不客氣,同是IT人員,技術和知識的交流是很重要的
    其實二位版主的blog裡有很多的技術文章,相當精彩,個人每天必到他們的blog裡吸收知識
    建議您也可以到二位版主的blog看看 :)
    2009年5月11日 上午 05:25
  • 再請問一個問題,屬於SQL Server的問題,我是為了MOSS才裝的,應該有關連吧?
    最近在事件檢視器都出現錯誤訊息,在應用程式類別中,稽核失敗/MSSQLSERVER/事件18456,詳情為使用者ABC\Administrator的登入失敗[CLIENT:<local machine>],但是我Administrator帳號是可以登入網域的,請問你有遇到過類似情形嗎?謝謝。
    造成我重新安裝SQL 2005時,就會無法安裝,那MOSS也裝不上去了。
    2009年5月11日 上午 06:18

  • 在我做moss的移機時, 就遇過這個問題, 而且不管怎麼做都是認證不過
    後來,我把sql server全部移掉, 連sql 2005的patches, registry都清掉
    再一步一步重新安裝 sql2005, 並上sp2,sp3後才正常

    比較快的做法是: 用acronis或ghost把乾淨的os還原,然後重灌sql2005
    2009年5月11日 上午 07:44
  • 我有按照你說的方式去做,把SQL Server全部移掉,連patches/registry都清掉,但是還是沒解決,請問可以列出步驟讓我參考嗎?也許我漏掉了某些步驟。

    把os還原比較困難,因為主機上已經安裝很多AP了,當初也沒做image,所以這是最後一招,希望不會用到。
    2009年5月11日 上午 10:57
  • 1.移除sql2005
    2.清除sql2005 patches & registry
    3.移除.net framework 2.0 & all about it(包含.net framework 3.0)
    4.退出網域,重新開機
    5.加入網域,重新開機
    6.安裝.net framework 2.0
    7.安裝 sql2005, sp2, sp3
    8.安裝patches
    9.安裝.net framework 3.0
    10.安裝MOSS
    11.使用acronis做image

    這是我上次解完狀況後寫成的SOP, 希望對您有幫助
    • 已標示為解答 D.H. _ 2009年5月15日 上午 02:34
    2009年5月12日 上午 12:23
  • 請問這兩個更新要移除,是指Windows Server的更新嗎?因為我發現IE也有相同編號的更新,原來安全性更新是有分很多類別的,謝謝。
    2009年5月14日 上午 10:13
  • 是的, 是win2003 server的更新
    2009年5月15日 上午 12:11
  • 移除更新後問題已解決,可以登入共用服務管理網站,謝謝。

    但是又出現新的問題,就是在使用者設定檔及屬性畫面,出現"存取SQL Server資料庫或Office SharePoint Server搜尋服務時發生錯誤",造成設定設定檔匯入無法使用,檢視使用者設定檔仍有早先匯入的資料,請問該如何處理呢?謝謝。
    SQL Server服務是正常的,而搜尋服務也有去檢查過已啟動。
    2009年5月15日 上午 02:33
  • 這.....我印象中,只有在我剛從sps2003升級到moss時有發生過
    當時的解法
    1.檢查search db的檔案安全性是否可讓moss的user存取

    2.是: 到IIS裡的應用程式集區,找到ssp的應用程式,按右鍵選內容,再選"身份識別",把帳號密碼重打一次,再到服務裡,找到Office SharePoint Server Search, Windows SharePoint Services
    Search 這二個services,重打一次帳號和密碼---> 到此應該可解, 如果無解我就不知道該如何做了

    3.否: 加權限, 然後做step2
    • 已標示為解答 D.H. _ 2009年5月21日 上午 10:11
    2009年5月15日 上午 03:07