locked
windows2008 CPU數量顯示問題 RRS feed

  • 問題

  • 硬體:IBM x3950M2 x2 兩台串接成一座

    CPU總數:6核心x8

    記憶體總數:64GB

    OS版本:windows2008 64bit ent sp2

    安裝完成之後 在裝置管理員看到48顆CPU

    系統資訊裡面 看到四顆六核CPU(應該要八顆)

    效能監視器只看到CPU核心總數為24核

    不知有何解決方法

    2010年6月30日 下午 04:49

解答

  • 這問題 後來找到答案了 , 詳解如下

     

     

    Microsoft Windows Server 2008 x64 does not show all processors under task manager - IBM System x3950 M2 (7233, 7234)

    http://www-947.ibm.com/support/entry/portal/docdisplay?brandind=5000008&lndocid=MIGR-5079202

    Microsoft Windows x64 2008 Enterprise and Standard Server Edition may not show all processors within Task Manager with Intel 6-core processors installed.

    To see all of the processors within the Operating System (OS), set the Central Processing Unit (CPU) Option from Logical Destination Mode (default) to Physical Destination Mode on each server / node in the server configuration.

    Workaround:

    1.    Press F1 to enter BIOS Setup.

    2.    Select Advanced Setup.

    3.    Select CPU option.

    4.    Select Clustering Technology.

    5.    Change the option from Logical to Physical.

    6.    Configure all system nodes with the same setting.

    7.    Boot into Windows Server x64 2008

    • 已標示為解答 yitse 2010年7月22日 上午 03:06
    2010年7月22日 上午 03:06
  • 請你安裝下面Hotfix看看是否改善

    Performance is slow on a multiprocessor computer that is running Windows Server 2008 or Windows Vista
    http://support.microsoft.com/kb/969468/en-us

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    • 已提議為解答 Vincent Lin 2010年7月5日 上午 10:10
    • 已標示為解答 Vincent Lin 2010年7月12日 上午 01:35
    • 已取消標示為解答 Vincent Lin 2010年7月22日 上午 03:21
    • 已取消提議為解答 Vincent Lin 2010年7月22日 上午 03:21
    • 已標示為解答 Vincent Lin 2010年7月22日 上午 03:22
    2010年7月1日 上午 06:46

所有回覆

  • 那工作管理員的效能標籤下看到的CPU數量是多少?

    請你執行一下 msconfig - 開機 - 進階選項 , 看裡面是否有勾選到CPU數目的選項 , 有的話將他取消勾選看看

    另外 , 你是透過什麼方式將兩台機器串成一台?

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年7月1日 上午 04:05
  • 那工作管理員的效能標籤下看到的CPU數量是多少?  24

    請你執行一下 msconfig - 開機 - 進階選項 , 看裡面是否有勾選到CPU數目的選項 , 有的話將他取消勾選看看 : 試過了 還是只有24

    另外 , 你是透過什麼方式將兩台機器串成一台 : IBM X3950M2 本身就是可以堆疊的機器 , 最多可以堆疊到四座..

     

    2010年7月1日 上午 05:23
  • 請你安裝下面Hotfix看看是否改善

    Performance is slow on a multiprocessor computer that is running Windows Server 2008 or Windows Vista
    http://support.microsoft.com/kb/969468/en-us

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    • 已提議為解答 Vincent Lin 2010年7月5日 上午 10:10
    • 已標示為解答 Vincent Lin 2010年7月12日 上午 01:35
    • 已取消標示為解答 Vincent Lin 2010年7月22日 上午 03:21
    • 已取消提議為解答 Vincent Lin 2010年7月22日 上午 03:21
    • 已標示為解答 Vincent Lin 2010年7月22日 上午 03:22
    2010年7月1日 上午 06:46
  • 剛剛試過了 這個PATCH 版本不合
    2010年7月1日 上午 08:47
  • 請你檢查一下下面檔案的檔案版本 , 並把版本號碼列貼上來看看 (右鍵 - 內容 - 詳細資料 - 檔案版本)

    C:\windows\system32\hal.dll
    C:\windows\system32\Ntoskrnl.exe

    另外 , 你安裝的Hotfix檔名為何? 你的系統應該是Server 2008 不是 Server 2008 R2吧?

    PS:麻煩將不能安裝的完整錯誤訊息也提供一下

    Thanks


    不管問題有沒有解決..麻煩都回來回報一下..對回答者也算是一種尊重:)
    微軟技術支援網站
    2010年7月1日 上午 09:23
  • 這問題 後來找到答案了 , 詳解如下

     

     

    Microsoft Windows Server 2008 x64 does not show all processors under task manager - IBM System x3950 M2 (7233, 7234)

    http://www-947.ibm.com/support/entry/portal/docdisplay?brandind=5000008&lndocid=MIGR-5079202

    Microsoft Windows x64 2008 Enterprise and Standard Server Edition may not show all processors within Task Manager with Intel 6-core processors installed.

    To see all of the processors within the Operating System (OS), set the Central Processing Unit (CPU) Option from Logical Destination Mode (default) to Physical Destination Mode on each server / node in the server configuration.

    Workaround:

    1.    Press F1 to enter BIOS Setup.

    2.    Select Advanced Setup.

    3.    Select CPU option.

    4.    Select Clustering Technology.

    5.    Change the option from Logical to Physical.

    6.    Configure all system nodes with the same setting.

    7.    Boot into Windows Server x64 2008

    • 已標示為解答 yitse 2010年7月22日 上午 03:06
    2010年7月22日 上午 03:06