locked
請問如何在 autounattend.xml 內指定安裝 Windows Server 2008 的版本? RRS feed

  • 問題

  • 請問如何在 autounattend.xml 內指定安裝 Windows Server 2008 的版本?
    2010年7月27日 上午 04:10

解答

  • Hi,

    In Windows Server 2008, you need an additional entry in the unattend.xml to automate the selection of the edition.  

    The following entry is required:

    Microsoft-Windows-Setup\ImageInstall\OSImage\Installfrom.

    You can use one of the following for the metadata:

    /Image/Index
    /Image/Name
    /Image/Description

    It is up to you to decide which one to use. Name might be the better one since this will not change. Image numbers could change in a image although if you are working with default install.wim they won't change. The default install.wim has the following images

     <IMAGE INDEX="1"><NAME>Windows Longhorn SERVERSTANDARD</NAME>
    <IMAGE INDEX="2"><NAME>Windows Longhorn SERVERENTERPRISE</NAME>
    <IMAGE INDEX="3"><NAME>Windows Longhorn SERVERDATACENTER</NAME>
    <IMAGE INDEX="4"><NAME>Windows Longhorn SERVERSTANDARDCORE</NAME>
    <IMAGE INDEX="5"><NAME>Windows Longhorn SERVERENTERPRISECORE</NAME>
    <IMAGE INDEX="6"><NAME>Windows Longhorn SERVERDATACENTERCORE</NAME>

    So for example, if you want to install Windows Longhorn Server Standard, the .XML would look like this:

    <ImageInstall>
    <OSImage>
    <InstallFrom>
    <MetaData wcm:action="add">
    <Key>/IMAGE/INDEX</Key>
    <Value>1</Value>
    </MetaData>
    </InstallFrom>
    <InstallToAvailablePartition>true</InstallToAvailablePartition>
    </OSImage>
    </ImageInstall>

    thx!


    Microsoft MVP for Windows Server-Networking, MCT, http://msmvps.com/blogs/richardwu
    • 已標示為解答 dogdogbb 2010年7月27日 上午 08:14
    2010年7月27日 上午 04:12