none
SQL SERVER 2005 的 JDBC Driver 是否支援 SQL Server 2008 資料庫的連結 RRS feed

  • 問題

  •  

    各位先進好:

     

    我有一個Java程式其連結資料庫為 SQL SERVER 2005 ,可正常執行,

    如今我改連結 SQL SERVER 2008 , 則出現

    com.microsoft.sqlserver.jdbc.SQLServerException: 不支援此伺服器版本。目標伺服器必須是 SQL Server 2000 或更新版本。
    的錯誤訊息,

    其發生點是在呼叫 DriverManager.getConnection(dbUrl, saUid, saPwd); 的函式時出現的,

    是否 SQL Server 2005 的 JDBC Driver 不支援 SQL Server 2008,

    可是我在網路上又查不到  SQL Server 2008 JDBC Driver 的相關資料,

    還是我什麼地方需要改正, 請不吝指導, 謝謝!

     

     

    2008年9月30日 上午 07:48

解答

所有回覆