locked
Hyper-V 安裝整合性服務錯誤 RRS feed

  • 一般討論

  • 各位先知:

    小弟昨日遇到一個怪問題,我已經轉換過好幾台Server VHD並裝好整合性服務,但是偏偏有一台在安裝整合性服務時會報錯,找遍所有網路都沒有相關文件,

    主要是安裝整合性服務時會報錯,錯誤如下 :

    用Domaiin Admin帳戶安裝整合性服務的話會出現 :更新處理傳回錯誤碼1625

    用Local Admin帳戶安裝整合性服務的話會出現 :更新處理傳回錯誤碼1630

    各位大大有無遇過這樣情況?煩請指點一下小弟

    PS : 剛看到論壇有另一位有育過相同問題,雖然有解決了,但未提供解決方式.....

    文章連結如下 : http://social.technet.microsoft.com/Forums/zh-TW/windowsserver2008zhcht/thread/2e1f9227-eca5-49de-8db8-a49c20047121/

    2012年2月11日 上午 04:03

所有回覆

  • Hi

    方便拍張圖放上來給大家看嗎?

    以及是在安裝到哪一個階段時會發生錯誤?

    是升級HAL還是Storport...?

    以及您的Windows Installer Services是否可正常Work?

    Hyper-V Integration Services會透過DISM Package的方式更新,會需要用到Windows Installer

    以及Event Log可否稍微檢查一下是否有其它錯誤訊息?

    您的錯誤碼比較像是msi所回傳的error log

    建議您先朝這方向試一下,再上傳一些比較詳細的資訊


    Best Regards, Daniel Liang

    2012年2月12日 下午 12:47
  • Hi 菜鳥工程師

    你可以先更新後再安裝整合元件因為之前在Vista的時候有出現類似的狀況

    不過後來更新後再安裝整合元件問題就解決了

    2012年2月13日 上午 04:02
  • 我昨日也遇到相同問題, 要你先升級hal 後重開機 再安裝整合服務, 但就出現類似1625 的錯誤訊息

    也已經windows update 到沒有可以更新了 , 後來透過另一個方式重新移轉P2V 再安裝整合服務就OK 了  

    2012年2月15日 上午 01:21
  • 01.Windows Installer Service 可正常WorK

    02.已經升級HAL及Storport,但是在安裝"虛擬元件"後立即跳出1603錯誤

    2012年2月15日 下午 01:20
  • Hi

    麻煩您做以下測試,看能不能解決您的問題

    如果環境允許,請您先快照一份起來

    第一個方法:

    請確認環境變數裡的TEMP跟TMP目錄是確實存在的

    系統變數的預設路徑是C:\Windows\Temp

    並確認C:\Windows\Temp是個存在的路徑,而且SYSTEM對該資料夾有【完全控制】的權限

    然後重新啟動後再安裝看看

    第二個方法:(Windows 2008 or Vista適用)

    開始→執行→MSCONFIG→【開機】頁籤→進階選項→刪除HAL

    然後重新啟動後再安裝看看

    第三個方法:

    刪除或重新命名以下兩個檔案

    C:\WINDOWS\system32\DRIVERS\wdf01000.sys
    C:\WINDOWS\system32\DRIVERS\wdfldr.sys

    無法刪除或重新命名,請使用WinPE去刪除或命名 

    然後重新啟動後再安裝看看

    請記得,環境允許下,先快照一份,第一個方法沒風險,可以先試看看

    如果還是沒辦法解決,請提供一下幾個在C:\Windows底下的Log檔讓大家參考一下

    setupact.log、vmguestsetup.log,還有在C:\Windows\********Inst.log


    Best Regards, Daniel Liang


    2012年2月15日 下午 05:47