none
兩台Exchange 2010 (擁有三合一),一台在大陸,一台在台灣(對外的出口) 郵件路由問題 RRS feed

  • 問題

  • 請問各位:

    之前我們是在大陸跟台灣各有一台Exchange 2003 ,兩邊為同一個site ,台灣安裝 Exchange 2010(三合一) 並將台灣的2003

    user 都轉移到新的Exchange 2010 ,這部分都OK

    後來在大陸安裝好另一台Exchange 2010(三合一),問題就出現了,發現台灣的user寄給其他台灣的user 都很慢,

    但寄到大陸或外面,或是人家寄進來都很快,查看郵件詳細資料發現台灣寄給台灣的user 竟然都會先到大陸的Exchange

    2010 再寄回來的感覺,有時又會正常,是因為同一個site ,Exchange 2010 會自己決定要從哪邊走嗎??

    但自己寄給自己都會從大陸再寄過來(真的很怪) ,有辦法讓他路徑正常嗎?  台灣是對外的出口

    還是說要將大陸的DC規劃到另一個site ? 請大家賜教,感恩~~

     

     說明:

     台灣2010到大陸2010正常很快,大陸2010到台灣2010正常很快,大陸 2003 到另兩台也都很快

     就只有台灣2010 到台灣2010 的user 有問題

     

     

     

     


    • 已編輯 shihfeng 2012年1月13日 上午 10:19
    2012年1月13日 上午 10:12

解答

所有回覆

  • Hi,

    當初在建置台灣第一台 Exchange 2010 時,應該會建立一個 Routing Group Connector, 請檢查一下 Bridgehead Server 看看

    另外,Exchange Server 2010 的路由是參考 AD Site, 建議你把 Site 切出來吧 !

     

    Regards,
    Lingo Chiang

     

     


    ~以無法為法,以無限為限~不在線上就在羽球館
    2012年1月13日 下午 02:18
    版主
  • Dear Lingo

    我覺得您說的對!可是我也有一些搞不懂,如果同一台Exchange 2010裡面的User互寄,實在沒道理路由出去?怎麼都想不懂>_<


    Alex Hung
    2012年1月13日 下午 05:02
  • Hi,

    當初在建置台灣第一台 Exchange 2010 時,應該會建立一個 Routing Group Connector, 請檢查一下 Bridgehead Server 看看

    另外,Exchange Server 2010 的路由是參考 AD Site, 建議你把 Site 切出來吧 !

     

    Regards,
    Lingo Chiang

     

     


    ~以無法為法,以無限為限~不在線上就在羽球館


    1. bridgehead 那邊目前是大陸那台,但之前是台灣那邊2010,還是有一樣的狀況

        且如果是台灣那台2010 , 有時也會發生大陸2003 轉道大陸2010 時會透過台灣的  

           2010 在過去 變得很慢,所以現在為了移轉大陸2003 才轉到大陸那邊的2010 跟大

         陸的2003 建立RCG ,台灣2010 跟台灣2003 的RCG 已經刪除

    2. 那如果已經安裝好2010 後,再切site 有甚麼要注意的嗎?

    感謝你的回覆

     

     


    • 已編輯 shihfeng 2012年1月14日 上午 02:51
    2012年1月14日 上午 02:48
  • Dear Lingo

    我覺得您說的對!可是我也有一些搞不懂,如果同一台Exchange 2010裡面的User互寄,實在沒道理路由出去?怎麼都想不懂>_<


    Alex Hung


        是阿~~就是這樣,我也覺得很怪,另外發現大陸那台寄到大陸自己好像有時也會從台灣寄過去

        再寄回大陸,只是速度還ok  台灣就特別慢

    2012年1月14日 上午 02:50
  • Hi,

    檢查一下 Exchange 2003 的路由群組裡面的成員有哪幾台 ? 如果可以,把圖放上來看一下, Thanks !

     

    Regards,
    Lingo Chiang


    ~以無法為法,以無限為限~不在線上就在羽球館
    2012年1月14日 上午 03:50
    版主
  •  

    Dear Lingo:

     

    另外這是台灣2010 寄給自己,郵件詳細資料

    Received: from TWMS01.abc.com.tw ([10.5.1.10]) by CNMS01.abc.com.tw
     ([10.5.131.15]) with mapi id 14.01.0339.001; Fri, 13 Jan 2012 17:20:14 +0800

    Content-Type: application/ms-tnef; name="winmail.dat"
    Content-Transfer-Encoding: binary
    From: user <user@abc.com.tw>
    To: user <user@abc.com.tw>
    Subject: aaa
    Thread-Topic: aaa
    Thread-Index: AczR1IudQpT9T5BoSr6umqqcOYVrOg==
    Date: Fri, 13 Jan 2012 17:20:09 +0800
    Message-ID: <164483366C416245910E5C6A3852EAAF42AE63@TWMS01.abc.com.tw>
    Accept-Language: zh-TW, en-US
    Content-Language: zh-TW
    X-MS-Has-Attach:
    X-MS-Exchange-Organization-SCL: -1
    X-MS-TNEF-Correlator: <164483366C416245910E5C6A3852EAAF42AE63@TWMS01.abc.com.tw>
    MIME-Version: 1.0
    X-MS-Exchange-Organization-AuthSource: CNMS01.abc.com.tw
    X-MS-Exchange-Organization-AuthAs: Internal
    X-MS-Exchange-Organization-AuthMechanism: 04
    X-Originating-IP: [10.5.8.62]
    X-MS-Exchange-Organization-AVStamp-Mailbox: SMEXkv@];870300;0;This mail has
     been scanned by Trend Micro ScanMail for Microsoft Exchange;

     

    2012年1月14日 上午 04:18
  • 我有一個猜想:有沒有可能mailboxdatabase所使用的rpc client access server不在同一台,就有可能造成這情境。

    確認方法:

    Get-MailboxDatabase -Server twms01|ft name,rpcclientaccessserver

    執行後,如果rpcclientaccessserver有不是twms01的,那就是這個問題了。

    修正方法:

    Get-MailboxDatabase -Server twms01|Set-MailboxDatabase -RPCClientAccessServer twms01
    接著需要在使用者的電腦=>[控制台]=>[郵件]=>outlook 設定檔中使用[修復]功能。(適用outlook 2010 & 2007,若outlook 2003則需要重建outlook profile)


    Alex Hung
    2012年1月14日 上午 04:42
  • 我有一個猜想:有沒有可能mailboxdatabase所使用的rpc client access server不在同一台,就有可能造成這情境。

    確認方法:

    Get-MailboxDatabase -Server twms01|ft name,rpcclientaccessserver

    執行後,如果rpcclientaccessserver有不是twms01的,那就是這個問題了。

    修正方法:

     

    Get-MailboxDatabase -Server twms01|Set-MailboxDatabase -RPCClientAccessServer twms01
    接著需要在使用者的電腦=>[控制台]=>[郵件]=>outlook 設定檔中使用[修復]功能。(適用outlook 2010 & 2007,若outlook 2003則需要重建outlook profile)

     


    Alex Hung

    [PS] C:\Windows\system32>Get-MailboxDatabase -Server twms01|ft name,rpcclientaccessserver

    Name                                                        RpcClientAccessServer
    ----                                                        ---------------------
    Mailbox Database 0362587239                                 TWMS01.abc.com.tw


    [PS] C:\Windows\system32>
    [PS] C:\Windows\system32>Get-MailboxDatabase -Server cnms01|ft name,rpcclientaccessserver

    Name                                                        RpcClientAccessServer
    ----                                                        ---------------------
    SZ-MailDB                                                   CNMS01.abc.com.tw

     

    目前看到的好像都是正確的



    • 已編輯 shihfeng 2012年1月14日 上午 05:59
    2012年1月14日 上午 05:56
  • 在使用者的電腦,畫面右下角有個Outlook的小圖示,按著ctrl + 滑鼠右鍵,選擇連線狀態,看一下outlook是否正確地連接台灣的主機。
    Alex Hung
    2012年1月14日 上午 06:41
  • 這部分是正常連接的,我連用owa 寄給自己也是一樣的狀況,忽快忽慢

    快的就是連到台灣,慢的就是連到大陸

    2012年1月14日 下午 02:28
  • Hi,

    Routing Group Connector 有缺喔 !! 兩邊都要有才可以 !!

     

    Regards,
    Lingo

     

     


    ~以無法為法,以無限為限~不在線上就在羽球館
    2012年1月14日 下午 02:33
    版主
  • Hi,

    Routing Group Connector 有缺喔 !! 兩邊都要有才可以 !!

     

     

    Regards,
    Lingo

     

     


    ~以無法為法,以無限為限~不在線上就在羽球館

    Sorry,那張圖忘了按重新整理,實際有的

    2012年1月14日 下午 02:47
  • Dear All:

    我後來在網路上找到這個文章

    http://johnnyyao.blogspot.com/2010/11/ref-exchange-2007-hub-issue.html

    參考上面的指令在

    Set-MailboxServer -Identity twms01 -SubmissionServerOverrideList twms01

    Set-MailboxServer -Identity cnms01 -SubmissionServerOverrideList cnms01

    重啟transport 跟郵件提交兩個服務

    目前看來好像正常,持續觀察中....

     

     

    • 已標示為解答 shihfeng 2012年1月16日 上午 10:31
    2012年1月14日 下午 03:58