none
[IE 6 WPAD] Auto-clear / Always refresh "DefaultConnectionSettings" and "SavedLegacySettings"

    問題

  • As IE 6 will remember the WPAD URL in IP format in registry value "DefaultConnectionSettings", "SavedLegacySettings" and doesn't refresh the URL until the "Automatic Detec Proxy" setting is toggled OR the above registry values are deleted. (http://technet.microsoft.com/en-us/library/cc302643.aspx#WPADFileIssues)

    Is it possible to configure Internet Explorer 6 to clear these registry values upon browser exit or force IE 6 to refresh WPAD URL automatically.

    [HKEY-CURRENT-USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections]
    values: DefaultConnectionSettings and SavedLegacySettings

    Many thanks!

    • 已編輯 ckumark 2009年6月26日 下午 07:08 Fixing thread title bug
    2009年6月18日 下午 04:12

解答

  • 想到一個方法是透過執行一個batch file..在開啟IE之前先將那兩個機碼值刪除
    你可以測試看看..是否可以達到你的要求

    batch file 內容如下
    ---------------------------------------------------------------------------
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v DefaultConnectionSettings /f
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v SavedLegacySettings /f
    @start "" /b "C:\Program Files\Internet Explorer\iexplore.exe" %*
    • 已提議為解答 Vincent Lin 2009年6月22日 上午 10:18
    • 已標示為解答 Vincent Lin 2009年6月24日 上午 04:45
    2009年6月19日 上午 03:00
  • 應該是沒有hotfix或是其他作法可以解決此問題
    Technet上面的文章有提到此問題的一些workaround

    WPAD file issues
    http://technet.microsoft.com/en-us/library/cc302643.aspx#WPADFileIssues

    看裡面的 "Latest Wpad.dat Information Is Not Being Applied" 問題

    1.Clear or select the Automatically detect settings option.
    2.Execute the Autoproxutil tools in a logon script.
    3.Delete the DefaultConnectionSettings and SavedLegacySettings registry keys.

    • 已編輯 Vincent Lin 2009年6月22日 上午 03:32
    • 已提議為解答 Vincent Lin 2009年6月22日 上午 10:18
    • 已標示為解答 Vincent Lin 2009年6月24日 上午 04:45
    2009年6月22日 上午 03:30

所有回覆

  • 想到一個方法是透過執行一個batch file..在開啟IE之前先將那兩個機碼值刪除
    你可以測試看看..是否可以達到你的要求

    batch file 內容如下
    ---------------------------------------------------------------------------
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v DefaultConnectionSettings /f
    reg delete "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections" /v SavedLegacySettings /f
    @start "" /b "C:\Program Files\Internet Explorer\iexplore.exe" %*
    • 已提議為解答 Vincent Lin 2009年6月22日 上午 10:18
    • 已標示為解答 Vincent Lin 2009年6月24日 上午 04:45
    2009年6月19日 上午 03:00
  • That's a great idea.

    But are there any special hotfix or registry setting to correct this issue?

    Thanks again for your great idea!!!
    2009年6月19日 下午 04:23
  • 應該是沒有hotfix或是其他作法可以解決此問題
    Technet上面的文章有提到此問題的一些workaround

    WPAD file issues
    http://technet.microsoft.com/en-us/library/cc302643.aspx#WPADFileIssues

    看裡面的 "Latest Wpad.dat Information Is Not Being Applied" 問題

    1.Clear or select the Automatically detect settings option.
    2.Execute the Autoproxutil tools in a logon script.
    3.Delete the DefaultConnectionSettings and SavedLegacySettings registry keys.

    • 已編輯 Vincent Lin 2009年6月22日 上午 03:32
    • 已提議為解答 Vincent Lin 2009年6月22日 上午 10:18
    • 已標示為解答 Vincent Lin 2009年6月24日 上午 04:45
    2009年6月22日 上午 03:30