none
2003昇級至2010公用資料夾複寫問題 RRS feed

  • 問題

  • 請教各位前輩,小弟執行Exchange 2003昇級至2010,但公用資料夾複寫時,如下附圖

    相關的資訊如下:

    1. 在Exchange 2003系統管理員中,可將其公用資料夾(含子資料夾)設定複寫至Exchange 2010 MBX (CNEXGMBX01,CNEXGMBX02)

    2. 在Exchange 2010公用資料夾管理主控台的預設公用資料夾內,未看到產生的階層清單

    3. 自06/22設定複寫後,已經過三天,然未看見階層清單,有重新試著"更新階層架構",但是同樣的情況

    可以有何方式能查明或排除此問題呢??

    感謝~~

     

    2012年6月25日 上午 06:40

解答

  • Dear Johnny_Yao & AskaSU:

             感謝兩位前輩的回覆,目前看起來E2K3的公用資料夾階層已有複寫至E2k10了,說明一下小弟找到及處理的方式

             在Exchange E2K3採用FE/BE的架構,在路由群組中成員,其FE Server (CNEXGFE)原為"主要"

             而Exchange E2K3與E2K10其路由連線設定為E2K3 BE Server (CNEXGBE01) <=> E2K10 MBX Server (CNEXGMBX01)

             將E2K3的路由群組成員,改其CNEXGBE01設定為"主要"後,發現CNEXGBE01主機佇列清空,再查看CNEXGMBX01,重新更新階層架構後

             可以看到公用資料夾階層了 (連帶E2K3寄送至E2K10的使用者信件,也有收到)

            目前尚在繼續觀察,後續再設定每層資料夾的複寫,看是否會有問題

            非常感謝兩位的協助~~~

          


      


    • 已提議為解答 AChange 2012年6月27日 上午 07:02
    • 已編輯 Pinno 2012年6月27日 上午 07:16
    • 已標示為解答 AChange 2012年6月28日 上午 08:29
    2012年6月27日 上午 07:01

所有回覆

  • 從網路找到另一篇類似的問題:http://social.technet.microsoft.com/Forums/zh-TW/exchangezhcht/thread/a1877529-0713-41fa-a292-e5195daaf6f9

    要從Exchange 2010執行指令:

    .\AddReplicaToPFRecursive.ps1 -server "Exchange 2010 Server" -TopPublicFolder "\" -ServerToAdd "Exchange 2010 Server"

    依指令所示應修改為如下嗎:(由於為正式區環境,所以還是希望確認一下)

    .\AddReplicaToPFRecursive.ps1 -server "CNEXGMBX01" -TopPublicFolder "\" -ServerToAdd "CNEXGMBX01"

    感謝~~

    補充:剛才大膽試了一下,執行後並沒有錯誤訊息,但仍未看清單????????


    • 已編輯 Pinno 2012年6月25日 上午 09:37 補充說明
    2012年6月25日 上午 09:14
  • 試著到 Exchange 2010 的管理介面中去看公用資料夾,
    詳細操作可以參考 TechNet 文件庫的資料:管理公用資料夾

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2012年6月25日 上午 09:43
    版主
  • Dear AskaSu:

           感謝您的回覆,再次確認了一次,連線的主機也沒有錯誤,附圖是目前執行的結果.....

           感謝您~~

           

    2012年6月25日 上午 09:55
  • 建議先參考那篇部落格文章中的資料,
    把 Update 及相關檢查步驟做一次看看。 :)


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2012年6月25日 上午 10:03
    版主
  • Dear AskaSu:

            感謝您的回覆,抱歉,擔誤您的時間,那篇文章所提述的內容,小弟大致說明如下

            Step 1: AddReplicaToPFRecursive.ps1有執行過了,Update-PublicFolderHierarchy也有執行許多次

        Step 2:此步驟未執行,主要是移動Exchange 2003公用資料夾複本至2010上,但目前這動作小弟是放在要移除Exchange 2003 Server才執

        在整個昇級的程序,小弟有先在測試區驗證過,相同的架構,Exchange 2003架構上安裝2010後,在2010上的公用資料夾管理員,就可以看到公用資

        料夾的階層構,然後先設定每層資料夾的複寫,在整個使用者信箱昇級完成後,在移動公用資料夾複本至2010

        但不解的是在正式區安裝後,卻看不到??...小弟不解哪有環節或設定有誤,還請前輩賜教....

        感謝您~~

    2012年6月25日 上午 10:24
  • 別說耽誤,這是開放論壇本來就是一起討論問題 :)

    我剛想到,CNEXGMBX01,CNEXGMBX02 跟 Exchange 2003 都是在同一個網段的網路嗎?
    會不會是防火牆阻擋了複寫?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2012年6月26日 上午 02:44
    版主
  • Dear AskaSu:

          在不同的網段,但基本上都是內部Server網段都是全通的,

          以下是相關的網段資訊:

          CNEXGMBX01 (10.2.3.x) Exchange 2010 STD SP2 (Rollup 2)

         CNEXGMBX02 (10.3.1.x) Exchange 2010  STD SP2(Rollup 2)

         C1SPMS01 (10.1.5.x) Exchange 2003 STD SP2

         CNEXGBE (10.2.1.x) Exchange 2003  STD SP2

         一直查了很多的資訊,也不斷的一直在更新階層指令,但仍舊未見其階層,但在先前於測試環境的在Exchange 2010安裝完就可以看到的階層架構

        但目前還是沒什麼頭緒

        感謝您~~~

    2012年6月26日 上午 03:55
  • 1. EMS>Get-PublicFolder -Recurse | fl name, replicas

    上面這個run 看看結果

    2. 看E2010 上 Public folder store 的replication schedule 設定有沒有調過


    Johnny_Yao

    2012年6月26日 上午 08:27
  • Dear Johnny_Yao:

            感謝您的回覆,相關的說明如下,煩請參閱

            1. 指令執行的結果,如附圖所示

                同樣的指令在小弟使用的測試區執行,可以看到每個階層複寫的公用資料夾

            2. 小弟不是很懂這裡所指的設定為何??目前在公用資料夾管理員所看到的內容如下圖所示(基本上都採用預設值)

     感謝您的回覆~~~~



    • 已編輯 Pinno 2012年6月26日 上午 08:51
    2012年6月26日 上午 08:43
  • 1. Run 下面這個

    .\AddReplicaToPFRecursive.ps1 -Server "E2K3 Server" -TopPublicFolder "台北辦公室" -ServerToAdd  "E2K10 Server"

    2. Replication Schedule,
    從 EMC - Organization Configuration - Mailbox - Database Management - Public Folder Database 去看


    Johnny_Yao

    2012年6月26日 上午 08:58
  • Dear Johnny_Yao:

            執行的結果如下,感謝您~~:

           1. 指令執行(CNEXGBE01是2003 Server STD SP2, CNEXGMBX01是2010 Server STD SP2)

               

          2. 複寫設定(預設值)



    • 已編輯 Pinno 2012年6月26日 上午 09:15
    2012年6月26日 上午 09:15
  • 抱歉! 有錯,此步驟應該不適用您的問題了

    .\AddReplicaToPFRecursive.ps1 -Server "E2K10 Server" -TopPublicFolder "台北辦公室" -ServerToAdd  "E2K10 Server"

    接著可以確認mail flow

    1. E2K3<->E2K10 RGC 是否正常運作,郵件可往來傳輸? 

    2. 此RGC 上的E2K3 source server 的queue message 狀態? ESM 看郵件佇列



    Johnny_Yao

    • 已提議為解答 AChange 2012年6月27日 上午 07:03
    2012年6月27日 上午 02:39
  • Dear Johnny_Yao:

            感謝您的回覆~~

            1. 指令執行的結果如下:(之前有跑過這個指令,但是執行沒有問題,但現在執行卻....@@?)           

           2. 檢查Exchange 2003 Server (CNEXGBE01)發現佇列中有許多信件,看起來像關於公用資料夾更新的信件??

               

    2012年6月27日 上午 03:11
  • 那應可歸納為mail flow問題

    E2K3<>E14 兩端信箱可互寄郵件嗎? 

    可能E14 default connector 有改過權限設定導致

    先get-RoutingGroupConnector 確認一下存在E14<-->E2K3 雙向RGC存在


    Johnny_Yao

    2012年6月27日 上午 03:16
  • Dear Johnny_Yao:

             感謝您~~

             1. E14???指的是E2K10???...

                 兩端信箱還沒互寄信件過,因為還沒有轉移使用者的信箱,待會我馬上建一個測試帳號來驗證

            2. default connector基本上沒動過什麼權限,指令執行結果如下,雙向的路由群組皆有建立

    補充說明:

    測試E2K3 <=>E2K10信箱互寄結果

    1. E2K10 User 可寄信至 E2K3 User

    2. E2K3 User 可送出信件,但E2K10 User未收到?? 

    • 已編輯 Pinno 2012年6月27日 上午 03:50
    2012年6月27日 上午 03:30
  • Dear Johnny_Yao & AskaSU:

             感謝兩位前輩的回覆,目前看起來E2K3的公用資料夾階層已有複寫至E2k10了,說明一下小弟找到及處理的方式

             在Exchange E2K3採用FE/BE的架構,在路由群組中成員,其FE Server (CNEXGFE)原為"主要"

             而Exchange E2K3與E2K10其路由連線設定為E2K3 BE Server (CNEXGBE01) <=> E2K10 MBX Server (CNEXGMBX01)

             將E2K3的路由群組成員,改其CNEXGBE01設定為"主要"後,發現CNEXGBE01主機佇列清空,再查看CNEXGMBX01,重新更新階層架構後

             可以看到公用資料夾階層了

            目前尚在繼續觀察,後續再設定每層資料夾的複寫,看是否會有問題

            非常感謝兩位的協助~~~

          


      

    2012年6月27日 上午 07:01
  • Dear Johnny_Yao & AskaSU:

             感謝兩位前輩的回覆,目前看起來E2K3的公用資料夾階層已有複寫至E2k10了,說明一下小弟找到及處理的方式

             在Exchange E2K3採用FE/BE的架構,在路由群組中成員,其FE Server (CNEXGFE)原為"主要"

             而Exchange E2K3與E2K10其路由連線設定為E2K3 BE Server (CNEXGBE01) <=> E2K10 MBX Server (CNEXGMBX01)

             將E2K3的路由群組成員,改其CNEXGBE01設定為"主要"後,發現CNEXGBE01主機佇列清空,再查看CNEXGMBX01,重新更新階層架構後

             可以看到公用資料夾階層了 (連帶E2K3寄送至E2K10的使用者信件,也有收到)

            目前尚在繼續觀察,後續再設定每層資料夾的複寫,看是否會有問題

            非常感謝兩位的協助~~~

          


      


    • 已提議為解答 AChange 2012年6月27日 上午 07:02
    • 已編輯 Pinno 2012年6月27日 上午 07:16
    • 已標示為解答 AChange 2012年6月28日 上午 08:29
    2012年6月27日 上午 07:01