none
RWW Error RRS feed

  • 一般討論

  • I have SBS 2008 setup with RWW.  I'm able to access the internal website  and OWA just fine.  When I try to RDP via RWW I get this error

    VBScript: Remote Desktop Disconnected
    An internal error has occurred (error 50331676).  For more information please contact your network administrator or Microsoft Product Support.

    I can connect this way if I'm internal to my network.  It is when I come from the out side that I get this error.  I'm also getting an error in TS Logs:

    Event ID 641:  TS Gateway Network access Policy engine received failure from IAS and the error was "16388"
    and
    Event ID 201:  The user "domain\username", on client computer "24.***.***.***", did not meet connection authorization policy requirements and was therefore not authorized to access the TS Gateway server. The following authentication method was attempted: "NTLM". The following error occurred: "23003".

    I have done a lot of research about this error and am unable to find a resolution.

    Please Help!

    Thanks,

    Nick

    2009年2月11日 下午 02:36

所有回覆

  • I'm having the same issue. My SBS 2008 server has been in operation for two weeks and the rww was working fine. This is not certificate problem as the self-signed certificate has been installed and it did work fine. I just rebooted the server, restarted the TS gateway service and the rww worked for a short while before failing. I can reach owa and the intranet page. But I get the "internal error 50331676" when trying to access any computer on the network. I'm wondering if this is a network policy problem?
    2009年2月12日 上午 06:31
  • I don't think it is certificate related either.  I have used the internal signed and now have a go-daddy certificate installed.
    2009年2月13日 下午 12:49
  • Have you received any response to your question?  We are having the same issue with no joy.
    Robert Brandenburg
    2009年3月22日 下午 07:55
  • I have yet to receive an answer.
    2009年3月23日 下午 12:28
  • Any Luck Yet ?

    Seeing the same problem, works fine for some remote users, some specific users have the same problem.
    Developer / Sys Admin / Director MS Gold Partner Firm.
    2009年4月9日 上午 02:10
  • Here is a transcript of how Microsoft had me go after and solve this problem  (note the bolded entries):

    PROBLEM: unable to browse rww
    CAUSE:

    RESOLUTION:

    installed certificate on clients and tried again no go

    checked terminal service gateway console there were three unknown policies hitting under tsgateway matched with my lab machine they were not present

    disabled them and tried rww no go

    checked terminal service gateway in event viewer

    found Log Name:      Microsoft-Windows-TerminalServices-Gateway/Operational

    Source:        Microsoft-Windows-TerminalServices-Gateway

    Date:          4/16/2009 5:09:09 PM

    Event ID:      400

    Task Category: (3)

    Level:         Warning

    Keywords:      (16777216)

    User:          SYSINT\administrator

    Computer:      SERVER2.sysint.local

    Description:

    The TS Gateway service is shutting down. To diagnose possible causes for this problem, verify whether the following services are installed and started: (1) World Wide Web Publishing Service (2) Internet Authentication Service (IAS) (3) RPC/HTTP Load Balancing Service. Also, check Event Viewer for Network Policy Server (NPS) and IIS events that might indicate problems with NPS or IIS.

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-TerminalServices-Gateway" Guid="{4d5ae6a1-c7c8-4e6d-b840-4d8080b42e1b}" />

        <EventID>400</EventID>

        <Version>0</Version>

        <Level>3</Level>

        <Task>3</Task>

        <Opcode>15</Opcode>

        <Keywords>0x4000000001000000</Keywords>

        <TimeCreated SystemTime="2009-04-16T22:09:09.482Z" />

        <EventRecordID>199</EventRecordID>

        <Correlation />

        <Execution ProcessID="4964" ThreadID="4968" />

        <Channel>Microsoft-Windows-TerminalServices-Gateway/Operational</Channel>

        <Computer>SERVER2.sysint.local</Computer>

        <Security UserID="S-1-5-21-2548818932-1819075483-2254345019-500" />

      </System>

      <EventData>

      </EventData>

    </Event>

    ***********************

    checked (1) World Wide Web Publishing Service (2) Internet Authentication Service (IAS) (3) RPC/HTTP Load Balancing Service.

    all service were started restarted all the above services works fine

    logon type for terminal service gateway was set to "administrator " instead of network service"

    went to registry hklm/system/ccs/services/tsgateway changed start mode to network service

    rebooted the server

    tried rww after reboot no go

    followed http://blogs.technet.com/sbs/archive/2009/02/20/the-network-policy-server-service-ias-fails-to-start-or-be-installed.aspx

    Checked the following registry key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\VssAccessControl

    Verified that the setting for NT AUTHORITY\NETWORK SERVICE is set to 1

    followed

    wennt in iis console SBS Web Applications\Rpc\Authentication

    > Enabled Windows Authentication

    tried rww success


    Robert Brandenburg
    2009年5月17日 下午 06:34