none
HYPER-V 3.0複寫失敗 RRS feed

  • 一般討論

  • 請問各位前輩,小弟有安裝2台HYPER-V SERVER其中一台已經有安裝2台虛擬機器,例如主要伺服器名稱為vm2次要為vm1,現在小弟要將vm2複寫至vm1,但設定完成後會依職停留在如下圖的畫面

      小弟設定方式將VM1的powershell下new-netfirewallrule -displayname "Hyper-V複本接聽程式" -direction inbound -protocol TCP -Localport 80 -Active Allow , 再到VM1的HYPER-V設定裡面,勾取啟用此電腦作為複本伺服器,勾取使用KERBEROS(HTTP),選擇允許來自指定的伺服器的複寫,新增,指定伺服器輸入"*.abc.local",位置設定成D磁碟,指定群組輸入TEST,之後在VM2上的虛擬機器上啟用複寫,設定完,就一直跑正在啟用複寫,小弟我把他丟了一天,還是在跑這個畫面,請問各位前輩,問題出在呢!!?麻煩幫忙一下!!~謝謝.


    • 已編輯 Chien_chen 2014年2月19日 上午 01:36
    • 已變更類型 Claire Ho 2014年3月7日 上午 03:37 customer did not show up over 3 day
    2014年2月19日 上午 12:41

所有回覆

  • Hi Chien_chen 您好,

    看您的描述您想做的事應該是有兩台主機(Host1、Host2),其中Host2上可能已經安裝了兩台VM,然後您想將Host2複寫到Host1~

    想先請問您是否有安裝防毒軟體,遇過案例是因為防毒軟體導致,因此建議您先將防毒軟體解除安裝,重新開機之後再試一次~

    2014年2月19日 上午 02:48
  • 前輩你好!!HYPER-V Server沒有安裝防毒軟體!!~請問是要移除虛擬機器裡面的防毒軟體嘛!!?
    2014年2月19日 上午 03:13
  • Hi Chien_chen 您好,

    所以您的意思是兩台server皆沒有安裝防毒,然後vm有裝防毒?

    2014年2月19日 上午 05:51
  • 前輩你好!!~HYPER-V能安裝防毒軟體嘛!?這我就不懂了!!~我是沒有安裝

    HYPER-V裡面的2台VM虛擬主機是有安裝防毒軟體的

    2014年2月19日 上午 06:04
  • 不知道你有沒有調整防火牆的設定假如沒有的話你可以參考這一篇設定方式來操作Hyper-V 複寫 (Replica) 設定 


    小白技術沒關係 金錢的力量 決定服務的高低



    • 已編輯 Kill Apple 2014年2月19日 上午 06:08
    2014年2月19日 上午 06:07
  • HI!!~這些步驟我都有做了!!~

    以前做過一次是成功的!!~最近VM1跟VM2打掉重新安裝就不行了.

    唯一的差別是之前我是VM1複寫至VM2,現在是VM2複寫至VM1

    2台機器都HP的,型號沒差多少!!~

    2014年2月19日 上午 07:19
  • 您好

    兩台fw 都確認是否有啟動,然後兩台複寫功能先全部停用在啟用,這樣看看行不行

    我之前有遇到要複寫但出現和你依樣類似畫面,但是我將複寫停用在啟用後就可以了

    2014年2月19日 上午 07:36
  • 前輩你好!!~我VM1跟VM2都有在powershell下new-netfirewallrule -displayname "Hyper-V複本接聽程式" -direction inbound -protocol TCP -Localport 80 -Active Allow ,前輩的停用複寫的意思是說在虛擬機器上停用在啟用嘛!?小弟也試過這個方法了!!~小弟還發現!!~複本伺服器會出現我要起定複寫的虛擬機器名稱,但看他的狀態,傳輸數量都是0KB
    2014年2月19日 上午 08:35
  • 您好

    我指的是在hyper-v 中的啟用複本伺服器功能停用在啟用試看看

    以上提供您參考看看


    2014年2月19日 上午 08:50
  • 對嚕兩台機器的時間有一致嗎有重新安裝過整合元件嗎

    小白技術沒關係 金錢的力量 決定服務的高低


    • 已編輯 Kill Apple 2014年2月19日 上午 09:10 錯字修正
    2014年2月19日 上午 09:10
  • Hi Chien_chen

    歡迎您將後續測試結果回報至論壇, 或將對您有幫助的回覆標示為解答,

    以利討論的進行並幫助其他有類似問題的朋友. 謝謝您!

    2014年2月21日 上午 08:49
    版主
  • 前輩你好!!~方法都試過了!!~目前問題還沒解決....

    2014年2月21日 上午 08:52
  • 嘗試改用 Powershell 進行設定,看會不會報錯,
    詳情設定方式可以參考這篇文章:
    Managing Hyper-V Replica from PowerShell

    還有請檢查事件檢視器是否有相關錯誤。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2014年2月21日 下午 03:30
    版主
  • 各位前輩!!~小弟發現我的複寫跟建立虛擬硬碟速度緩慢!!~如果退出網域!!~一切都正常了!!但加入網域!!~就會有這個問題!!~
    2014年2月24日 上午 10:33
  • 如果退出網域就正常,
    可能就要知道你的網域有套什麼 GPO,
    或者加入網域後會強制安裝什麼軟體或設定。

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2014年2月25日 上午 02:20
    版主
  • Hi Chien_chen

    就如同Aska板主所說的加入網域就復寫失敗 退出網域就覆寫成功那或許有套用一些設定才會這樣子那你可以檢查一下防火牆、群組原則、軟體派送、使用者權限差異..........

    小白技術沒關係 金錢的力量 決定服務的高低


    • 已編輯 Kill Apple 2014年2月25日 上午 05:31
    2014年2月25日 上午 03:54
  • Hi Chien_chen 您好,歡迎您將後續測試結果回報至論壇,或將對您有幫助的回覆標示為解答,以利討論的進行並幫助其他有類似問題的朋友。謝謝您!

    2014年3月4日 上午 07:48