none
Exchange Server 2007: upgradecms 失敗, 能由SP2降回SP1嗎? RRS feed

解答

  • 說穿了沒什麼, 問題在我跟 "How to Upgrade a Single Copy Cluster to Exchange 2007 SP1 or SP2" 跟得太足了.

    在 "How to Upgrade a Single Copy Cluster to Exchange 2007 SP1 or SP2" 裡的8-11點說到如何upgradecms的步驟: 先將ClusteredMailboxServer停掉, 再將其轉到剛做完 upgrade 的 Passive Node上, 進入CMD run setup /upgradecms.

    這幾個步驟我前後做了不下數十次, 令我懷疑到底錯在什麼地方? 明明跟足說明來做了. Backup Exec Remote Agent 早就停了 (在upgrade mailbox role時發生BE Agent 咬住 Mailbox 不放, 導致錯誤), Anti Virus 也uninstall了, 明明很單純的一個環境了, 為什麼還是不行?

    試到沒力之後, 突然想到曾在 "How to Upgrade a Clustered Mailbox Server in a CCR Environment to Exchange 2007 SP1 or SP2" 看過卻一直忽略的一個句子: "Setup /UpgradeCms must be run on the active node." 不過我這裡是SCC, 文件裡隻字未提. 既然都是HA的架構, 也只能試試了.

    於是我將所有的clustered group 全部轉到剛升級完的 Passive Node, 令它成為 Active Node, 再進入CMD run setup /upgradecms. 搞定.

    在找 solutions 時也見過國外有幾個人跟我一樣的問題, 就算我蠢吧, 也不孤單了. 總之這問題就算解決了.
    • 已標示為解答 dapiwang 2010年2月8日 上午 10:39
    2010年2月8日 上午 10:39

所有回覆

  • Dear Sir,
    升級到SP2是不能回SP1的.
    $亮晶晶的小欣$ Gary Yuan. http://yuanwenshin.spaces.live.com
    • 已提議為解答 Gary Yuan. _ 2010年1月24日 上午 09:24
    • 已取消提議為解答 dapiwang 2010年2月8日 上午 10:43
    2010年1月23日 上午 04:12
  • 是的. 在提出問題之前我已試過, 正常的方法沒辦法 rollback 回去 SP1, 有其他solutions可以建議嗎?

    事實上在進行升級前我已在VM上跑過一次, 現在就算想再模擬出相同的問題環境都不容易.
    2010年1月25日 上午 01:14
  • upgradecms 的問題已解決.

    • 已標示為解答 dapiwang 2010年1月29日 上午 04:38
    • 已取消標示為解答 dapiwang 2010年2月8日 上午 10:39
    2010年1月29日 上午 04:38
  • 請問如何解決?
    $亮晶晶的小欣$ Gary Yuan. http://yuanwenshin.spaces.live.com
    • 已標示為解答 dapiwang 2010年2月8日 上午 10:21
    • 已取消標示為解答 dapiwang 2010年2月8日 上午 10:41
    2010年1月29日 上午 06:04
  • 說穿了沒什麼, 問題在我跟 "How to Upgrade a Single Copy Cluster to Exchange 2007 SP1 or SP2" 跟得太足了.

    在 "How to Upgrade a Single Copy Cluster to Exchange 2007 SP1 or SP2" 裡的8-11點說到如何upgradecms的步驟: 先將ClusteredMailboxServer停掉, 再將其轉到剛做完 upgrade 的 Passive Node上, 進入CMD run setup /upgradecms.

    這幾個步驟我前後做了不下數十次, 令我懷疑到底錯在什麼地方? 明明跟足說明來做了. Backup Exec Remote Agent 早就停了 (在upgrade mailbox role時發生BE Agent 咬住 Mailbox 不放, 導致錯誤), Anti Virus 也uninstall了, 明明很單純的一個環境了, 為什麼還是不行?

    試到沒力之後, 突然想到曾在 "How to Upgrade a Clustered Mailbox Server in a CCR Environment to Exchange 2007 SP1 or SP2" 看過卻一直忽略的一個句子: "Setup /UpgradeCms must be run on the active node." 不過我這裡是SCC, 文件裡隻字未提. 既然都是HA的架構, 也只能試試了.

    於是我將所有的clustered group 全部轉到剛升級完的 Passive Node, 令它成為 Active Node, 再進入CMD run setup /upgradecms. 搞定.

    在找 solutions 時也見過國外有幾個人跟我一樣的問題, 就算我蠢吧, 也不孤單了. 總之這問題就算解決了.
    • 已標示為解答 dapiwang 2010年2月8日 上午 10:39
    2010年2月8日 上午 10:39