locked
Application Hang 無回應的應用程式.....無回應的位址 0x00000000。
&#x000a RRS feed

  • 問題

  • 各位前輩您好:
    在下最近安裝一部新的電腦,但是使用了不久就會出現程式無回應的情形發生,使用工作管理員強制將程式中止也是無法成功,剛開始可能以為是沒有Update Services Pack所以軟體有衝突情形才會導致程式當掉,但經過更新後仍然發現情況依舊!!電腦從開機使用後甚至不到30分鐘就出現,會當掉的軟體包含Office產品,MSN,Skype.以下我把相關資訊貼上,希望大家能協助小弟找出故障的原因,謝謝大家!!

    OS:Windows XP Professional SP2 (已更新)
    Office 2000

    Windows 錯誤報告如下:
    2006/11/23 上午 11:29    Application Hang    無回應的應用程式 msnmsgr.exe,版本 8.0.812.0。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。

    2006/11/23 上午 11:30    Application Hang    無回應的應用程式 Skype.exe,版本 2.5.0.151。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。

    2006/11/23 下午 02:31    Application Hang    錯誤容器 315410415。

    2006/11/23 下午 04:15    Application Hang    無回應的應用程式 EXCEL.EXE,版本 9.0.0.2719。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。

    2006/11/23 下午 04:21    Application Hang    無回應的應用程式 IEXPLORE.EXE,版本 6.0.2900.2180。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。

    2006/11/23 下午 04:23    Application Hang    錯誤容器 126637809。

    2006/11/23 下午 06:41    Application Hang    無回應的應用程式 QueueManagerC.exe,版本 3.1.2.0。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。

    2006/11/24 上午 10:28    Application Hang    無回應的應用程式 OUTLOOK.EXE,版本 9.0.0.2416。無回應的模組 hungapp 版本 0.0.0.0。無回應的位址 0x00000000。


    2006年11月24日 上午 07:28

解答

  • 問題似乎已經解決了!!Post上來作為參考~
    經小弟做完Memory測試及Office修復後仍然完法解決問題時,小弟嚐試著用Local Administrator帳號登入,然後將Office產品皆打開,關閉,重覆了幾次後發現不會當掉了,接著登出再用網域Administrator登入,做一樣的動作也不會當了,再用使用者帳號登入之後結果一樣,不會當掉了!!一直觀察到今天約一星期多了,到目前為止除了Skype偶爾當掉外,Office的部份完全恢復正常!!小弟是因為看見EventID:5603這問題才想到這解決方式,也許是小弟當初安裝Office時是用Local Administrator安裝,但沒有去做第一次開啟的動作所造成的吧!
    2006年12月4日 上午 02:07

所有回覆

  • 若是新的電腦便如此的話,建議您能夠看看所購買的硬體是否皆在 Microsoft Windows 硬體相容性清單 (HCL) 中,並將所有硬體的驅動程式都安裝到最新的版本,或是更換記憶體模組看看。
    2006年11月24日 下午 07:30
  • 感謝前輩的回應~
    不好意思小弟做了一些測試所以晚了點回覆!
    這台電腦不是新的,之前有在使用且沒問題,是為了弄一台新的電腦給同事換,且我到微軟的HCL查過,確實我的硬體有在Windows XP Professional支援中,驅動程式都安裝最新版本,另外我也上網查過類似問題,有人的建議是測試是否是記憶體或主機板的問題,我也下載了Windows Memory DiagnosticMemtest86兩個工具,但因為時間問題只做了Windows Memory Diagnostic的測試,做完後發現沒有出現任何Error,所以至少應該不是主機板或記憶體的問題是嗎?小弟回想起在安裝Office 2000的時候曾經出現錯誤訊息,訊息如下:"無法存取Microsoft Personal Web伺服器的設定"但是依然完成安裝,難道是這個問題造成的嗎?我重新使用Office光碟使用修復依然會出現這個訊息,之後我到事件檢示器中發現有個錯誤訊息:
    EvenID:5603
    內容:提供者 OffProv 已在 WMI 命名空間 Root\MSAPPS 中註冊,但未指定 HostingModel 內容,將會使用 LocalSystem 帳戶來執行這個提供者。這個帳戶具有特殊權限且如果該提供者未正確
    的模擬使用者要求,它可能導致安全性違規。請確定已檢視提供者安全性行為,並更新提供者註冊的 HostingModel 內容到對所要求的功能具有最起碼權限的帳戶。

    2006年11月28日 上午 02:36
  • 問題似乎已經解決了!!Post上來作為參考~
    經小弟做完Memory測試及Office修復後仍然完法解決問題時,小弟嚐試著用Local Administrator帳號登入,然後將Office產品皆打開,關閉,重覆了幾次後發現不會當掉了,接著登出再用網域Administrator登入,做一樣的動作也不會當了,再用使用者帳號登入之後結果一樣,不會當掉了!!一直觀察到今天約一星期多了,到目前為止除了Skype偶爾當掉外,Office的部份完全恢復正常!!小弟是因為看見EventID:5603這問題才想到這解決方式,也許是小弟當初安裝Office時是用Local Administrator安裝,但沒有去做第一次開啟的動作所造成的吧!
    2006年12月4日 上午 02:07