none
Configure a PXE server to load Windows PE RRS feed

  • 問題

  • Hi,

    I follow this article to deploy WinPE to PXE server and it works in legacy BIOS https://docs.microsoft.com/en-us/windows/deployment/configure-a-pxe-server-to-load-windows-pe. All of sources extracr from Win10 DVD. My TFTP/PXE/DHCP servers is on Synology NAS.

    Next, I want to launch it in UEFI BIOS. So I make some changes:

    1. Use bootmgfw.efi which extracted from Win10 DVD instead of pxeboot.n12.

    2. Modify BCD file boot loader entry: winload.exe -> winload.efi

    But I failed....

    TFTP log says only boomgfw.efi, BCD, and font transferred to PC(PXE client). client does not request boot.wim and boot.sdi.

    BCD file content extracted from Win10 DVD is as follow:

    Windows Boot Manager
    --------------------
    identifier              {bootmgr}
    description             Windows Boot Manager
    locale                  en-US
    inherit                 {globalsettings}
    default                 {default}
    displayorder            {default}
    toolsdisplayorder       {memdiag}
    timeout                 30

    Windows Bootloader
    -------------------
    identifier              {default}
    device                  ramdisk=[boot]\sources\boot.wim,{7619dcc8-fafe-11d9-b411-000476eba25f}
    path                    \windows\system32\boot\winload.efi
    description             Windows Setup
    locale                  en-US
    inherit                 {bootloadersettings}
    isolatedcontext         Yes
    osdevice                ramdisk=[boot]\sources\boot.wim,{7619dcc8-fafe-11d9-b411-000476eba25f}
    systemroot              \windows
    bootmenupolicy          Standard
    detecthal               Yes
    winpe                   Yes
    ems                     No

    I also use bootx64.efi instead, error 0xc000225 still occurred. Please give me some advise to solve this problem.

    Many thanks




    • 已編輯 阿譽 2019年10月31日 上午 09:51
    2019年10月31日 上午 09:44