none
Exchange services not starting help!

    問題

  • Colleague was troubleshooting an exchange outage and used the following commands to set a preferred and static domain controller and global catalog

    Set-ADServerSettings -PreferredServer DC02.mydomain.local

    Set-ExchangeServer -Identity -StaticDomainController DC02.mydomain.local

    Set-ExchangeServer -Identity -StaticGlobalCatalogs  DC02.mydomain.local

    Now the exchange services will not start at all. My exchange management shell also doesn't connect to the Exchange server since services are'nt running and just stays on "Connecting to DC02.mydomain.local" so I can't revert the above back to $null as Microsoft articles suggest

    Is there any way for me to manually change this setting back WITHOUT using powershell or the Exchange Management Console (doesn't launch either) so that my exchange server can search for a usable domain controller and gc? 

    Thanks for any input! 



    • 已編輯 jmontalbo 2018年7月13日 上午 08:45
    2018年7月13日 上午 08:11

解答

  • Problem solved - I was able to make the necessary changes in the registry at the following registry keys

    HKLM\System\CurrentControlSet\Services\MSExchange ADAccess\Instance0\ConfigDCHostname

    HKLM\System\CurrentControlSet\Services\MSExchange ADAccess\Profiles\Default\

    Once these were pointed to a working domain controller and global catalog server, Exchange services booted back up with no issues and EMC + shell connected fine

    Since exchange powershell was working again, I ran the following after as well just to make sure it was clean per suggestion from another Microsoft article. 

    Set-ExchangeServer -Identity -StaticDomainController $null

    Set-ExchangeServer -Identity -StaticGlobalCatalogs  $null

    Now to figure out why it stopped working when he had set it to this particular domain controller.. but for another post! :) 

    • 已標示為解答 jmontalbo 2018年7月13日 上午 09:20
    • 已編輯 jmontalbo 2018年7月13日 上午 09:24
    2018年7月13日 上午 09:19