none
開啟IE後,CPU會一直跑100%? RRS feed

  • 問題

  • 請問
    作業系統是Windows 2000 adv server+ SP4,才剛安裝完系統沒多久,過了幾天要上網開啟IE時會發生 services.exe造成CPU 100%一直執行有時候是IEXPLORE.EXE 100%(關掉IE也沒用,只能強迫重開機),但是如果使用Firefox就完全沒事,木馬,防毒軟體都完全掃描過沒問題,不知到底IE和系統是不是有衝突?不知有人遇過這種詭異的情況嗎?

    謝謝!
    2006年11月3日 上午 08:19

解答

  • 問題解決了,後來發現是無線網卡的問題,換另一廠牌就恢復正常,但是有問題的網卡再另一XP OS又可以正常運作,可能是和Windows 2000 Server衝突吧~~~
    2006年11月29日 上午 03:04

所有回覆

  • 首先,services.exe這程式應該放在c:\winnt\system32目錄內,你可以搜尋一下是否有奇怪的目錄也有該程式。

    IE當機的部份,你可以先試著到c:\winnt\Downloaded Program Files移除一些元件,看是否有元件當機,導致IE不穩定。
    如果你有安裝TOOLBAR FOR IE,試著先移除,把環境簡化,這樣比較有利你找到問題可能的原因。

    c:\winnt 是您安裝WINDOWS的目錄

    2006年11月3日 上午 08:35
  • 你可以抓這個工具:

    http://www.sysinternals.com/Utilities/ProcessExplorer.html

    這個工具被微軟多個 KB 引用,下方有說明介紹。

    功能基本上跟工作管理員差不多,不過有執行中程序完整路徑,所以你可以看看跑到 100% 的那個完整路徑是啥,也可以用屬性檢查,是否有簽名正確、有沒有偷開網路的連線。

    這是綠色軟體,免安裝,解開壓縮就可以執行,所以可以不用搜尋目錄,用很直覺的方式檢查。

    IE 啟動時,會使用到 COM ,因為 IE 本身只是殼,真正的物件在 windows 系統內(Win2003 在 Shell32.dll 內),若是你在服務內,把 COM 服務關閉,可能會出問題。

    2006年11月3日 下午 12:48
  • 您可至命令提示字元下面執行 tasklist /svc 指令看看目前每個處理程序中所顯示的服務,確定一下是哪個服務在作怪,常見的情形都是 Windows 沒有更新或是電腦中了木馬程式所造成的
    2006年11月3日 下午 01:10
  • 後來又測試了一下,登入本機執行IE就完全正常,但是登入網域就執行IE CPU就會一直100%@@"
    2006年11月3日 下午 01:35
  • 您好!

    您說的COM服務是指哪一個服務(詳細名稱),我系統的服務都沒有去做更改過(系統預設),使用這個工具只發現IEXPLORE.EXE,C:\Program Files\Internet Explorer\IEXPLORE.EXE一值跑100%因該不是病毒,現在只能使用Firefox可以正常......

    謝謝!

     

     

    2006年11月6日 上午 02:25
  • 你使用其他網域帳號登入該電腦,檢視是否也會有類似現象,

    如果只是該帳號會發生問題,您可以試著備份該帳號的資料,並重新建立該帳號使用者登入環境。

     

    2006年11月10日 上午 07:20
  • 謝謝您的建議,我會再試試看。
    2006年11月13日 上午 04:18
  •  璉璉 寫信:

    你可以抓這個工具:

    http://www.sysinternals.com/Utilities/ProcessExplorer.html

    這個工具被微軟多個 KB 引用,下方有說明介紹。

    功能基本上跟工作管理員差不多,不過有執行中程序完整路徑,所以你可以看看跑到 100% 的那個完整路徑是啥,也可以用屬性檢查,是否有簽名正確、有沒有偷開網路的連線。

    這是綠色軟體,免安裝,解開壓縮就可以執行,所以可以不用搜尋目錄,用很直覺的方式檢查。

    IE 啟動時,會使用到 COM ,因為 IE 本身只是殼,真正的物件在 windows 系統內(Win2003 在 Shell32.dll 內),若是你在服務內,把 COM 服務關閉,可能會出問題。

     

    good tool!

    2006年11月16日 下午 10:53
  • 我的情形與開版的大大有些許的不一樣,我的ie也是會一直吃掉資源100%

    但我只要關閉ie通常就可以解決!我也嘗試過重新完整安裝,但也沒有用!

    ie的外掛toolbar,只有使用google toolbar,無其它!

    不知道各位怎解決這樣的問題!~

    2006年11月17日 上午 12:53
  • 最近微軟好像有更新IE的BUG,但對於會導致CPU使用率達到100%還是沒有解決!

    本人認為此一問題可能出現在USER在瀏覽某些網站時,而該網站會對USER的頁面一直做"攻擊"或"更新"

    之類的動作!就算是USER已經離開了該網頁的瀏覽,但還是會有此問題發生!

    初步判斷可能是COOKIE的影響吧!?

    最好的解決辦法就是關閉IE,並且清除COOKIE及記錄!若還有問題願大家一起來討論^^

    2006年11月19日 上午 09:15
  • 會導致CPU使用率達到100%,這問題不一定由IE本身的BUG導致。

    建議把IE所有的附加元件暫時停用(Windows XP Sp2)

    看是否問題依舊。

    2006年11月19日 上午 10:32
  • 問題解決了,後來發現是無線網卡的問題,換另一廠牌就恢復正常,但是有問題的網卡再另一XP OS又可以正常運作,可能是和Windows 2000 Server衝突吧~~~
    2006年11月29日 上午 03:04
  • 謝謝你的回覆分享
    2006年11月29日 上午 04:33
  • 也有可能是跟主機板衝

    我碰過 Microsoft MN-710 會跟我的華碩主機板衝,開機時會卡住 1 分鐘,拔掉就沒事,而且只有開機時會衝,把那個無線網卡識別為開機 USB 碟,跟其他電腦都不會衝。

    K 大知道了後,找了位華碩內部高階工程師來幫我處理,還派小弟來我家拿那張網卡回去處理,最後是只跟我那台電腦主機板衝。

    最後被我自己把主機板燒掉了,那就算了...

    2006年11月29日 上午 07:12