none
Exchange 2010 新增憑證後無法生效的問題 RRS feed

  • 問題

  • 各位好:

    請教一個問題, 個人依顧大俠的教學影片以及原廠網站參考

    在CAS+HT Server 上新增Exchange 憑證

    並已經在AD DC 上建立Root CA

    在新增Exchange 2010 憑證並完成擱置的要求後

    在EMC的畫面中發現該憑證仍然是打x 的狀態

    畫面如下, 也已經設定主體別名

    http://img233.imageshack.us/img233/2387/123zd.jpg

    http://img515.imageshack.us/img515/8688/456nn.jpg

    感覺似乎CAS+HT Server 並沒有信任這個憑證, 是否Root CA 要重新安裝 ? 

    有參考其他文章表示要透過OWA 先行登入來驗證憑證安裝

    但是IIS 的憑證目前還是自我簽署的憑證

    我不懂要怎麼讓OWA 來驗證剛剛新增的憑證 ? 

    是要在IIS 網站中的Binding 中把Https 的憑證手動選為剛剛新增的那個嗎 ? 

    以上 還請各位協助

    謝謝

    2010年10月11日 下午 02:51

解答

  • Hi,

    伺服器設定\用戶端存取\設定用戶端外部存取網域 --> 這個要設定 !!

    P.S. 憑證設定後如果還是打 "X",可以在 Exchange Server 上執行 gpupdate /force 就可以解決

     

    Regards,
    Lingo Chiang


    ~以無法為法,以無限為限~不在線上就在羽球館
    2010年10月12日 上午 10:42
    版主

所有回覆

  • 你好:

    請將該憑證刪除,到CA中策銷該憑證,將Exchange重新開機,再重新要求一次憑證。

     

    IIS 不需要額外去設定,只要在Exchange 中去指派憑證給IIS 就會更新為指派的新憑證。 


    Lusheng
    2010年10月12日 上午 02:25
    版主
  • 您好 :

    目前查看該憑證已經生效, 並且我已經指派服務給該憑證, IIS , IMAP , POP3 , SMTP

    主體也都有指派外部Mail Server FQDN

    但是其他外部網路用戶端在連線OWA 仍會出現憑證錯誤的訊息

    是否要另外安裝憑證才行 ? 謝謝

     

    2010年10月12日 上午 03:25
  • Hi,

    伺服器設定\用戶端存取\設定用戶端外部存取網域 --> 這個要設定 !!

    P.S. 憑證設定後如果還是打 "X",可以在 Exchange Server 上執行 gpupdate /force 就可以解決

     

    Regards,
    Lingo Chiang


    ~以無法為法,以無限為限~不在線上就在羽球館
    2010年10月12日 上午 10:42
    版主
  • Dear :

    外部使用者也需要安裝企業根憑證,關於The Certificate is Invalid for Exchange Server Usage,可以參考 :
    http://exchangeserverpro.com/exchange-server-2010-certificate-invalid-for-exchange-server-usage-error

    這是本機電腦帳戶並未有企業根憑證所造成的,您重開機後若根憑證有部署下來會顯示正常!

    若企業根憑證有正確部署,則參考Lingo所說的確認外部存取網域及啟用outlook anywhere

     

    以上資訊提供您參考

    Mike Lin 林彥廷

    2010年10月12日 下午 04:53
  • 您好 :

    在外部PC 中安裝Root CA 後, 在連線OWA 已經不會再出現憑證錯誤訊息

    目前正試著在Ipad , Iphone 裝置上測試中 (用其他信箱收有憑證附件的信, 直接執行憑證安裝)

    謝謝

     

    2010年10月13日 上午 01:50