locked
對同一張網卡新增 IP , 重開機後設定會遺失? RRS feed

  • 一般討論

  • (由於是運作中的主機發生, 所以暫時沒有自行 LAB )

    公司有一台主機(Server 2008 32bit)同時提供兩種服務, 以管理的角度想配發兩個 IP

    原本主要的 IP : 172.16.2.250 , Gateway : 172.16.2.254
    而第二個服務安裝好之後, 在 TCP/IP(v4) - 進階 新增了另一組 IP : 172.16.2.190 (無 Gatetway )

    最近由於更新軟體(非微軟內建服務), 將這台主機重新啟動,
    但啟動之後只有 IP 還在(兩個都在), 但主要 IP 的 Gateway 一欄卻是空白,

    想請問大家是否有遇過類似情況, 或者是否有哪些可能的因素會造成?
    不管黑貓白貓, 會抓老鼠的就是好貓. 不管 Win/Linux/Mac , 能對工作有助益的就是好系統.
    • 已變更類型 Vincent Lin 2009年12月16日 上午 02:44
    • 已變更類型 Vincent Lin 2009年12月22日 上午 02:35
    • 已變更類型 Vincent Lin 2009年12月22日 上午 02:36
    2009年12月15日 上午 06:25

所有回覆

  • 如果現在在把Gateway設定回去後...是重新開機才會不見? 還是過一下就不見了?

    在問題發生時..麻煩執行 ipconfig /all 然後把畫面貼出來看看

    假設是每次重新開機都會發生的話..可能要蒐集一些資訊去看說是否設定被某隻程式清掉所導致


    微軟技術支援服務
    2009年12月16日 上午 02:44
  • 前次是重開機才不見, 由於主機還在運作, 運作中都正常.

    因為目前沒有備用機可以 Lab , 所以想先蒐集一下資料.
    不管黑貓白貓, 會抓老鼠的就是好貓. 不管 Win/Linux/Mac , 能對工作有助益的就是好系統.
    2009年12月16日 上午 08:07
  • 那可能要先假定是重新開機後才會發生...那建議你可以先按造下面步驟設定
    讓Process Monitor去紀錄開機時的所有動作..看是否為開機時有程式去修改到網路設定

    ----------------------------------------------------------------------------------------------
    1.下載Process Monitor - http://download.sysinternals.com/Files/ProcessMonitor.zip

    2.解壓縮後執行Procmon.exe

    3.如有出現Filter的畫面時..直接按Cancel取消

    4.出現主畫面時..點選上方的 Options - Enable Boot Logging - OK

    5.關閉Process Monitor & 重新開機

    6.重新開機再次打開 Process Monitor , 會問你要不要儲存 (如果出現Filter畫面請按Cancel)

    7.儲存後將該檔案"壓縮"並上傳到免費空間(如http://www.badongo.com)給我看看 (沒壓縮的話檔案很大)
    ----------------------------------------------------------------------------------------------

    之前有遇過是防毒軟體會影響到網路設定..移除掉就好了..給你參考看看
    如果之後問題有重現的話再把上述資料給我們看看囉

    Thanks


    歡迎參加MSDN&TechNet技術社群交流活動 (時間:1/9(六) 11:30-17:30(台中金典),1/16(六) 11:30-17:30(台北微軟),1/23(六) 11:30-17:30(高雄漢來)),
    MSDN老爹TechNet小妹將盛裝出席, 要一睹風采, 就趕快報名!!
    2009年12月16日 上午 09:10
  • Thanks, 我等有機會再試試看.
    不管黑貓白貓, 會抓老鼠的就是好貓. 不管 Win/Linux/Mac , 能對工作有助益的就是好系統.
    2009年12月16日 上午 09:21