none
如何將SQL Server 2005 Cluster (以Virtual Server Name) 設定為允許遠端連接 RRS feed

  • 問題

  • 網頁出現

    '/' 應用程式中發生伺服器錯誤。

    在建立連接至伺服器時發生錯誤。當連接至 SQL Server 2005 時,失敗的原因可能是,在預設設定下,SQL Server 不允許遠端連接。 (provider: 具名的管線提供者, error: 40 - 無法開啟至 SQL Server 的連接)

    乃根據以下KB設定為允許遠端連線

     

    http://support.microsoft.com/kb/914277/zh-tw

     

    所有的步驟都做了,除了開啟SQL Server 2005 Surface Area Configuration,展開Database Engine的Remote Connections後,

    即出現警示

    You cannot configure surface area of clustered services by connecting to a computer. connect to the virtual server to configure clustered services.

    按下ok後即跳出設定畫面.

     

    有什麼方法可以解決以上問題?

     

     

    2008年7月12日 上午 02:11

解答

  •  

    後來發現是網管的的防火牆沒開完全,

    所有AP之Web.config所載的的資料庫連線port都必須開啟,

    雖當時請網管確認,但卻沒確認清楚,

    故即使我於Server設例外,仍然徒勞無功,

    直至網管再次發現問題,才獲解決.

    2008年7月21日 上午 09:00

所有回覆

  • 請問是以 虛擬 SQL Server 名稱(Virtual Server Name)連線進行設定嗎? 

    2008年7月12日 上午 09:01
    版主
  • You can enable tcp/ip and/or named pipes protocols in sql server configuration manager.

     

    2008年7月12日 下午 05:18
  • 您好:

    我也有遇過此問題,我當時的處理方式有二,可擇一選擇:

    1.連接端的電腦可設定『別名』,若是未安裝SQL工具可至控制台ODBC設定,來指定主機名稱(或IP)與連接埠(14XX)。

    2.若不想設定別名或ODBC,則SQLSERVER該台電腦的防火牆需開啟『例外』-->UDP的1434埠。

     

    希望對您有幫助,謝謝!

     

     

    小腸

    97.7.17

     

     

    2008年7月17日 下午 12:59
  •  

    是.
    2008年7月21日 上午 08:56
  • I had already done it. 

    2008年7月21日 上午 08:57
  •  

    後來發現是網管的的防火牆沒開完全,

    所有AP之Web.config所載的的資料庫連線port都必須開啟,

    雖當時請網管確認,但卻沒確認清楚,

    故即使我於Server設例外,仍然徒勞無功,

    直至網管再次發現問題,才獲解決.

    2008年7月21日 上午 09:00