none
重新啟動後,有些服務無法啟動 RRS feed

  • 問題

  • 這個問題在於做過某次windows update更新後發生的

    第一次發生是做完更新後重新啟動現伺服器,開完機後發現備份軟體無法正常運作,

    檢查才知道他的服務停止,手動啟動無法啟動,要進去重新輸入執行帳號的密碼,才可以啟動服務

     

    如果直接啟動會出現"錯誤1069 登入失敗所以服務無法啟動"

    重新輸入密碼確定會出現"帳戶xxx 已獲得[以服務方式登入]的權利"

     

    而且很多台都有這種情形發現,頭先一直覺得是備份軟體的問題,請廠商處理也找不出什麼原因

    後來發現不是只有備份軟體會這樣,有的伺服器是FTP的服務、其它軟體在重新開機過後,有一定機率會發生無法啟動

    解決的方法都是重新輸入一次密碼再啟動即可啟動,服務都是有使用帳號啟動(非本機系統、網路服務)

     

    請問有人遇過這樣子的問題嗎?


    • 已編輯 方程式 2011年4月26日 上午 06:55 補充
    2011年4月26日 上午 06:44

解答

  • 謝謝各位的回覆

    最後有查到只要有更新過群組原則,服務就會變無法啟用

    所以才會剛重設完是正常的,但只要過一段時間就會失效

     

    後來把服務用的帳戶加入"以服務的方式登入",問題就排除了。

    • 已標示為解答 方程式 2011年5月2日 上午 02:40
    2011年5月2日 上午 02:40

所有回覆

  • 通常懷疑Windows Update的話就將更新過的檔案移除

    這樣就可以先排除Windows Update問題

    你這樣的問題可以參考這一篇

    http://support.microsoft.com/kb/282254/zh-tw

    不過依你的情況說有很多都有問題

    通常個人遇過第一是帳號有勾選每次都登入須重設密碼

    不然就是有變動過密碼

    另一種可能就是系統看看是否中毒導致不正常

    建議使用本身的防毒再選擇第二種方式掃描


    分享工作上的經驗,Windows歡迎提出討論,Jerry_IT資訊技術手札 - 無名小站http://www.wretch.cc/blog/jerry0822 10/26影音教學(有聲音)Jerry_IT資訊教學影片技術手札 http://www.dotblogs.com.tw/jerry710822 Jerry_IT資訊技術手札 - 2010~2011 Virtual Machine Microsoft MVP (http://kili92.myweb.hinet.net/index.htm)
    • 已提議為解答 AChange 2011年4月29日 上午 01:38
    • 已標示為解答 AChange 2011年5月2日 上午 01:19
    • 已取消標示為解答 AChange 2011年5月2日 上午 02:42
    2011年4月26日 上午 08:04
  • 如果是大規模的狀況發生,
    一般建議先檢查這些機器是否有什麼共通性,
    比如:
    1. 相同的 WindowsUpdate
    2. 相同的防毒軟體
    3. 時間發生點

    然後先試著移除更新或者防毒軟體看看。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    • 已提議為解答 AChange 2011年4月29日 上午 01:38
    • 已標示為解答 AChange 2011年5月2日 上午 01:19
    • 已取消標示為解答 AChange 2011年5月2日 上午 02:42
    2011年4月27日 上午 05:33
    版主
  •  

    你好

    頭先一直以為是備份軟體的問題,更新也做了很多次,目前要查到是那個更新問題是比較難

    防毒軟體我會再試看看是不是有影響,發生的時間點是差不多再某次更新後發生的沒錯

    2011年4月27日 上午 08:46
  • 其實也有可能是防毒軟體在某次時間點的更新後所造成,
    過去在論壇上也有不少案例是防毒軟體產生的靈異現象。 :)


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    2011年4月27日 下午 01:22
    版主
  • 謝謝各位的回覆

    最後有查到只要有更新過群組原則,服務就會變無法啟用

    所以才會剛重設完是正常的,但只要過一段時間就會失效

     

    後來把服務用的帳戶加入"以服務的方式登入",問題就排除了。

    • 已標示為解答 方程式 2011年5月2日 上午 02:40
    2011年5月2日 上午 02:40