locked
2008server 網路磁碟機連線問題 RRS feed

  • 問題

  • 小弟的軟體是放在SERVER開網路磁碟機共用,然後CLIENT端XP 是利用連線網路磁碟機去執行,目前20台連線到SERVER去作業

    CLIENT端會灌安裝程式BDE 然後設定路徑去執行,最近我們公司把網路改成GIGA環境,接法是SERVER下來有一台16 PORT GIGA HUB

    底下個接6各8PORT GIGA HUB到各個辦公室,改成這樣之後,我們系統常常會出現NETWORK 錯誤,但是對外連線卻都正常,

    有時編輯系統一段時間後,要存檔就會出現 NETWORK 錯誤,但是當下去點網路磁碟機去都正常可以進入,也沒有瞬段情形,不知道是哪裡出了問題

    真的是GIGA環境的問題嗎 有點類似網路延遲 我們系統登入者斷掉之後要在進入就會無法進入他會顯示已有相同使用者在裡面

    請教大家有沒有解決方法 感激不盡

    1.目前16PORT HUB 也更換過 

    2. SERVER本來是2008 換成備用 2003 也是一樣問題

    3.不知道是不是SERVER效能不夠

    4.SERVER也更換過 INTEL 網卡 也不行

    5.有將各個辦公室用VLAN切開 但是各個辦公室還是會不定期發生問題

    2013年11月8日 上午 08:25

解答

  • 從描述中,覺得有一點怪,
    文中提到有切 vlan,
    但是環境所使用到的交換器似乎都沒有 vlan 的功能。

    會建議做以下測試,確認問題點:
    1. 找一台 Client 與伺服器端同處一個 Switch。
    確認是否有相同狀況發生,若無,則代表可能是交換器造成的錯誤。
    2. 是否有安裝防毒軟體?
    如果有,請在伺服器及用戶端都暫時「移除」,確認是否有相同狀況。
    3. 如果只有該軟體存檔時會造成這樣的錯誤訊息,
    觀察同時間以網芳方式存取檔案是否會有同樣錯誤。

    若還是無法解決問題,會建議向軟體廠商或者 SI 尋求協助,
    因為這部份可能要收錄兩端的封包,
    並進行分析才有辦法找出問題點。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    • 已標示為解答 林建瑋 2013年11月13日 上午 12:32
    2013年11月11日 上午 03:09
    版主

所有回覆

  • 看看有沒有機會再出問題的機器上收集網路封包吧

    正常與不正常的狀況下各收個3次然後再來討論看看吧


    小白技術沒關係 金錢的力量 決定服務的高低

    2013年11月8日 上午 08:52
  • 請問要如何收集封包
    2013年11月8日 上午 09:39
  • 可以參考小歐前輩的文章來操作

    http://www.dotblogs.com.tw/chou/archive/2010/06/29/16256.aspx


    小白技術沒關係 金錢的力量 決定服務的高低

    2013年11月8日 上午 11:13
  • GB 環境不會影響,有錢的話,裝 10GB 都可以。

    會網路錯誤,通常是電腦參數設錯、網管型 Switch 參數設錯 (這個年代很難買到 Hub ,除非特別去找,一般都是 Switch),或是線路接錯造成迴圈,此外,GB 環境網路線是八芯全用,跟 100MB 只用四芯不一樣,所以也要確認這部分。

    Cat5e 超過 20 m ,會自動降速,若是距離較遠,一定要用 Cat6 的線。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2013年11月8日 下午 12:51
  • 您好謝謝你的指導

    我公司用的hub 是 zyxel 108S

    主線的部分都改成CAT6  但 接到電腦的線還是原來的cat5 沒有更換

    總共有六台 zyxel 都接到前端有一台 BUFFALO 16 PORT LWW3-GT-16NSR

    接線的問題有檢查過是否有迴圈 線頭是否有接好 目前線路部分測試都是正常

    軟體是進銷存廠商說是用DELPHI 寫的 他們的回覆是跟軟體無關


    2013年11月11日 上午 01:06
  • 從描述中,覺得有一點怪,
    文中提到有切 vlan,
    但是環境所使用到的交換器似乎都沒有 vlan 的功能。

    會建議做以下測試,確認問題點:
    1. 找一台 Client 與伺服器端同處一個 Switch。
    確認是否有相同狀況發生,若無,則代表可能是交換器造成的錯誤。
    2. 是否有安裝防毒軟體?
    如果有,請在伺服器及用戶端都暫時「移除」,確認是否有相同狀況。
    3. 如果只有該軟體存檔時會造成這樣的錯誤訊息,
    觀察同時間以網芳方式存取檔案是否會有同樣錯誤。

    若還是無法解決問題,會建議向軟體廠商或者 SI 尋求協助,
    因為這部份可能要收錄兩端的封包,
    並進行分析才有辦法找出問題點。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    • 已標示為解答 林建瑋 2013年11月13日 上午 12:32
    2013年11月11日 上午 03:09
    版主
  • 感謝 之前我有用vlan hub 切過沒有用

    之後才又換回原來的zyxel 108s 再另外找問題

    1.有跟server接到同一個SWITCH 但該電腦還是會出現這樣的情形

    2.伺服器端防毒軟體已有移除,client也有移除,問題還是會出現

    3.同時間網方存取沒有問題,

    4.目前我的方法是把所有的switch通通換成10/100M

    到目前為止兩天暫時還沒有任何問題產生,我會持續觀察看看

    謝謝你我會再向軟體廠商請他們協助

    2013年11月12日 上午 01:18
  • 我的感覺是妳要抓到證據

    廠商才會認錯

    所以假如有時間就抓個網路包給大家看看吧

    看看有沒有辦法幫你抓到問題點

    讓廠商沒有辦法推卸責任


    小白技術沒關係 金錢的力量 決定服務的高低

    2013年11月12日 上午 03:27