locked
Windows Server 2008 R2的.Net Framwork版本問題請教 RRS feed

  • 問題

  • 各位好!

    目前Windows Server 2008 R2中,已經有安裝了Microsoft .NET Framework 4.5.2

    但是,為何在應用程式集區中卻仍顯示為4.0呢?

    找了另外一台Windows Server 2012 R2的來比對,在2012 R2中顯示的就是4.5無誤!

    感謝~

    2017年5月22日 上午 02:19

所有回覆

  • .Net 4.xx 基礎元件為 .Net 4.0

    .Net 2.x/3.x 基礎元件為 .Net 2.0

    .Net 2.0 跟 .Net 4.x 完全沒關係,是獨立的個體。

    在 ASP.NET 應用程式集區為 v4 的,可以跑 4.xx ,v2 的可以跑 2.x/3.x 。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2017年5月22日 下午 12:47
  • .Net 4.xx 基礎元件為 .Net 4.0

    .Net 2.x/3.x 基礎元件為 .Net 2.0

    .Net 2.0 跟 .Net 4.x 完全沒關係,是獨立的個體。

    在 ASP.NET 應用程式集區為 v4 的,可以跑 4.xx ,v2 的可以跑 2.x/3.x 。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    謝謝您的回覆,因為開發團隊那邊測試,發現在Windows Server 2012 R2上面可以正常運作,但是在Windows Server 2008 R2上面運作卻有問題。

    所以才有此一問,感恩 :)

    2017年5月23日 上午 12:44
  • 那麼請注意你站台所使用的集區是啥。預設會執行 DefaultAppPool ,而你的 Win2008r2 的 DefaultAppPool 是 v2 ,不是 v4

    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2017年5月23日 下午 03:04
  • 那麼請注意你站台所使用的集區是啥。預設會執行 DefaultAppPool ,而你的 Win2008r2 的 DefaultAppPool 是 v2 ,不是 v4

    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    謝謝您的回覆,上面的圖片只是示意圖,讓大家了解2012 R2和2008 R2 IIS安裝4.5之後的差異  
    2017年5月24日 上午 12:48