none
Exchange 2010--使用OWA寄信至外部,信件內容亂碼 RRS feed

  • 問題

  • 我司前鎮子升級mail server為Exchange 2010

    目前環境Exchange 2003 & Exchange 2010並存,僅先架好一台CAS+HT,其餘為兩台BE-Sever、一台FE-Server

    在Exchange 2010 加入免責聲明的Transport Rule後,免責聲明的Text僅使用純文字

    但發現若是使用OWA寄信到外部的信件內容會是亂碼,但免責聲明的文字是正常的;免責聲明Rule拿掉後就恢復正常。

    • OWA寄到內部 - 正常
    • OWA寄到外部 - 內容亂碼
    • 使用Outlook寄到內外部 - 正常

    試過了以下方法,都無法解決亂碼的問題

    • 免責聲明用HTML撰寫
    • 在Exchange 2003的server設定 Turn Off Regional Character Settings
    • 在Exchange 2010將OWA字元設定改為永遠使用UTF-8

    想請問有人知道這問題是出在哪裡嗎?? 是否還有其他解決方法??? (被壓著要打開這規則,非常急需解法) 謝謝XD

    2012年2月21日 上午 12:43

解答

所有回覆

  • OWA 是在 Exchange 2003 上還是 Exchange 2010?
    Outlook 會有相同問題嗎?
    HTML 有宣告 character 語言嗎?

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    Windows 7 技術支援中心

    2012年2月21日 上午 06:10
    版主
  • 目前user的mailbox都是在2003上, 連2010 OWA時,自動導入2003 OWA,

    信件出去皆是從2010 連到 MSE 再出去;Outlook 2007寄出去的信件都是正常顯示的, 只有從web寄出的會這樣

    文字內如若為以下:

    <hr>
    <b>%%DisplayName%%</b><br>
    <font size=small>
    %%Department%% - %%Company%% <br>
    %%StreetAddress%% - %%City%% - %%StateOrProvince%% - %%PostalCode%% <br>
    Telephone: %%Phone%% / Fax: %%Fax%% / Mobile: %%MobilePhone%%<br><br>
    </font>
    <h5> <font color=gray>
    The content of this e-mail (including any attachments) is strictly confidential and may be commercially sensitive. If you are not, or believe you may not be, the intended recipient, please advise the sender immediately by return e-mail, delete this e-mail and destroy any copies.
    </h5>

    gmail收到的信件內容會是以下這樣(名字,電話等資訊處理過已拿掉)

    免則是純文字的話,就會像以下圖片顯示


    • 已編輯 DonnaShen 2012年2月21日 上午 06:42
    2012年2月21日 上午 06:41
  • 測試把使用者搬到 Exchange 2010 上看是否會再發生,
    否則就是試著參考這篇文章把 Exchange 2003 的 OWA 強制使用 UTF8,
    又或者直接使用微軟 KB935489 的 Hotfix:An e-mail message is corrupted after the Disclaimer rule is enabled on an Exchange Server 2007 or 2010 server


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    Windows 7 技術支援中心

    • 已提議為解答 AChange 2012年2月24日 上午 05:56
    • 已標示為解答 AChange 2012年2月29日 上午 01:54
    2012年2月22日 上午 07:23
    版主
  • Exchange 2003 的 OWA 強制使用 UTF8 ->這個方法使用過了,還是一樣!!

    前幾天上了Hotfix並重新開開機,一樣無法解決IE開啟OWA寄信,信件內容亂碼問題。

    但昨天使用firefox寄,是可以正常顯示的..... 再改用IE6 IE8寄到gmail,就無法顯示了....

    看了一下原始碼,大概是差在chatset, 一個big5,一個是UTF-8,難不成微軟的瀏覽器會與自家exchange衝突.....??

    • firefox寄送的信件,原始碼顯示如下(擷取片段) --- 正常

        

    • IE寄送的信件,原始碼顯示如下(擷取片段) --- 正常

           內容是一堆數字和英文組成的,正常應該會與firefox一樣顯示正常信件內容才對

         

    2012年3月12日 上午 03:38
  • 問題已解決了~~ 謝謝!!!
    2012年3月14日 上午 01:48