none
請問在 Exchange 2007 如何變更 Helo 的回應 FQDN? RRS feed

  • 問題

  • Dear ALL!
     
     請問在 Exchange 2007 如何變更 Helo 的回應 FQDN呢?之前在 2003 時可以任意更改,但現在在 2007 的集線傳輸/Default XXX
    /指定此連接器為了回應 HELO 或 EHLO 所將提供的 FQDN ,改更時出現以下訊息:
    Microsoft Exchange 錯誤
    --------------------------------------------------------
    儲存變更時發生下列錯誤:
    set-receiveconnector
    失敗
    錯誤:
    當接收連接器上的 AuthMechanism 參數設為 ExchangeServer 值時,您必須將接收連接器上的 FQDN 參數設為下列其中一值: 傳輸伺服器 "MAIL.XXXX.taiwan" 的 FQDN、傳輸伺服器 "MAIL" 的 NetBIOS 名稱或 $null。

    如何才可任意變更,而不受到以上限制呢?麻煩大家了,謝謝!

    最主要我是想解決有的伺服器會回應:#554 A.4 the EHLO/HELO 'MAIL.XXXX.taiwan' has no DNS A or MX records! ##
    而造成退信的狀況!!

              Richard

    2009年6月12日 上午 09:21

解答

所有回覆


  • Exchange Server 2007 SP1 Setup Fails on Hub Transport Role Due to Incorrect FQDN on Receive Connector
    http://technet.microsoft.com/en-us/library/cc671172.aspx 

    How to Modify the Default SMTP Banner
    http://technet.microsoft.com/en-us/library/bb124740.aspx



    #554 A.4 the EHLO/HELO 'MAIL.XXXX.taiwan' has no DNS A or MX records! ##
    而造成退信的狀況!!


    而上述這個問題應該不受receive connector 的影響
    Johnny_Yao
    • 已標示為解答 Dainese 2009年6月15日 上午 07:46
    2009年6月15日 上午 07:27
  • Hello Johnny!
     
     謝謝您的回覆,您的第一個鏈結說明,就是我要修改那個參數時,出現上述問題。
    第二個鏈結說明,修改 Smtp Banner,按指令更改,它還是沒有一樣,呈現原設定值
     
    因為有的 Anti-SPAM system,會檢查對方伺服器回應 EHLO/HELO 後的值,再去檢查此值是否有 DNS A record等
    ,我們的值是內部伺服器 NetBIOS 名稱,所以會有問題,如果改設此郵件伺服器的 FQDN,郵件伺服器也不接受,
    出現相同的錯誤訊息。
     
                        Richard
    2009年6月24日 上午 04:33
  • Hello Johnny!
     
     謝謝您的回覆,您的第一個鏈結說明,就是我要修改那個參數時,出現上述問題。
    第二個鏈結說明,修改 Smtp Banner,按指令更改,它還是沒有一樣,呈現原設定值
     
    因為有的 Anti-SPAM system,會檢查對方伺服器回應 EHLO/HELO 後的值,再去檢查此值是否有 DNS A record等
    ,我們的值是內部伺服器 NetBIOS 名稱,所以會有問題,如果改設此郵件伺服器的 FQDN,郵件伺服器也不接受,
    出現相同的錯誤訊息。
     
                        Richard

    您的問題是指在您寄送到對方的Anti Spam的系統時被拒絕嗎? 若是,那您應該修改的是Send Connector的FQDN
    相反的,若是對方的Anti Spam在寄信到你的Exchagne 2007時會做檢查,那您應該要修改的是你的Receive Connector,
    但若是如此,您的HUB上的Receive Connector上應該要勾選允許匿名存取
    Jammy羅濟棠
    2009年7月19日 下午 03:14
  • 請問一下羅老師:

    是不是 同時安裝 Mailbox server role 的 Hub Transport Server 上設定傳送連接器,此時設定 Send Connector的FQDN就沒有用?

    那這種狀況應該怎麼去設定 Send Connector FQDN??

    2010年5月20日 上午 04:21