locked
WindowsServer7安裝WindowsSystemImageManager(6.1.7077)製作出來的unattend.xml跑完installing update之後重新開機要到enable low-resolution videot去重新設定display settings, RRS feed

  • 問題

  • 各位先進大家好:
    抱歉又打擾了,小弟已經可以成功的使用unattend.xml安裝好一個pure的Windows7(....拖了這麼久。汗)想說可以試試看加入Driver跟不同的language還有其他的軟體的安裝
    在這個目標前進之下,只是目前又遇到一個問題。display setting-->在installing update complete之後出現了意外的狀況-->我只能看到桌面的桌布

    硬體的設定是(還是那兩台機器....嗯-->因為在下手邊比較優的就是他們哥兩好了XD)

    硬體的環境環境如下
    Host:
    OS: Windows Server 7--> ( 應該就是Windows Server 2008吧 )
    CPU : Intel Core 2 Duo P7450 2.13GHz
    RAM : 3GB
    System : Window Server 7 64 bit System
    HDD : 320GB
    Windows System Image Manager Version : 6.1.7077

    Client:
    CPU : P8700 2.53G
    HDD : 500G
    RAM : 2G

    測試的Driver是放在%configsetroot%\AutoUnattend_Files\rcd\w7\0428E01\0428I\Out-of-Box Drivers\Driver1底下的inf檔案(jmcr的Cardreader)
    這版Driver在w7安裝以後可以明顯的發現Device Manager會多出四個不同的裝置所以選擇他
    (其他的driver都不上,因為w7本身裝好就已經不用再安裝了)

    unattend檔案的內容下:

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserData>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                </UserData>
                <DiskConfiguration>
                    <Disk wcm:action="add">
                        <CreatePartitions>
                            <CreatePartition wcm:action="add">
                                <Extend>true</Extend>
                                <Order>1</Order>
                                <Type>Primary</Type>
                            </CreatePartition>
                        </CreatePartitions>
                        <ModifyPartitions>
                            <ModifyPartition wcm:action="add">
                                <Active>true</Active>
                                <Format>NTFS</Format>
                                <Label>0428I</Label>
                                <Letter>C</Letter>
                                <Order>1</Order>
                                <PartitionID>1</PartitionID>
                            </ModifyPartition>
                        </ModifyPartitions>
                        <DiskID>0</DiskID>
                        <WillWipeDisk>true</WillWipeDisk>
                    </Disk>
                    <WillShowUI>OnError</WillShowUI>
                </DiskConfiguration>
                <ImageInstall>
                    <OSImage>
                        <InstallTo>
                            <DiskID>0</DiskID>
                            <PartitionID>1</PartitionID>
                        </InstallTo>
                        <WillShowUI>OnError</WillShowUI>
                    </OSImage>
                </ImageInstall>
                <UseConfigurationSet>true</UseConfigurationSet>
            </component>
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>en-US</UILanguage>
                </SetupUILanguage>
                <InputLocale>en-US</InputLocale>
                <UILanguage>en-US</UILanguage>
                <UserLocale>en-US</UserLocale>
                <SystemLocale>en-US</SystemLocale>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Reseal>
                    <Mode>Audit</Mode>
                </Reseal>
            </component>
            <component name="Microsoft-Windows-PerfCenterCPL" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <WindowsExperienceIndexOemInfo>
                    <HardwareUpgradeURL>http://tpeww</HardwareUpgradeURL>
                    <Logo>c:\Windows\System32\OOBE\info\FABRIKAM_F_ICON_48X48_FINAL_96DPI.BMP</Logo>
                </WindowsExperienceIndexOemInfo>
            </component>
        </settings>
        <settings pass="auditSystem">
            <component name="Microsoft-Windows-PnpCustomizationsNonWinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DriverPaths>
                    <PathAndCredentials wcm:keyValue="23194fa4" wcm:action="add">
                        <Path>%configsetroot%\AutoUnattend_Files\rcd\w7\0428E01\0428I\Out-of-Box Drivers\Driver1</Path>
                    </PathAndCredentials>
                </DriverPaths>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-IE-InternetExplorer" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <FavoritesList>
                    <FavoriteItem wcm:action="add">
                        <FavID>Favorite1</FavID>
                        <FavTitle>Fabrkiam</FavTitle>
                        <FavURL>http://www.fabrikam.com</FavURL>
                    </FavoriteItem>
                </FavoritesList>
                <SearchScopes>
                    <Scope wcm:action="add">
                        <ScopeDisplayName>Wikipedia</ScopeDisplayName>
                        <ScopeKey>Scope1</ScopeKey>
                        <ScopeUrl>http://en.wikipedia.org/wiki/Special:Search:Search?search={searchTeams}</ScopeUrl>
                    </Scope>
                </SearchScopes>
                <StartPages>
                    <StartPage wcm:action="add">
                        <StartPageKey>Home page 1</StartPageKey>
                        <StartPageUrl>http://www.fabrikam.com</StartPageUrl>
                    </StartPage>
                    <StartPage wcm:action="add">
                        <StartPageKey>Home page 2</StartPageKey>
                        <StartPageUrl>http://www.wikipedia.com</StartPageUrl>
                    </StartPage>
                </StartPages>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OEMInformation>
                    <HelpCustomized>false</HelpCustomized>
                    <Logo>c:\Windows\System32\OOBE\info\FABRIKAM_F_ICON_100X100_FINAL_96DPI.BMP</Logo>
                    <Manufacturer>Compal</Manufacturer>
                    <SupportHours>8hr</SupportHours>
                    <SupportPhone>12345678</SupportPhone>
                    <SupportURL>tpewww</SupportURL>
                </OEMInformation>
                <OEMWelcomeCenterLinks>
                    <Link0>c:\FabriKam\Welcome\Welcome.lnk</Link0>
                </OEMWelcomeCenterLinks>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="catalog://win/rcd/w7/sources/install_windows 7 professional.clg" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

    等到安裝程序跑跑~重開機幾次以後(畫面不再是windows的安裝畫面)

    結果
    (聽到了熟悉的開機聲)
    小弟看到那條可愛的鬥魚在畫面的正中央。不過...........只有那一條鬥 魚,其他的東西全部都不知道跑到哪邊去了,不管怎麼動滑鼠就是不知道游標在哪邊。
    小弟嘗試過在那個只有一條魚的畫面

    1. 點選滑鼠右鍵....但是修改設定之後發現...桌面是會有改變(我可以換成葉子也能換成其他的圖片,還可以進去control panel去修改設定),但是不管是怎麼改,資源回收桶還是滑鼠的游標都還不見蹤影

    2. 重新跑unattend.xml再安裝,也還是遇到相同的狀況。

    最後有同事表示再開機的時候按F8切換到enable low-resolution videot這個選項去做設定

    沒錯-->我終於可以看到鬥魚以外的東西了
    只是
    問題還是存在,因為小弟的這個unattend.xml還是沒有寫好,不然怎麼會只看到那條魚......麻煩各位大大幫幫忙一下,卡在這種尷尬的地方真囧,請問一下是哪邊應該要去新增還是要做修改?才能在最後開機以後出現正常的畫面。
    請各位不吝給予指教。謝謝各位的幫忙。

    小弟是在想說會不會是在放圖片的時候路徑設定錯誤還是有哪張圖弄錯了,不過也怪,因為我放的圖片一張都沒有看到,真的很奇怪,小弟會繼續努力的。感謝各位。也麻煩大家了。謝謝。
    2009年4月28日 下午 01:21

所有回覆

  • 你是部屬Windows 7? 還是 Windows Vista?
    如果你用Low-Resolution Video的選項去開啟就可以的話
    問題可能會在顯示卡Driver上面
    可以試試看進入Low-Resolution的模式中去安裝顯卡Driver看看有沒有改善
    2009年4月29日 上午 07:40
  • Vincent大大~感恩~

    小兄弟部署的是windows 7所以目前還是沒有Driver~不過小兄弟用光碟安裝的時候卻不會發生這個問題。所以有此疑問。目前還在繼續找問題當中。如果有找到會PO上來。感恩。
    2009年5月4日 上午 06:06