none
用Word開啟txt檔案的問題 RRS feed

  • 問題

  • 如題,當我用word 2003 開啟txt文字檔,因檔案裡有中文字元

    會出現另一檔案轉檔視窗,要求使用者選擇一文字編碼方式(Windows,MS-DOS,其他編碼方式)來開啟該檔案,選擇windows(預設值)可開啟檔案,並且中文也顯示正常

    有沒有方式可以不要出現轉檔視窗,自動選擇windows(預設值)開啟


    2010年5月20日 上午 07:16

解答

    1. 關閉 Word
    2. 執行 regedit.exe
    3. 找到下列路徑:
      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    4. 新增一個名稱為 DefaultCPG 的 DWORD
    5. 在上個步驟建立的機碼上,連按兩下滑鼠左鍵
    6. 填入 3b6(預設會選用 16 進位),按下確定

    經過上述的設定之後,此後開啟使用記事本存檔的文字檔(亦即編碼為 ANSI 的),就不會再出現轉換的對話視窗了。


    ☞ 這裡是「免費的討論區」付費支援服務請造訪 此處享受尊榮服務
    如果回覆對您有幫助,請記得按下標示為解答」
    在本討論區使用正體中文(即繁體中文),是對參與的朋友的一種尊重,因此請用本討論區的語言:正體中文。
    • 已編輯 Alex Chuo 2010年5月20日 上午 09:13 刪除多餘的文字
    • 已標示為解答 Evan Chung 2010年5月20日 上午 09:13
    2010年5月20日 上午 09:02

所有回覆

  • 這項功能是經過設計的。Word 可能會自動偵測文字檔案中所使用的編碼標準:當檔案的編碼標準符合預設的編碼標準,Word 就會直接開啟檔案。
    ☞ 這裡是「免費的討論區」付費支援服務請造訪 此處享受尊榮服務
    如果回覆對您有幫助,請記得按下標示為解答」
    在本討論區使用正體中文(即繁體中文),是對參與的朋友的一種尊重,因此請用本討論區的語言:正體中文。
    2010年5月20日 上午 07:44
  • Hello Alex 所以沒辦法不要出現這個視窗 有沒有任何設定可以用預設值帶入,不要再出現這提示視窗
    2010年5月20日 上午 08:15
    1. 關閉 Word
    2. 執行 regedit.exe
    3. 找到下列路徑:
      HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Word\Options
    4. 新增一個名稱為 DefaultCPG 的 DWORD
    5. 在上個步驟建立的機碼上,連按兩下滑鼠左鍵
    6. 填入 3b6(預設會選用 16 進位),按下確定

    經過上述的設定之後,此後開啟使用記事本存檔的文字檔(亦即編碼為 ANSI 的),就不會再出現轉換的對話視窗了。


    ☞ 這裡是「免費的討論區」付費支援服務請造訪 此處享受尊榮服務
    如果回覆對您有幫助,請記得按下標示為解答」
    在本討論區使用正體中文(即繁體中文),是對參與的朋友的一種尊重,因此請用本討論區的語言:正體中文。
    • 已編輯 Alex Chuo 2010年5月20日 上午 09:13 刪除多餘的文字
    • 已標示為解答 Evan Chung 2010年5月20日 上午 09:13
    2010年5月20日 上午 09:02
  • Hello Alex

    It's work, thanks a lot

    2010年5月20日 上午 09:14