none
sbs 2008 連線到網路 設定問題 RRS feed

  • 問題

  • 各位大哥

      請問一下  sbs 2008 連線到網路的問題
     環境如下
      兩張網卡  一張直接街 adsl 固定IP
                    另一張 連 lan
      首先啟動 nat 功能  但是在 lan 部分的 ipv4 都沒看到有nat出來
      所以要連線到網路的時候 都一直找到 固定IP 的位置 然後將 lan 那張網卡停用
      畫面顯示 要設定成 192.xxxxx.  ip 才能繼續下一步驟
      導致 無法完成 連線到網路的設定
    2009年7月6日 上午 03:18

解答

  • 針對您的問題回覆如下:
    經過確認後您所描述的架構是不被支援的.
    SBS Server 2008的第一台伺服器只能支援單一網路卡的設定.
    亦即若您安裝了兩張網卡在此伺服器上而執行連線到網際網路精靈時會造成失敗.
    您可以參考下列官方SBS 2008 FAQ中的說明:
    Q. Does Windows Small Business Server 2008 support two network cards?
    A. One NIC is recommended and supported on the Standard Edition server. If you have more than one NIC on the first server, then when the network wizards are run the additional NICs are disabled. Multiple NICs are an advanced scenario; if you want to use multiple NICs you should do so on the Premium Edition server.

    • 已標示為解答 wen-kun chen 2009年7月10日 上午 10:55
    2009年7月10日 上午 10:55

所有回覆

  • 有考慮使用一台防火牆或者IP分享器幫你作NAT的動作嗎?
    畢竟讓你的SBS 2008 直接暴露在Internet上,
    有蠻高的資安風險存在。


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    2009年7月6日 上午 03:57
  • 所以還要再安裝isa server 嗎?

    其次 要知道 為何會這樣

    安不安全是一回事

    能不能用又是一回事

     想知道原因 及解決方式

    感謝你的回答
    2009年7月6日 上午 06:56
  • 如果要Server 2008 作NAT,
    只要安裝「網路原則及存取服務」的角色,
    及啟用「遠端存取服務」及「路由」服務,
    就可以很輕鬆的設定。

    設定方式如下:
    環境說明
    區域連線:對Internet,並含對外閘道及DNS等設定。
    區域連線2:對內部,僅有IP、遮罩及DNS設定。

    到開始->系統管理工具->路由及遠端存取


    選擇NAT。


    勾選欲對外的那張網卡。


    這樣就完成了NAT設定,給您參考看看。

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    2009年7月6日 上午 08:28
  • 所以 我在 wan 那張 ip 設好以後
     lan 那張 ip 設 
     192.168.0.2
     255.255.255.0
    gateway 不設

    dns: 192.168.0.2

    nat 設定的時候 選 wan 那張網卡
      就可以完成 nat & 連線到網路的設定了喔



    ps 我是選 lan 那張網卡


    請問一下 這是甚麼原因

    感恩
    2009年7月6日 上午 09:50
  • 剛剛測試一下

     選 wan or lan 那張
     在 ipv4還是沒有出現nat

    以至於連線到網際網路 還是出現wan ip
     導致於無法完成設定
    2009年7月6日 上午 10:02
  • 事件檢視器那邊有什麼異常的訊息嗎?
    有試過更新網路卡的驅動程式嗎?
    蘇老碎碎念
    資訊無涯,回頭已不見岸
    2009年7月6日 上午 10:27
  • lan driver 沒有更新過 sbs 2008 裝好 就可以正常使用
     asus p5q-e 主機板

    事件檢視器的內容 大都是 dns 的問題
     那是因為 lan 被關掉的原因

    所以 要更新一下 網卡的driver囉

     nat  設定時 要選 wan or lan ?
    2009年7月6日 上午 10:46
  • 可以參考一下第三張圖及環境說明。

    如果網路名稱為「區域連線」是負責對Internet ,
    因此在共用介面就選擇那一張。
    蘇老碎碎念
    資訊無涯,回頭已不見岸
    2009年7月6日 上午 10:54
  • 所以
      當使用 固定IP 的時候  nat 要選 wan 對外那張
      當使用 ppoe or dhcp 的時候 nat 要選 lan 那張

     nat 設好以後 在 ipv4 那兒就會出現 nat 這樣才算是nat設定完成

     可是我就式一直沒辦法看到 ipv4 那兒的 nat 出現

    所以 有可能是網卡的驅動程式 需要更新

    2009年7月6日 上午 11:26
  • 你現在的需求是要讓公司內部的人都透過這台主機上網嗎?
    如果是,才有需要啟動NAT服務。
    而且不太瞭解你說的狀況,
    不是已經有固定IP了,
    為何又冒出使用DHCP 或PPPoE 的問題?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    2009年7月6日 下午 12:32
  • 沒有啦


    只是很單純 要架設 sbs2008
     會用到 exchange & web

    所以會申請固定IP

     只是因為 sbs2008 安裝的時候 若沒有 ans file 就會預設 name.local
     要改成 name.com.tw 才能繼續下一步驟

     要有 name.com.tw 就要先將連線到網路給設定好

    剛好主機有兩張網卡

     所以 就一張連 wan 一張連 lan
      wan 端只勾選 ipv4 其他都沒勾選

    所以是一開始要架設 sbs2008 的設定問題

     目前雖沒有要用主機的nat 來上網
     但是以後會用到


    此外主機網卡程式更換成 vista 64 的驅動程式
    結果還是相同

    此外 我無法將圖片貼出來



    2009年7月6日 下午 04:42
  • 其實我的問題也很簡單

    就是要在兩張網卡 有固定IP的情況下 架設 sbs 2008

    sbs2008 安裝完成以後  第一步就是要連上網路的設定
      之後才有設定你的網際網路位置  這時應該才能設定 name.com.tw

    由於是 固定IP 可以直接上網 外面不需要 nat

    但是為何 sbs 2008 卻一定需要有一個內部網路可以上網的ip 位置 才能完成 連到網路的設定

    這就跟以前的 sbs 2003 差異很大了

    以前的 sbs 2003 發現有其他的 dhcp nat 之類 就不能安裝 要求停用才可以繼續

    為了有 nat 我只好安裝「網路原則及存取服務」的角色

    但是安裝好以後 就始終 看不到ipv4 中的 nat

    所以我就不知道 要如何走下一步


    難道 這樣的環境就無法架設 sbs 2008?

    一定須要先安裝 isa or 有其他的 ip share 才能安裝嗎?
    2009年7月8日 上午 12:27
  • 針對您的問題回覆如下:
    經過確認後您所描述的架構是不被支援的.
    SBS Server 2008的第一台伺服器只能支援單一網路卡的設定.
    亦即若您安裝了兩張網卡在此伺服器上而執行連線到網際網路精靈時會造成失敗.
    您可以參考下列官方SBS 2008 FAQ中的說明:
    Q. Does Windows Small Business Server 2008 support two network cards?
    A. One NIC is recommended and supported on the Standard Edition server. If you have more than one NIC on the first server, then when the network wizards are run the additional NICs are disabled. Multiple NICs are an advanced scenario; if you want to use multiple NICs you should do so on the Premium Edition server.

    • 已標示為解答 wen-kun chen 2009年7月10日 上午 10:55
    2009年7月10日 上午 10:55