none
OpenLDAP 與 Sharepoint 2013 server 的問題 RRS feed

  • 問題

  • 請問一下. 我現在使用 OpenLDAP 作為 Sharepoint 2013 的登入方式之一.

    現在考 這份文件

    http://technet.microsoft.com/en-us/library/ee806890.aspx

    可是在設定完之後. 我在使用者設定是可以找到OpenLDAP 的使用者. 可是我無法用 OpenLDAP 的使用者來登入.

    我的設定檔都跟 technet 文章一樣.

    三個 web.config 的provider 的設定都跟下面一樣

    <membership>
          <providers>
            <add name="LDAPmembership"
                 type="Microsoft.Office.Server.Security.LdapMembershipProvider, Microsoft.Office.Server, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
                 server="172.16.60.3"
                 port="389"
                 
                 useSSL="false"
                 userDNAttribute="CN"
                 userNameAttribute="CN"
                 userContainer="DC=cc,DC=gwinstek,DC=com"
                 userObjectClass="person"
                 userFilter="(ObjectClass=*)"
                 scope="Subtree"
                 otherRequiredUserAttributes="sn,givenname,cn" />
          </providers>
        </membership>
        <roleManager enabled="true" >
          <providers>
            <add name="LDAProle"
                 type="Microsoft.Office.Server.Security.LdapRoleProvider, Microsoft.Office.Server, Version=15.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c"
                 server="172.16.60.3"
                 port="389"
                 useSSL="false"
                 groupContainer="DC=cc,DC=gwinstek,DC=com"
                 groupNameAttribute="CN"
                 groupNameAlternateSearchAttribute="CN"
                 groupMemberAttribute="member"
                 userNameAttribute="CN"
                 dnAttribute="DN"
                 groupFilter="(ObjectClass=*)"
                 userFilter="(ObjectClass=*)"
                 scope="Subtree" />
          </providers>
        </roleManager>

    請教一下

    1.這web.config 是否還有地方需要修正,

    2.還是有別的LDAP 比較建意我們使用(ADAM 除外)

    3.除了這篇還有沒有可以參的文件.

    2013年3月22日 上午 07:08

解答

  • 卡了二個星期多了. 不過我找到問題所在了.

    OpenLDAP 的設定要多加 allow bind_V2 的設定就好. (我是這樣就解決了)

    • 已標示為解答 SP 小白 2013年3月25日 上午 04:03
    2013年3月25日 上午 04:01