none
關於Exchange2007的OWA兩個困擾的問題~ RRS feed

  • 問題

  • 請問各位Exchange的大大~

    我們公司也上了 Exchang2007 (是與Exchange2003共存,仍在信箱移轉中..)

    不過發現EX2007有兩個問題,一直困擾著~以致於還沒完全移轉~

     

    問題(1): 開啟OWA仍會要先跳出基本驗證視窗,成功後才會跳到FormBase驗證畫面.?? 這樣豈不是都要兩次驗證??

    問題(2): OWA驗證時都要輸入Domain\username 這樣真的很困擾,即使已設定了"登入網域"也沒用,這樣真的很困擾??

    說明: 之前EX2003開啟OWA便直接進入FormBase驗證畫面,現在EX2007要先跳出一個基本驗證視窗才進入表單,感覺很怪

               因為這樣就變成驗證兩次,我們已在Exchange主控台->伺服器組態->用戶端存取->OWA-Exchange內容->驗證

                設定了表單型驗證,也指定了登入網域Domain. 仍然會有上述的問題!!

     

    有遇到相同情形的大大們~麻煩您們了!!!

              

     

    2007年8月13日 上午 07:20

解答

  • A1:你們有使用ISA Server 當 Proxy Server 嗎? 或是安裝什麼其他的AP嗎?

     

    A2:你可以到ESM中的Server Configuration ->Client Access-> Click OWA Virtual Directory-> 右鍵 ->properties->

     

    Authentication -> 將 Logon Format 改成 User Name Only。不過這也不是什麼設計不便的問題,只是大家的考量

    點不同。

    2007年8月14日 上午 08:57
    版主
  • 你是透過Exchange 2007 CAS要登入到信箱還在Exchange 2000/2003的User OWA中嗎?

    若是,由於個人目前沒有此環境所以未能測試問題所在

    在此種情況下,你可能無法使用OWA 2007的表單型驗證

    請將你的OWA 2007改為一般的登入方式,且將驗證改為Windows整合驗證

    此外,後端的Exchange 2003的OWA也應該設定與前端的2007相同的驗證方式

    若不是,那麼Exchange 2007 OWA的連線方式應為https://FQDN/owa

     

    2007年8月15日 上午 01:36

所有回覆

  • 在個人的LAB環境下沒有你所說的情況發生

    且Exchange 2007 RTM OWA預設就是使用表單型驗證,不需要再做任何額外的修改

    可以先確認你的Exchange 2007的版本嗎?

    另外,你是從內部去測試OWA還是從Internet?若是從Internet那麼Firewall所對應的OWA Server IP

    是否已經指向Exchange 2007?

     

    2007年8月13日 上午 11:32
  •  

    感謝Jammy的回應~

    不過~OWA重複的驗證的情況~我跟其他工程師的結果都是會發生重覆驗證的情形~您說的沒錯,預設在裝完Exchange2007的OWA便已經是SSL的表單型驗證~

        讓我再重新描述一次問題,我們的Exchange2007為64bit 中/英企業版都有裝過,也更新過Rollup 3彙總套件,Client端是使用公司內部的XP來存取Exchange主機,在開啟IE之後https://ex2007.contoso.com/exchange之後,照理說應隨即進入FormBase驗證畫面,不過在進入表單驗證畫面之前,會先跳出一個基本驗證的Windows視窗,驗證過之後,才會看見表單驗證的畫面,我的問題是=>為何會有2次的驗證?? 這樣的情形每次都會出現!!  

        至於另一個OWA的驗證問題,是需要輸入Domain\User的困擾,當然公司的User是不希望輸入網域\使用者的格式,在們的測試中如果Exchange2007同時也是2003DC或者是MembertServer環境時, 以https://10.10.10.10/exchange的方式 便可以直接輸入USERNAME,如果是Member Server install Exchange2007 Server 便會需要輸入Domain\USERNAME??這樣確實帶來不方便...

     

    2007年8月13日 下午 02:42
  • A1:你們有使用ISA Server 當 Proxy Server 嗎? 或是安裝什麼其他的AP嗎?

     

    A2:你可以到ESM中的Server Configuration ->Client Access-> Click OWA Virtual Directory-> 右鍵 ->properties->

     

    Authentication -> 將 Logon Format 改成 User Name Only。不過這也不是什麼設計不便的問題,只是大家的考量

    點不同。

    2007年8月14日 上午 08:57
    版主
  • 你是透過Exchange 2007 CAS要登入到信箱還在Exchange 2000/2003的User OWA中嗎?

    若是,由於個人目前沒有此環境所以未能測試問題所在

    在此種情況下,你可能無法使用OWA 2007的表單型驗證

    請將你的OWA 2007改為一般的登入方式,且將驗證改為Windows整合驗證

    此外,後端的Exchange 2003的OWA也應該設定與前端的2007相同的驗證方式

    若不是,那麼Exchange 2007 OWA的連線方式應為https://FQDN/owa

     

    2007年8月15日 上午 01:36
  • [問題已解決]
    非常不好意思: 非常感謝Lusheng鄭祿盛+Jammy羅濟棠兩位老師~

    其實我的問題就如兩位老師所提供的資訊.

     

    我把它Summaryㄧ下:
    Q1.為何會有2次驗證的問題~
      答案就如同Jammy所述:
      OWA URL應該是
    https://FQDN/owa
      而我未注意到ㄧ直用的URL是 https://FQDN/Exchange 而導致這個結果 (兩次驗證)
    Q2.為何驗證設定"登入網域",卻仍然是需要Domain\User的Format
      答案是如同Lusheng所述:
      應該在這裡:這樣設定就好了,先前我跑到了\Exchange V.D所以設錯啦!!
      A2:你可以到ESM中的Server Configuration ->Client Access-> Click OWA Virtual Directory-> 右鍵 ->properties->

     

    自己的小疏忽~感謝諸位朋友及老師的熱心回答~~ 謝謝大家!!

     

    2007年8月15日 下午 02:54