locked
關於Autounattend自動回應無法跳過使用者協議 RRS feed

  • 問題

  • 如題,請問各位我在

    Microsoft-Windows-Setup | UserData | AcceptEula

    設置了true但還是會出現下圖的使用者協議

    不知道是不是我弄錯選項了呢(?)

    感謝

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="specialize">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <AutoLogon>
                    <Password>
                        <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Username>Administrator</Username>
                    <Enabled>true</Enabled>
                </AutoLogon>
                <ComputerName>OS</ComputerName>
            </component>
            <component name="Microsoft-Windows-SystemRestore-Main" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DisableSR>1</DisableSR>
            </component>
        </settings>
        <settings pass="windowsPE">
            <component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <UserData>
                    <ProductKey>
                        <WillShowUI>OnError</WillShowUI>
                        <Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
                    </ProductKey>
                    <AcceptEula>true</AcceptEula>
                    <FullName>MX</FullName>
                    <Organization>MX</Organization>
                </UserData>
            </component>
            <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SetupUILanguage>
                    <UILanguage>zh-TW</UILanguage>
                </SetupUILanguage>
                <InputLocale>zh-TW</InputLocale>
                <SystemLocale>zh-TW</SystemLocale>
                <UILanguage>zh-TW</UILanguage>
                <UserLocale>zh-TW</UserLocale>
                <UILanguageFallback>zh-TW</UILanguageFallback>
            </component>
        </settings>
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <OOBE>
                    <NetworkLocation>Other</NetworkLocation>
                    <ProtectYourPC>3</ProtectYourPC>
                    <HideEULAPage>true</HideEULAPage>
                </OOBE>
                <UserAccounts>
                    <AdministratorPassword>
                        <Value>QQBkAG0AaQBuAGkAcwB0AHIAYQB0AG8AcgBQAGEAcwBzAHcAbwByAGQA</Value>
                        <PlainText>false</PlainText>
                    </AdministratorPassword>
                </UserAccounts>
                <AutoLogon>
                    <Password>
                        <Value>UABhAHMAcwB3AG8AcgBkAA==</Value>
                        <PlainText>false</PlainText>
                    </Password>
                    <Username>Administrator</Username>
                    <Enabled>true</Enabled>
                </AutoLogon>
                <TimeZone>Taipei Standard Time</TimeZone>
            </component>
        </settings>
        <settings pass="offlineServicing">
            <component name="Microsoft-Windows-LUA-Settings" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <EnableLUA>false</EnableLUA>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim:install.wim" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>
    


    2015年1月3日 下午 05:30

解答

所有回覆

  • Hi 天烆

    您可以使用WAIK先確認您的設定是否都是正確的

    適用於 Windows® 7 的 Windows® 自動化安裝套件 (AIK)

    如果設定沒有問題,那有可能是您放置Unattend File上的問題,請參考以下KB

    Methods for Running Windows Setup


    請記得將對您有幫助的回覆"標示為解答"以幫助其他尋找解答及參與社群討論的朋友們。

    Please remember to click Mark as Answer on the post that helps you. This can be beneficial to other community members reading the thread.

    • 已標示為解答 memories_tc 2015年1月5日 下午 02:33
    2015年1月5日 上午 02:26
  • 我後來換成x86的

    Microsoft-Windows-Setup | UserData | AcceptEula

    它就沒問題了,雖然不知道為什麼amd64的會沒有效果,感謝您的回覆

    2015年1月5日 下午 02:33