none
請教Terminal Server設定上的問題 RRS feed

  • 問題

  • Dear MVP

     

    您好,想請教一個問題。

     

    當用IE連到遠端的terminal server,時  一般第一個出現的畫面會先要你輸入:(1) Server, (2) Size。這時如果再按"Connect" button, 就會跳出要你輸入USR/PWD的登入畫面。

     

    現在問題是,我希望user 在用IE登入時,(e.g. IE URL 輸入 http:// [server name] / tsweb) 可直接跳過選擇Server & Size的畫面,而直接進入登入的畫面,不知要如何做?

     

    還請不吝賜教,謝謝

    2007年3月27日 上午 06:36

解答

  • Dear Alex,

     

    最後的答案我已經找到了,就是在Terminal Services Configuration 中的Logon Settings 標籤中,點選 "Always use the following logon information" , 並在 Domain 中填入希望預設登入的網域名稱即可。

    還是謝謝您之前的幫助,不好意思問了這麼怪的問題。

     

    Best Regards

    Jimula

     

     

    2007年4月6日 上午 12:48

所有回覆

  • 您好:
    把您不要使用者鍵入的那兩個欄位寫死在網頁中,要求使用者於登入的時候,連到那個寫死的網頁去
    2007年3月29日 上午 01:02
  • Dear sir,

    感謝您的說明,只是不太清楚您的意思。我目前作法是這樣,將 Terminal server 的c:\windows\web\tsweb\default.htm 修改其中的一段VBscript:

    ===========================

    function autoConnect()
     Dim sServer
     Dim iFS, iAutoConnect


     sServer = getQS ("Server")
     iAutoConnect = getQS ("AutoConnect")
     iFS = getQS ("FS")

     if NOT IsNumeric ( iFS ) then
      iFS = 0
     else
      iFS = CInt ( iFS )
     end if

     'if iAutoConnect <> 1 then
     ' autoConnect = false
     ' exit function
     'else
      if iFS < 0 or iFS >= Document.all.comboResolution.options.length then
       iFS = 0
      end if

      if IsNull ( sServer ) or sServer = "" then
       sServer = window.location.hostname
      end if

      Document.all.comboResolution.selectedIndex = iFS
      Document.all.Server.value = sServer

      btnConnect ()

      autoConnect = true
     'end if

    end function
    ==================================

    也就是將上面紅色字體的部份給mark掉,就可直接跳過default.htm的網頁而進入遠端的登入畫面,只是這樣作有一個問題:

    離開terminal server時,點選"叉叉"無法將畫面關掉,它會一直又跳回登入畫面。

     

    另外在登入畫面中,無法讓它登入(log on to...)的下拉表單選擇預設為 "網域"的項目,它會永遠都會將選擇定在"本機電腦"的項目。不知這可不可以在那裏作設定

     

    以上問題再麻煩您解惑,謝謝。

     

    2007年4月1日 上午 08:10
  • Dear Alex,

     

    我找到另一個方法了,就是在連結中在 default.htm 後加上 ?AutoConnect=1 即可,但現在還是有一個問題,就是在登入畫面中,它預設登入的網域為本機電腦(下拉選項停在本機的項目),我如希望它可以預設的下拉選單是選到網域的項目,不知如何可辦到?

     

    Best Regards

    Jimula

    2007年4月4日 上午 05:56
  • Dear Alex,

     

    最後的答案我已經找到了,就是在Terminal Services Configuration 中的Logon Settings 標籤中,點選 "Always use the following logon information" , 並在 Domain 中填入希望預設登入的網域名稱即可。

    還是謝謝您之前的幫助,不好意思問了這麼怪的問題。

     

    Best Regards

    Jimula

     

     

    2007年4月6日 上午 12:48