locked
Window 7 旗艦版,網路分享連線網路磁碟機會顯示無法連線 RRS feed

  • 問題

  • 工作站搭設三台Windows 7 旗艦版,使用網路分享連線網路磁碟機時,開機的時候,有兩台電腦會顯示連線磁碟機是x,無法連線,但啟動時,自動連線有打勾,但還是會出現此情形,重新開機在啟動之後,又可以正常連線,但每次都需要開兩次才會正常,煩請協助確認,為何會出現此情況,感謝

    2014年7月7日 上午 02:51

解答

  • 您好

    我又研究了一下,比較可能的原因可能和蘇老提供的連結說明驗證層級的問題

    我安裝了一台win2003R2 32bit,裝完 查詢安全性原則 2003 只傳送回應NTLM 

    而預設win7 win2008  vista 只傳送 NTLMv2 回應

    所以您測試裝了一台win2008 後,這兩台連線偶爾發生錯誤的問題就沒有發生。

    再來win7預設在工作做群組環境下連線server的分享資料夾,預設先用本機工作群組去做驗證

    也就是說使用你登入的帳號密碼去驗證(PC\user01),雖然帳號密碼和server端都相同,但是我的經驗有時還是會跳出來驗證視窗,變成就要輸入servername\user01 後才能正常連線。

    所以我建議您可以先將win7 & Server 兩端的驗證層級調整一致 ,在試看看狀況有沒有改善

    或是說

    建立一個批次檔放到開機啟動執行,先將所以有網路磁碟中斷再重新連線網路磁碟(批次檔內容如下)

    net use h: /delete /yes

    net use h: \\server ip \folder  /user:servername\id password

    以上提供您參考看看

    • 已提議為解答 chyuanyiin 2014年7月14日 上午 06:18
    • 已標示為解答 George.Chang 2014年7月14日 上午 10:24
    2014年7月11日 上午 05:28

所有回覆

  • 有將 client 指到 網段內的 WINS Server 嗎?若沒有,請使用 IP 連線。

    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2014年7月7日 下午 01:18
  • 報告

    主機系統沒有設定win server  PS:主機系統是鼎新處理的

    環境是用IP分享器建置 要設固定IP嗎?

    以上報告完畢!!!

    2014年7月7日 下午 03:58
  • 您好,

    建議您主機設定固定IP才是.

    Thanks!

    2014年7月8日 上午 03:46
  • 抱歉 忘記說了  主機有設定為內網固定ip值  主機系統為windows 2003server  每次工作站開機後網路磁碟機為xx符號點起時他會出現輸入帳密的畫面 但是輸入最高權限帳密並勾選開機後自動連線 重新開機後仍然出現相同的問題

    不知是不是win7跟windows2003兩者等級不同造成的現象

    尚請協助解答排除問題   感恩.....................

    2014年7月8日 上午 03:58
  • Hi

    先確認一下您的問題

    1.有三部Windows 7旗艦版的電腦

    2.都是透過網路磁碟機連線到Sever 2003所分享的資料夾

    3.其中兩部Windows 7旗艦版電腦,第一次開機的時候無法連線到網路磁碟機,必須再重新開機一次才可以正常連線

    您可以操作並回報以下操作結果

    1.三部Windows 7旗艦版的電腦是否有加入和Server 2003同樣的網域?

    2.您有說Windows 7有設定自動連線,是指網路磁碟機的"登入時重新連線",還是電腦開機時自動透過DHCP連線上網?

    3.在第一次開機時,如果使用 \\主機IP 是否可以連線呢?

    2014年7月8日 上午 06:10
  • 在沒有 WINS Server 的網段裡,每台電腦每 15 分廣播自己跟電腦名一次

    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2014年7月8日 下午 03:05
  • 回報環境內容

    第一台win7是32位元 沒這問題  第2,3台視win7 64位元  << 目前自行判斷 伺服器主機 2003 server是32位元,是否因為位元數不同造成此現象 在不同環境windows2008 server 32位元對應10幾台win7家用進階版64位元沒這問題

    1.有 都用相同的網域名稱 workgroup 預設名稱

    2.兩個設定都對

    3.透過command下指令連結時不論用名稱伺服器或是ip指定都可以連線, 但要輸入伺服器帳密

    以上報告  敬請協助 謝謝


    • 已編輯 chyuanyiin 2014年7月8日 下午 05:11
    2014年7月8日 下午 05:08
  • Hi chyuanyiin

    1.所以您的Server 2003也是workgroup嗎?

    2.如果您的Server 2003也是使用Workgroup的工作群組,那您其他電腦在登入2003的時候,就必須在帳號的部分輸入Server 2003的電腦名稱再搭配Server 2003上已經建立的本機帳號,才可以正確通過驗證。

    3.例如您的Server 2003電腦名稱是SRV2003,上面有一個使用User01,那您在其他Windows 7登入時,必須輸入

       SRV2003\User01 這樣的方式登入,密碼也是User01的密碼

    4.以您圖片上的登入畫面,登入驗證的帳號密碼是"HQ-03"這部電腦帳號密碼,但"HQ-03"的帳號不一定存在Server 2003上,所以才會造成無法登入的問題。

    2014年7月9日 上午 10:31
  • 鼎新的 ERP 請電洽客服處理

    一般鼎新工程師來安裝 Server 端時,會設定 Guest 權限,讓使用者自動以 Guest 登入。而進鼎新系統後,用鼎新的認證方式存取。例如工號+密碼。

    如果你們沒開 Guest 權限,就要在 Server 一個個 Windows 帳號建立。

    文中、鼎新基本上服務還是要每年買,因為因應稅法必須一直改版,既然有買服務,直接叫客服處理就可以了。


    不精確的問法,就會得到隨便猜的答案;自己都不肯花時間好好描述問題,又何必期望網友會認真回答?

    2014年7月9日 下午 01:09
  • 前輩您好

    問題是工作站共有3台 其中一台跟另外兩台只差在位元數不同 一台32bit  另外那2台都是 64bit   但是 32位元的電腦沒這現象 3台設定都是一樣的!!!

    2014年7月9日 下午 05:59
  • 前輩 系謝您撥空回答 不過這問題解決與否應該跟鼎新工程師技術無關吧!!!

    問題點是工作站連線網路磁碟機而不是進鼎新作業環境

    是進windows 2003server連線磁碟機就出現問題 不是開啟應用程式認證問題歐

    還是謝謝您撥空回答

    2014年7月9日 下午 06:02
  • 您好

    您說重開機會無法連線網路磁碟機,當時如果使用\\ip\分享資料夾是否可以?

    我建議如果您這個環境是workgroup

    在你這三台win7 設定host 檔 解析windows 2003 再觀察看看是否有改善

    以上提供您參考

    2014年7月10日 上午 12:09
  • 前輩您好:

    我前面的留言內容與回應資料不知您是否看過? 大致上都實際測試過了

    至於您提的win7 設定host 檔  請問host黨內如何編寫 ? 請指點一、二 謝謝您!!!

    2014年7月10日 上午 01:31
  • 您好

    修改win7 C:\Windows\System32\drivers\etc\hosts 檔案

    參考看看

    2014年7月10日 上午 01:46
  • MIS的背影前輩

    已經實測您提供的方案仍然無效  尚請協助   謝謝您!!!!

    2014年7月10日 上午 07:57
  • 三台電腦的硬體是一樣的嗎?
    譬如網卡型號?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2014年7月10日 上午 08:36
    版主
  • George.Chang 104 MSFT CSG 前輩您好:

    關於您提供的4點我逐一寫下

    1.是的  環境內的電腦群組都是用workgroup這名稱

    2.在windows 2003server有個別建立工作站每台電腦使用者的帳密資料

    3.這點 不知如何操作了 畢竟是要登入伺服器主機 所以應該不可能是輸入工作站的帳密作為驗證資料

    4.這點在第二點已經有回答了

    以上 再次麻煩您費心了

    2014年7月10日 上午 08:49
  • AskaSu
    AskaSu 的 Avatar

    蘇老 前輩您好:

    關於這點以我認知應該跟目前的問題無關才對  PS:有問題的那兩台硬體完全不相同 但運作上都碰到相同的問題 環境系統是一樣的  

    謝謝您提供這不同的思考點

    再次麻煩您了!!


    • 已編輯 chyuanyiin 2014年7月10日 上午 08:51
    2014年7月10日 上午 08:51
  • 請問

    win7登入的電腦帳號密碼和連線分享資料夾的帳號密碼相同嗎?

    2014年7月10日 上午 09:03
  • 帳密與主機設定使用者帳密是一樣的
    2014年7月10日 上午 11:01
  • AskaSu
    AskaSu 的 Avatar

    蘇老 前輩您好:

    關於這點以我認知應該跟目前的問題無關才對  PS:有問題的那兩台硬體完全不相同 但運作上都碰到相同的問題 環境系統是一樣的  

    謝謝您提供這不同的思考點

    再次麻煩您了!!


    在解決問題的方向上,我自己是不會認為無關就不去嘗試,
    可以的話,還是建議提供網卡型號,
    讓大家幫你找尋看有無新版的驅動程式。

    另外,有問題的電腦是否剛好也有安裝同樣的防毒軟體,
    或其他同樣有安裝的軟體?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    2014年7月10日 下午 12:58
    版主
  • 蘇老您好:

    我想 沒有人願意像我一樣花更多時間去做排除問題的測試了 >>>題外話

    為了排除這問題也證明我之前的分析 我做了一個測試

    就是重新安裝一台伺服器  windows 2008 server 32bit(這是要確認是不是位元數產生的或是系統本身的問題)

    經由測試得證

    問題出在windows 2003 server系統本身所造成的

    簡單說應該是windows 7 與 windows 2003 server等級上的差異 造成上下層的權限關係衍生這問題

    提供大家參考 這是我個人在之前的提問回報就有寫上來的分析

    但卻沒有人願意就這方向提供見解

    不是在怪各位先進 而是 技術本身就會有盲點   每個人的專業有時候會導引到不同的方想與思考邏輯

    碰到我這基礎差的 就只好透過碰撞學理(亂碰亂撞)總有一次會碰到

    不曉得目前我碰到的是不是真理 還希望各位前輩能針對我寫的 提供不同見解

    以上 謝謝謝各位熱心的解答 !!


    • 已編輯 chyuanyiin 2014年7月11日 上午 01:09
    2014年7月11日 上午 01:08
  • 我剛想到另一種狀況,
    嘗試將 Windows 7 的驗證模式等級修改看看,
    這部分可以參考黑暗執行緒的文章
    【茶包射手專欄】Vista/Windows 7無法登入網站及網路芳鄰

    另外,您認為問題是出在 Server 2003 本身系統所造成的,
    但是我在以前的公司也是這樣掛載網路磁碟機,
    卻沒有遇到相同的狀況,
    畢竟論壇也接觸不到你的環境,
    只能就可能的經驗討論或針對問題給予方向,
    就不清楚你想得到的見解是什麼?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案

    • 已提議為解答 chyuanyiin 2014年7月14日 上午 06:19
    2014年7月11日 上午 02:17
    版主
  • Hi chyuanyiin

    網路的檔案共享都是統一使用SMB這個相同的協定,不論是哪一版本的Server或Client,其它非微軟的系統只要使用SMB協定,都可以和微軟的伺服器做檔案存取,所以才會比較沒有從位元的角度來剖析您的問題。

    從您這幾個回覆,都是可以連線到伺服器,但問題出在使用者帳號密碼驗證不過

    上面提到的問題,的這個操作方式

    3.例如您的Server 2003電腦名稱是SRV2003,上面有一個使用User01,那您在其他Windows 7登入時,必須輸入

       SRV2003\User01 這樣的方式登入,密碼也是User01的密碼

    請參考 http://support.microsoft.com/kb/315621/zh-tw

    2014年7月11日 上午 03:15
  • 您好

    我又研究了一下,比較可能的原因可能和蘇老提供的連結說明驗證層級的問題

    我安裝了一台win2003R2 32bit,裝完 查詢安全性原則 2003 只傳送回應NTLM 

    而預設win7 win2008  vista 只傳送 NTLMv2 回應

    所以您測試裝了一台win2008 後,這兩台連線偶爾發生錯誤的問題就沒有發生。

    再來win7預設在工作做群組環境下連線server的分享資料夾,預設先用本機工作群組去做驗證

    也就是說使用你登入的帳號密碼去驗證(PC\user01),雖然帳號密碼和server端都相同,但是我的經驗有時還是會跳出來驗證視窗,變成就要輸入servername\user01 後才能正常連線。

    所以我建議您可以先將win7 & Server 兩端的驗證層級調整一致 ,在試看看狀況有沒有改善

    或是說

    建立一個批次檔放到開機啟動執行,先將所以有網路磁碟中斷再重新連線網路磁碟(批次檔內容如下)

    net use h: /delete /yes

    net use h: \\server ip \folder  /user:servername\id password

    以上提供您參考看看

    • 已提議為解答 chyuanyiin 2014年7月14日 上午 06:18
    • 已標示為解答 George.Chang 2014年7月14日 上午 10:24
    2014年7月11日 上午 05:28
  • Hi

    針對您對於位元版本的疑慮,我實際模擬您的使用環境,結果確認是不會因為版本或位元差異造成無法連線的問題,以下是我的測試環境。

    1.Server 2003 企業版 SP2 32位元

    • 電腦名稱:S2003
    • IP:192.168.100.120
    • 工作群組:Workgroup
    • E碟分享資料夾ERPdb,給使用者Ben完全存取的權限

    2.Windows 8.1 with update 64位元

    • 電腦名稱:User-81-PC
    • IP:192.168.100.7
    • 工作群組:Workgroup
    • 網路磁碟機Z,連線到 \\S2003\ERPdb ,輸入帳號:S2003\Ben,密碼:ben1234,勾選記憶密碼
    • 重複測試開關機數次,都可以正常連線到網路磁碟機Z

    2014年7月11日 上午 05:28
  • 謝謝指導

    星期一上班再做測試  有進展在行提報

    2014年7月13日 下午 05:27

  • MIS的背影

    前輩您的第一點分析是真理   透過驗證層級修正(工作站)  就把此問題解決了也謝謝其他前輩不辭辛勞的協助提供解決方案  感恩....!

    至於第二點方案也經由實測得到也是可行的替代方案   不過有一點必須提報出來就是

    net use h: /delete /yes

    net use h: \\server ip \folder  /user:servername\id password

    必須是沒用到的磁碟對應  也就是說要做一個假的對應磁碟騙系統   然後真正的連線磁碟機才能正確使用  PS:一定要設家的磁碟機代號  真正原因尚待有興去的前輩解說!!!

    net use Y: /delete /yes

    net use Y: \\192.168.1.110\erpdb /hq-112:erpdb\hq-112 abAS3352

    如果依照批次檔的設定   則重新開機後 連線磁碟機Y 會不見且產生如圖顯示之錯誤訊息,但是其他的網路磁碟機卻可正常使用!!  <<  不解  依照批次檔內容應該是可成立的

    工作站安裝完成後內定驗證等級如圖所示





    • 已編輯 chyuanyiin 2014年7月14日 上午 06:29
    2014年7月14日 上午 06:18
  • George.Chang 104  前輩您好  

    不好意思 讓您花那麼多時間實測  感恩...

    因為環境的不同造成您提供的解決方案無法適用    還是感激您的熱心

    謝謝您!!!!

    2014年7月14日 上午 06:31