none
Active Directory作業於"主機"失敗。在聯繫作業提供給"網域\administrator"的認證無效。錯誤碼 0x31。他的執行命令是"Get-ExchangeAdministrator"。 RRS feed

  • 問題

  • Dear all

    今天開啟Exchange控制台時出現這個錯誤訊息,找不到相關錯誤,相當煩惱,麻煩各位前輩幫小弟看一下。

    另外還伴隨著兩個錯誤

     

    --------------------------------------------------------
    Microsoft Exchange 錯誤
    --------------------------------------------------------
    載入拓撲資訊時回報了下列錯誤:

    get-ExchangeServer
    失敗
    錯誤:
    Active Directory 作業於 JFTWSRV41.jagfamily.local 失敗。在 繫結 作業提供給 'JFTWSRV08\Administrator' 的認證無效。錯誤碼: 0x31。

    提供的認證無效。

     

     

    get-UMServer
    失敗
    錯誤:
    Active Directory 作業於 JFTWSRV41.jagfamily.local 失敗。在 繫結 作業提供給 'JFTWSRV08\Administrator' 的認證無效。錯誤碼: 0x31。

    提供的認證無效。

     


    --------------------------------------------------------
    確定
    --------------------------------------------------------

     

    • 已變更類型 AChange 2011年4月11日 上午 01:22
    • 已變更類型 AChange 2011年4月18日 上午 06:50
    2011年4月1日 上午 03:21

解答

  • 今天我很認真地把每一台主機裡面的遠端帳戶全部中斷,然後將Exchange 重開機,在使用網域帳戶登入就沒有出現錯誤訊息了。

    因此Lusheng前輩說的沒錯,或許有使用者使用本機帳戶登入其中某台導致這個情況發生,因為登入時有出現 本機名稱\帳戶  的登入方式,改成 網域\帳戶 登入就沒有錯誤訊息可以正常開啟。

    感謝!

    • 已標示為解答 AChange 2011年4月18日 上午 06:51
    2011年4月12日 上午 06:46

所有回覆

  • 你好:

    試試開啟控制台 -> 使用者帳戶 -> 管理您的網路密碼 -> 清掉所有濟助的密碼,重新開機 在試試。


    Lusheng
    2011年4月1日 上午 03:58
    版主
  • 您好:

    我剛剛確認過了裡面沒有任何密碼呢...

    2011年4月1日 上午 04:14
  • 確認一下,你是登入網域中的帳號吧。
    Lusheng
    2011年4月1日 上午 04:20
    版主
  • 是的。是登入網域的帳戶。

    2011年4月1日 上午 04:28
  • 如果是 這樣,你是用 runas 試試吧。
    Lusheng
    2011年4月1日 上午 04:39
    版主
  • 用 Runas 執行 ESM 試試吧。
    Lusheng
    2011年4月1日 上午 05:22
    版主
  • Runas

    範例:
    > runas /noprofile /user:mymachine\administrator cmd
    > runas /profile /env /user:mydomain\admin "mmc %windir%\system32\dsa.msc"
    > runas /env /user:user@domain.microsoft.com "notepad \"my file.txt\""

    請問是哪一總呢??

    不好意思第一次使用Runas,不熟悉。

    2011年4月1日 上午 06:24
  • 在 Exchange 管理控指台 按住 shift + 滑鼠右鍵 -> 以系統管理身分執行,使用domain\administrator 執行。
    Lusheng
    2011年4月1日 上午 06:31
    版主
  • 您好,執行了之後還是會有錯誤呢。

    我抓了圖,請看謝謝。

    https://lh5.googleusercontent.com/_hcYxv65XAbQ/TZVy3H3jvFI/AAAAAAAAAK0/aRekB8ecUtY/s576/exchange.jpg

    2011年4月1日 上午 06:39
  • 在該台電腦 執行 dcdiag 試試吧。看看有什麼錯誤。
    Lusheng
    2011年4月1日 上午 07:06
    版主
  • 您好:

    執行之後沒有其他問題呢。更新問題是我有另外設定wsus...Microsoft Windows [版本 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Users\administrator.JAGFAMILYTW>dcdiag

    目錄伺服器診斷

    正在執行初始安裝程式:
       嘗試尋找主伺服器...
       主伺服器 = JFTWSRV41
       * 識別的 AD 樹系。
       已完成收集初始資訊。

    正在執行初始的必要測試

       正在測試伺服器: ADSite-CCC\JFTWSRV41
          正在啟動測試: Connectivity
             ......................... JFTWSRV41 通過測試 Connectivity

    正在執行主要測試

       正在測試伺服器: ADSite-CCC\JFTWSRV41
          正在啟動測試: Advertising
             ......................... JFTWSRV41 通過測試 Advertising
          正在啟動測試: FrsEvent
             ......................... JFTWSRV41 通過測試 FrsEvent
          正在啟動測試: DFSREvent
             ......................... JFTWSRV41 通過測試 DFSREvent
          正在啟動測試: SysVolCheck
             ......................... JFTWSRV41 通過測試 SysVolCheck
          正在啟動測試: KccEvent
             ......................... JFTWSRV41 通過測試 KccEvent
          正在啟動測試: KnowsOfRoleHolders
             ......................... JFTWSRV41 通過測試 KnowsOfRoleHolders
          正在啟動測試: MachineAccount
             ......................... JFTWSRV41 通過測試 MachineAccount
          正在啟動測試: NCSecDesc
             ......................... JFTWSRV41 通過測試 NCSecDesc
          正在啟動測試: NetLogons
             ......................... JFTWSRV41 通過測試 NetLogons
          正在啟動測試: ObjectsReplicated
             ......................... JFTWSRV41 通過測試 ObjectsReplicated
          正在啟動測試: Replications
             ......................... JFTWSRV41 通過測試 Replications
          正在啟動測試: RidManager
             ......................... JFTWSRV41 通過測試 RidManager
          正在啟動測試: Services
             ......................... JFTWSRV41 通過測試 Services
          正在啟動測試: SystemLog
             發生警告事件。EventID: 0x00000010
                產生時間: 04/01/2011   14:50:07
                事件字串:
                無法連線: Windows 無法連線到自動更新服務,因此無法根據設定的排程下載
    和安裝更新。Windows 將繼續嘗試建立連線。
             發生警告事件。EventID: 0x000003FC
                產生時間: 04/01/2011   15:20:48
                事件字串: 領域 192.168.1.0 已使用百分之 100,只剩下 0 個 IP 位址。
             ......................... JFTWSRV41 通過測試 SystemLog
          正在啟動測試: VerifyReferences
             ......................... JFTWSRV41 通過測試 VerifyReferences


       正在執行分割測試的位置 : ForestDnsZones
          正在啟動測試: CheckSDRefDom
             ......................... ForestDnsZones 通過測試 CheckSDRefDom
          正在啟動測試: CrossRefValidation
             ......................... ForestDnsZones 通過測試 CrossRefValidation

       正在執行分割測試的位置 : DomainDnsZones
          正在啟動測試: CheckSDRefDom
             ......................... DomainDnsZones 通過測試 CheckSDRefDom
          正在啟動測試: CrossRefValidation
             ......................... DomainDnsZones 通過測試 CrossRefValidation

       正在執行分割測試的位置 : Schema
          正在啟動測試: CheckSDRefDom
             ......................... Schema 通過測試 CheckSDRefDom
          正在啟動測試: CrossRefValidation
             ......................... Schema 通過測試 CrossRefValidation

       正在執行分割測試的位置 : Configuration
          正在啟動測試: CheckSDRefDom
             ......................... Configuration 通過測試 CheckSDRefDom
          正在啟動測試: CrossRefValidation
             ......................... Configuration 通過測試 CrossRefValidation

       正在執行分割測試的位置 : jagfamily
          正在啟動測試: CheckSDRefDom
             ......................... jagfamily 通過測試 CheckSDRefDom
          正在啟動測試: CrossRefValidation
             ......................... jagfamily 通過測試 CrossRefValidation

       正在執行企業測試的位置 : jagfamily.local
          正在啟動測試: LocatorCheck
             ......................... jagfamily.local 通過測試 LocatorCheck
          正在啟動測試: Intersite
             ......................... jagfamily.local 通過測試 Intersite

    C:\Users\administrator.JAGFAMILYTW>

    2011年4月1日 上午 07:34
  • 各位前輩....沒有方法可以處理嗎???

    2011年4月3日 上午 08:11
  • 你的主機看起來似乎是SBS,
    有試過用其他具有管理權限的帳號登入是否正常呢?

    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    2011年4月4日 上午 02:59
    版主
  • 您好.

    主機不是SBS,是獨立Win2k3 x64 + Exchange 2007,目前距管理權限的帳戶只有Adminstrator,其他不給管理權限.....

    跟做HA有關係嗎??

    2011年4月7日 上午 10:58
  • 你的 HA 建立方式及其網路環境方便描述一下嗎?


    蘇老碎碎念
    資訊無涯,回頭已不見岸
    好用的微軟技術支援小工具
    Facebook - 微軟台灣官方論壇愛好者俱樂部
    如何在論壇正確發問,請參考iThome的文章: 如何問到我要的答案
    2011年4月7日 下午 02:23
    版主
  • 兩台Exchange跑HA然後前端有一台CAS,設定由CAS這台設定。

    2011年4月8日 上午 02:56
  •  在其他台Exchange 開啟 EMC 也會如此嗎??


    Lusheng
    2011年4月8日 上午 07:34
    版主
  • 是的,其他台開也會如此。
    2011年4月8日 上午 10:12
  • 去開 Case  給CSS 吧。
    Lusheng
    2011年4月8日 上午 10:45
    版主
  • 今天我很認真地把每一台主機裡面的遠端帳戶全部中斷,然後將Exchange 重開機,在使用網域帳戶登入就沒有出現錯誤訊息了。

    因此Lusheng前輩說的沒錯,或許有使用者使用本機帳戶登入其中某台導致這個情況發生,因為登入時有出現 本機名稱\帳戶  的登入方式,改成 網域\帳戶 登入就沒有錯誤訊息可以正常開啟。

    感謝!

    • 已標示為解答 AChange 2011年4月18日 上午 06:51
    2011年4月12日 上午 06:46