locked
OSD drive letter RRS feed

  • Question

  • sccm 2012 sp1 cu01 MDT deploying Windows 7 OSD 32bit

    ok, this is really getting pathetic.

    Why are some OSD'd going to ANTHING other than C? I captured my original from a c:\ host machine not the media. 80% of new OSD'd are fine but out of the blue I get deployments to D, E, F what a frickin' joke! When i do a diskpart I noticed that the USB got C so I changed the drive letter and re-ran the task, no luck.

    I never, not once had these problems with SCCM 2007.

    What gives experts? How do I force OS on C?

    Update: Just for grins I tried the Windows 8 32bit OSD and it installed correctly on the C drive.

    Both images were captured from C and both Tasks / MDT are pretty much identical.

    Any ideas?



    • Edited by jamicon Sunday, July 7, 2013 4:10 PM sup
    Sunday, July 7, 2013 12:12 AM

All replies

  • Have you tried with Task Sequence variable OSDPreserveDriveLetter?

    See: http://technet.microsoft.com/en-us/library/hh273375.aspx

    Sunday, July 7, 2013 6:14 PM
  • By default in an MDT task sequence in ConfigMgr the bitlocker partition is assigned a drive letter, even though it shouldn't be, go in to the formatting steps and remove the checkbox to assign the bitlocker partition a drive letter.

    Also make sure you've imported the Windows 7 Image as an "Operating System Image" rather than an "Operating System Installer" 

    Monday, July 8, 2013 12:59 AM
  • not only is mine already set to False the imaged captured from was C:\ anyway. But thanks for your reply.
    or... Since I know my image was c:\ then maybe I should have it set to True??

    But my Windows 8 image is set the same way and it installed correctly??

    • Edited by jamicon Monday, July 8, 2013 12:26 PM update
    Monday, July 8, 2013 12:21 PM
  • thanks for your reply

    Ya I went through those problems already and just removed that all together.

    yes, they are under Images.

    Monday, July 8, 2013 12:28 PM
  • That is the default behavior of windows 7 deployment, even if your image was on C:\ it won't work unless set the variable OSDPreserveDriveLetter to false,but in order for that to work you must have SCCM 2012 SP1, without the SP1 it won't work,i am only speaking out of my experience, it has something to do with the default behavior of windows 7.

    On the other hand windows 8 was made to behave differently.

    See attached snapshots of how i am doing that and i am getting successful deployments to C:\ drive now. 


    Regards,

    Ahmad


    Regards, Ahmad

    • Proposed as answer by Ahmad AlAbbadi Thursday, July 11, 2013 5:59 AM
    Tuesday, July 9, 2013 4:30 AM
  • If your image came from a system where the drive letter was C:, then actually the OSDPreserveDriveLetter variable should be set to TRUE.  This will honor the drive letter given to the captured OS and not whatever occurs as a result of the partitioning layout during WinPE.

    My Personal Blog: http://madluka.wordpress.com

    Tuesday, July 9, 2013 9:08 AM
  • Thank you very much, I will try this and let you know how it goes.

    One question, was the partition properties changes under "Format and Partition Disk 6.1" only?

    Looks like all we've done is change the variable name from OSDisk to Windows, how does that help? Thanks.

    One other difference, "Make this as the boot partition" is only selected on 5.x and nothing else, is that the key? Note that these TS were generated by the MDT.

    Its just crazy that sometimes it works fine and sometimes they get the wrong drive letter, I'd just like to understand the logic. Does seem to happen more on laptops that come with multiple partitions.

     

    Thanks again.



    • Edited by jamicon Tuesday, July 9, 2013 12:57 PM info
    Tuesday, July 9, 2013 11:45 AM
  • update:

    Based on everything above I threw up a hyperv test environment.

    Virtual Machine:

    4 GB Memory
    Disk 1 2 partitions, 30 GB
    Disk 2 1 partition, 10 GB
    Disk 3 SCSI 2 partitions, 10 GB

    Task Sequense

    TS1 - My original, the one that randomly install OS on wrong drive letter
    TS2 - set OSDPreserveDriveLetter = True (MadLuka)
    TS3 - Variable = Windows, Make this the boot partition (Ahmad AlAbbadi)


    Results

    all 3 Task(s) installed successfully on the C drive


    Clearly this proves nothing. So back to my physical laptop a few days ago and
    Why was it always going to the E drive; even after I did F8 > Dispart and removed
    all volumes and performed a clean on the disk.

    NOte: This is randomly happening in our production environment and I really
    to get a handle on this. Thanks for your help.

    Tuesday, July 9, 2013 1:58 PM