none
PSExec on remote server giving Program Exit code:-1073741502

    Question

  • Hi,

    I am using PS Exec in Command Prompt Activity on remote Server.

    Command:

    psexec -n 300 -d -h -e -u "UserName" -p "Password" \\ServerName cmd /c "mycommand"

    But I am getting "-1073741502" Exit code.

    The same command I am able to run using Command Prompt from Orchestrator Server.

    Help me.

    Regards,

    Abhi

    Wednesday, April 24, 2013 3:03 AM

Answers

  • Hi Abhi,

    I don't know why you do not run the command ("mycommand") directly with the "Run Program" Activity on the target system ("ServerName").

    Anyway, ... On the computer you run psexec with the"Run Program" Activity  from Orchestrator uncheck the "Allow service to interact with desktop" option of the "Orchestrator Run Program Service".

    If you still get the error it might be a good idea to paste the complete error message here.

    Regards,

    Stefan


    www.sc-orchestrator.eu , Blog sc-orchestrator.eu

    Wednesday, April 24, 2013 7:31 AM
    Answerer

All replies

  • Hi Abhi,

    I don't know why you do not run the command ("mycommand") directly with the "Run Program" Activity on the target system ("ServerName").

    Anyway, ... On the computer you run psexec with the"Run Program" Activity  from Orchestrator uncheck the "Allow service to interact with desktop" option of the "Orchestrator Run Program Service".

    If you still get the error it might be a good idea to paste the complete error message here.

    Regards,

    Stefan


    www.sc-orchestrator.eu , Blog sc-orchestrator.eu

    Wednesday, April 24, 2013 7:31 AM
    Answerer
  • Hello Stefan,

    Did that change ( Unchecking ) after a lot of research on the net.

    Now, after seeing your post with same solution, I think I can test it. Will test and will get back.

    As you have mentioned running the command directly on the target system, some times it is giving me Win RM Client Exception. So went to PS Exec.

    Any idea on this ?

    Thanks,

    Abhi

    Wednesday, April 24, 2013 7:52 AM
  • I think it is done.

    Not getting errors any more.

    Thanks Stefan.

    Regards,

    Abhi


    Wednesday, April 24, 2013 8:22 AM
  • Hi Stefan,

    We have this problem and unchecking that box does solve the issue. However, we don't want to cause any issues with existing runbooks that use the Run Program activity. Do you have any idea what impact it may have with other runbooks?

    Cheers,

    Stu

    Monday, March 21, 2016 3:26 PM