SCVMM 2012R2 Update Rollup 12. Unable to change VM network on virtual network adapter RRS feed

  • Question

  • Hi,

    2 days ago i've installed rollup 12 in SCVMM 2012R2. Update went fine, no errors, updated all agents on hosts. After update, if i open VM hardware configuration and want cahnge Network adapter VM network - i get error:

    The specified VLAN configuration is not valid.

    Ensure that the virtual network adapter is connected to a virtual switch, that a valid VLAN ID is specified, and then try the operation again.

    ID: 10605

    VMM configuration didn't change and right before update i could do those changes. 

    I can change vm network from powershell and no problem with vm network configuration while deploying VM from template. Any ideas?

    Friday, February 3, 2017 1:36 PM

All replies

  • are all your Logical Networks showing Fully compliant in the Fabric?

    I would also try failing over your SCVMM role to another cluster node so it purges out any problematic jobs in the queue - assuming it's not running as standalone

    • Edited by armin19 Tuesday, February 7, 2017 1:47 PM
    Tuesday, February 7, 2017 1:46 PM
  • Hi,

    I have the same problem after update scvmm rollup 12, unable to update VM network on virtual network adapter.

    any ideas ?

    Wednesday, February 8, 2017 9:14 AM
  • Try to change the VM network in the failover cluster (if you use Hyper-V) instead of in VMM. I have had to do this a few times. It's a workaround though, and not a real solution to the problem
    Thursday, February 9, 2017 12:41 PM
  • Hi Sir,

    Have you tried to use powershell script to change Vlan setting ?

    To get the script you may click "view script" after you changed VLAN in VM property:


    Best Regards,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact

    Friday, February 10, 2017 5:15 AM
  • Hello Elton,

    I analyzed the script using the "View Script" facility provided by System Center as you suggested. I noticed that VlanId switch is missing for the command "Set-SCVirtualNetworkAdapter" so the "VLAN ID" selected in the GUI is ignored and the operation fails.

    This is the relevant command:

    Set-SCVirtualNetworkAdapter -VirtualNetworkAdapter $VirtualNetworkAdapter -VMNetwork $VMNetwork -VMSubnet $VMSubnet -VLanEnabled $true -VirtualNetwork "Teaming Logical Switch - HVCL02 - NPAR4" -IPv4AddressType Dynamic -IPv6AddressType Dynamic -NoPortClassification -JobGroup 7a513fdf-e8ac-466b-b9d6-e929fb1b8f7b

    Assuming we want the adapter to be connected in Access mode to the VLAN 10 we have to add the parameter "-VlanId 10" to the command. Executing the corrected portion of code using powershell it works.

    This is the relevant corrected command (in my scenario with VLAN ID: 10):

    Set-SCVirtualNetworkAdapter -VirtualNetworkAdapter $VirtualNetworkAdapter -VMNetwork $VMNetwork -VMSubnet $VMSubnet -VLanEnabled $true -VlanId 10 -VirtualNetwork "Teaming Logical Switch - HVCL02 - NPAR4" -IPv4AddressType Dynamic -IPv6AddressType Dynamic -NoPortClassification -JobGroup 7a513fdf-e8ac-466b-b9d6-e929fb1b8f7b 

    This is an important issue since in our company some operators works only using GUI. I hope that a hotfix will be released by Microsoft soon.

    Kind regards,


    • Edited by C0ReDuMPX Sunday, February 12, 2017 6:23 PM
    Sunday, February 12, 2017 6:22 PM
  • this issue now seems to be a known issue under the rollup 12 kb:

    no word on when it will be resolved or if it will be part of the next rollup

    Thursday, February 23, 2017 8:30 PM
  • MS has released Hotfix for UR12 3.2.8292.20  this seems to have fixed most issues with vlan.

    I have found there is still an issue if you clone a VM that has NIC connected you still get "The Specified VLAN configuration is not valid".  Temporary workaround is disconnect NIC before cloning or set NIC to not connected during the clone.

    Has anyone else seen this or confirm Microsoft knows this is still an issue?  I can open a case if necessary.


    Wednesday, April 26, 2017 6:27 PM
  • This issue still (or again) exists in SC VMM 2012 R2 Update Rollup 14. Any Solutions for this?
    Wednesday, February 7, 2018 8:27 AM