locked
SharePoint 2010 Date Columns are not Indexing (or searchable) RRS feed

  • Question

  • I have a 2010 Record Center.  Indexing and search functions seem to be working.  However, searching dates does not produce results.  The date column is marked for indexing.  Crawling is working and I do get other text type results.  I have tried switching the column to Date & Time in the detailed column settings.  With or withouth the time, it does not come up in the results. 

    There is an interesting twist.  On SOME, the search returns the AllItems.aspx PAGE (not the document or list item itself) that it resides on with the searched date highlighted in the result item description.


    North to the Future
    Tuesday, October 5, 2010 11:29 PM

Answers

  • How are you doing your searching? Are you just typing in the date in the upper right hand corner search box, or are you typing in the name of the managed property and the date value? In order to search on date values from SharePoint fields you must set up a managed property that maps the crawled property of your SharePoint field, then do a full crawl. After that type in the managed property name : value. For example datefield:12/31/2009.

    http://technet.microsoft.com/en-us/library/cc164182.aspx


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    • Marked as answer by steve.fink Wednesday, October 6, 2010 10:12 PM
    Wednesday, October 6, 2010 3:00 AM

All replies

  • How are you doing your searching? Are you just typing in the date in the upper right hand corner search box, or are you typing in the name of the managed property and the date value? In order to search on date values from SharePoint fields you must set up a managed property that maps the crawled property of your SharePoint field, then do a full crawl. After that type in the managed property name : value. For example datefield:12/31/2009.

    http://technet.microsoft.com/en-us/library/cc164182.aspx


    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    • Marked as answer by steve.fink Wednesday, October 6, 2010 10:12 PM
    Wednesday, October 6, 2010 3:00 AM
  • Steve, thank you! Managed properties and crawled properties just became part of my vocabulary thanks to you, even though I do not completely understand it.

    Yes I was just typing the date in the top right corner search field and exactly in the format given in the date column (copied and pasted to test). I was able to follow the directions in Technet to map the property and value as you prescribed.  However the instructions indicate that this is to be used with "Search Server 2010".  I do know what that is, but as far as I know, I do not have Search server installed anywhere on our network.  Yet all the settings as described on Technet exist and I was able to configure them.

    I am still getting the same results as described in my problem posted.  Are you suggesting that I use Search server instead of the built in search?  If I must I will, but prefer not to since I am woring in a low volume user environment and dont want to add any more complexity to an otherwise low to medium technical level project.  I am the only SP Admin here supporting only 80 users, in addition to many other roles I serve in our department.  The built in search suits my needs and with the other data, is quick and accurate.  K.I.S.S. if possible. 


    North to the Future
    Wednesday, October 6, 2010 6:56 PM
  • Steve,

    Side note, I looked at your profile.  Coincidentaly I am using KnowledgeLake Capture Software on this project to create a paper to electronic document archive system.  I recently reported a bug I found to Mike L. concerning date fields as well. Small world and I hope to continue business with KnowledgeLake.


    North to the Future
    Wednesday, October 6, 2010 7:03 PM
  • Did you do a full crawl after you mapped the managed property to the crawled property? The technet instructions also apply to SharePoint 2010. Make sure you are typing in the name of your managed property : datevalue.
    Blog | SharePoint Field Notes Dev Tool | ClassMaster
    Wednesday, October 6, 2010 7:09 PM
  • Yes, I did a full crawl, twice for good measure.  I am also set to crawl every 30 minutes. My search query looked like this: DateOfBirth:10/4/1964 . Resulted in not found.  I tried other dates that were available, same results.
    North to the Future
    Wednesday, October 6, 2010 7:24 PM
  • Steve Curran, that worked!  After a little digging, I found that my auto crawls stopped working on 9/29/2010.  I was using the stsamd command to initiate new crawls that were telling me "Operation Successful".  However I noticed they were a little too fast and the logs told a different story.  I found the manual crawl page and used it. 

    Your suggestion was the real fix for the column though.  The problem I posted here has been going on well before 9/29/2010, so crawling was only one piece of the broken puzzle today.  I have only now had time to fully address it.

    You the man! Thanks to you and others at KnowledgeLake that have been helpful as I wrap up this project. 


    North to the Future
    Wednesday, October 6, 2010 10:19 PM
  • Steve,

    I am trying to Search by Year. I have datetime column in Picture library and if user gives 2009 I have to return all 2009 records. Could you guide me how can I do this using Meta Data Property?

    Why do we have to specify DateTime Property Name in Search(datefield:12/31/2009)? I am not giving any Property Name for Text Properties.

    Thank you.

    Thursday, March 3, 2011 9:42 PM
  • Hi Bob,

    I am not sure which Steve you are asking, me or Steve.Curran.  Anyway, Steve Currans answer worked for me. Included in his explanation is a technet guide on how to do this.  Although it is an advanced function of SharePoint, it is easy to do.  Here is the link:

    http://technet.microsoft.com/en-us/library/cc164182.aspx\

    To answer your question (or not), I do not know why The SharePoint developers make you (us) go through such great lengths to index and search on Metadata dates.  Sorry.


    My server died and went to Dell.
    Thursday, March 3, 2011 10:45 PM