none
Active Directory Management Pack - No alerts

    Question

  • Hi,
     
    I have SCOM 2012 running. I will be using SCOM to monitor Domain Controllers (W2K3 SP2). Presently all DCs are

    being monitored with MOM 2000. I have uninstalled the MOM 2000 agent on the DCs. I installed the Active Directory Management Pack in SCOM 2012. Next I installed the SCOM Agent on the DCs from the Operations Manager Console.

    All Agents running under the Local System account.

    I have noticed that quite a few Alerts are not reported to the console. For example,

    Event ID: 1419 Directory service: The local domain controller is both a global catalog

    and the infrastructure operations master = Alert: DC is both a global Catalog . . . . . . Does this have to do with the fact that I installed the ADMP, THEN the agents

    on the DCs? Reading the ADMP documentation mentions that I should verify that all

    Agents are installed before importingt the ADMP. I find this rather annoying

    as I have over 500 DCs and I would need to install all 500 Agents before I

    install the ADMP. As this takes time, it means my DCs will not be monitored for several days. How can I correct this without having to re-install the SCOM environment?

    Would it be enough to simply delete the ADMP and reinstall it after all DCs

    have the Agent installed? Woud I need to wait a specific amount of time

    after the removal of ADMP before reinstalling it so that all Agents are aware of it being removd? Anyone have any suggestions? dave


    
    Friday, February 22, 2013 7:31 AM

Answers

  • Hi Dave,

    As i am currently not having my console open, I couldn't check if the Rule is configured to ALERT by default though it is enabled. Please check if the mentioned Rule is configured for Alerting.

    If it is configured for Alerting, please proceed on Restarting the "System Center Management" service by clearing the cache. Also make sure that have latest Config file. And try triggering the event 1419 and check for alerts.


    Regards, Suresh

    Thursday, February 28, 2013 4:45 PM

All replies

  • Hi David,

    Though guidelines says agent to be installed first once you have basic SCOM infra ready and then install required MP's. But it works either way as well, there is no as such hindrance I've noticed.

    http://technet.microsoft.com/en-us/library/hh212838.aspx

    You also mentioned that you are not getting a few alerts it means except few you are getting other alerts. Are you looking for specific alerts to be generated?

    Also, have you enabled proxy agent on all of your DC's in SCOM, this is must for discovery data for AD?

    Are you done with Post MP import steps for AD, if not please refer to AD MP guide?

    Thanks,

    Varun 

    Friday, February 22, 2013 10:26 AM
  • Hi Varun,

    I have enabled the proxy agent on all DCs being monitored. I have completed all Post MP steps.

    All DCs are global catalogs so I should be receiving the following Alert:

    Rule Name: DC is both a Global Catalog and the Infrastructure Update master.

    The error message Event ID: 1419 appears in the Directory Service event log so I should be receiving an Alert, but I don't. The Rule has no overrides and is ENABLED.

    Thanks for your response.

    dave

    Friday, February 22, 2013 10:31 AM
  • Hi Dave,

    As i am currently not having my console open, I couldn't check if the Rule is configured to ALERT by default though it is enabled. Please check if the mentioned Rule is configured for Alerting.

    If it is configured for Alerting, please proceed on Restarting the "System Center Management" service by clearing the cache. Also make sure that have latest Config file. And try triggering the event 1419 and check for alerts.


    Regards, Suresh

    Thursday, February 28, 2013 4:45 PM