locked
Do not require password after display off RRS feed

  • Question

  • Hello,

    since I have joined a domain with Windows 8 Enterprise on my notebook, it requires a password when the display turns off due to inactivity. How can I disable this, either using local setting, or the domain group policy?

    Please note that I want to keep it requiring password when the computer goes to sleep and wakes up.

    Thank you,
    Jan

    Thursday, January 24, 2013 6:22 PM

All replies

  • Unless you've got a domain group policy that enforces it (in which case you would need to talk to your network admins) you should be able to do this by clearing the on resume, display logon screen checkbox in the screen saver.  To get to your screen saver go to your desktop background, right click and select Personalize from the context menu.  You'll see the screensaver entry in the lower right hand corner.  Click on that to open a screensaver settings dialog.  You'll see the checkbox to the right of the wait time entry.  That will keep the screensaver from requiring a password, but should be independent of the sleep power settings.

    Paul Stork SharePoint Server
    MVP Principal Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Thursday, January 24, 2013 6:39 PM
  • Oh yes I forgot the note on screensaver, I am not using it at all.
    The Personalisation says None under Screen Saver and the checkbox in settings is cleared.

    This is the default installation of the domain controller, no extra policies were set up. If you know which policy might influence this, I will be more than happy to check it.

    Jan

    Thursday, January 24, 2013 6:44 PM
  •  Hi,

    When you remove the “On resume, display logon screen” option on Screen Saver, it should not ask for  your credential.

    You may check this GPO:

    • User Configuration/Administrative Templates/Control Panel/Personalization/

    Password protect the screen saver  

    Furthermore, this article may helpful to you:

    http://support.microsoft.com/kb/221784


    Leo Huang
    TechNet Community Support

    Monday, January 28, 2013 6:59 AM
  • Hi Leo, as I noted I am not using screen saver, and the option is not checked. Yet still, the password is required when the display turns off.
    Monday, January 28, 2013 9:46 AM
  • I would try re-adding the screen saver, then turn off the password to see if it changes anything.  There are some behind the scenes items, like power plan or strict security after adding an Exchange account to Mail, that modify the way things work.  That may have happened without being reflected in the UI.  Resetting it through the UI may alter that behavior.  Otherwise it might require digging in GPOs or the registry.

    Paul Stork SharePoint Server
    MVP Principal Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, January 28, 2013 4:01 PM
  • I have tried enabling the screen server, turning the password on and off, this works as expected, and turned the screen saver off again. Does not seems the screen saver setting influences the display off power option.
    Monday, January 28, 2013 6:04 PM
  • Have you tried Control Panel->Power Options-)Require a  Password on Wakeup?

    Change the setting to not require a password.

    Friday, February 1, 2013 5:29 PM
  • Sure, but I want a password to be required when the computer wakes up from sleep, just not when the display turns off.
    Saturday, February 2, 2013 8:33 AM
  • After joining a Windows 8 machine to a domain, you need to set the following registry key to continue using the "Require a password after the display is off for" feature under PC Settings -> Users

    Without the key, you will see the option greyed out.  The amount of time that you can choose to delay will also be limited by the amount of time you have set before your screensaver kicks in.  That is, only if you have your screen saver set to require a password, but if the screensaver doesn't require a password, then you can set the display lock to never require a password.

    If you don't see the option at all under PC Settings -> Users, then also make sure that you have your power options set to require a password when resuming from Standby.  From what I could tell, it seems like the option disappears if you don't have that set.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
    "AllowDomainDelayLock"=dword:00000001


    You also cannot have the policy set to require Ctrl+Alt+Del, which becomes "Hold down the Windows button, then press the power button" on Windows 8.  Enabling that policy also prevents the Delayed lock from being used.
    • Edited by Darin S Tuesday, June 18, 2013 10:03 PM
    • Proposed as answer by Darin S Tuesday, June 18, 2013 10:03 PM
    • Unproposed as answer by Jan Kučera Friday, June 28, 2013 10:07 PM
    • Proposed as answer by Darin S Saturday, September 7, 2013 1:55 PM
    • Unproposed as answer by Jan Kučera Monday, February 10, 2014 10:19 AM
    Friday, June 14, 2013 8:24 PM
  • Darin, I want to provide the password when resuming from standby, that part works.

    I do not want to provide it after display off time out, and that part does not work.

    I do not use any screen saver.

    What was your suggestion to try? I am not sure I understand it properly.

    Friday, June 28, 2013 10:18 PM
  • Jan,

    My suggestion is to try setting the registry key I listed above.  This should allow you to chose the display lock timeout again, even if your computer is joined to a domain.  You set the password timeout for the display in the Users settings area.

    Friday, July 5, 2013 2:15 PM
  • This was actually very simple, but not reachable by any normal control panel features. Just go to start and type in "Screen Saver". It will open the now-hidden screen saver options. There, un-check the "require password" check box.

    Greg Speed
    speedsoft.com


    Thanks, Greg

    Wednesday, August 14, 2013 10:15 PM
  • gave ya a vote worked a dream important to  add to a tablet to give that iPad exp.

    I know I could deploy a rego file in GP but is there a GPO for this. Or is it a custom make one.

    Saturday, September 7, 2013 1:00 AM
  • There's no GPO for it, as far as I can tell it's not documented anywhere.  I found it using the Procmon Sysinternals tool.  Maybe Microsoft will be nice enough to add it to the GPO set in 8.1, or who knows, the behavior could be completely different in 8.1...
    Saturday, September 7, 2013 1:54 PM
  • Darin, I want to provide the password when resuming from standby, that part works.

    I do not want to provide it after display off time out, and that part does not work.

    I do not use any screen saver.

    What was your suggestion to try? I am not sure I understand it properly.


    Has your problem been solved? I have the same problem but I can't figure it out.
    Monday, February 10, 2014 9:46 AM
  • yzgulec83, not it hasn't. There indeed seems to be a GPO for it, though.

    Darin S, sorry for late response, notifications weren't coming. Now I see your point but unfortunately there does not seem to by any screen saver settings on 8.1, are they?

    Jan

    Monday, February 10, 2014 10:25 AM
  • I believe I have found the solution.

     

    Go to power plan settings (Control Panel\All Control Panel Items\Power Options\Edit Plan Settings), click "Change advanced power settings", in power options window click "Change settings that are currently unavailable." Set "Require a password on wakeup" to No. This controls the password prompt after display timeout.

     

    Go Charms, then PC Settings. Accounts, then Sign-in options. "Password policy" controls the password prompt after sleep, and can be controlled by domain policy.

     

    Go to personalization (Control Panel\All Control Panel Items\Personalization), then Screen Saver. If you want a password prompt after a certain idle time, check "On resume, display logon screen." You can leave the screen saver set to "None." The wait time setting will be enabled after the box is checked. This will still allow the display(s) to turn off, wiggle mouse, no password.

     

    I did some thorough testing to make sure it works. It has been a point of frustration for me for quite a while. Especially watching web conferences through the browser that don't disable the display timeout.

     

    These are my settings:

    On battery: display off after 5 min (no password), password required after 20 min, sleep after 25 min (password)

    Plugged in: display off after 10 min (no password), password required after 20 min, never sleep

     

    I should point out that a password is still required after wake from sleep even if I didn't set the screen saver resume password. So I could have something like this:

    On battery: display off after 5 min (no password), sleep after 25 min (password)

    Plugged in: display off after 10 min (no password), never sleep





    Thursday, May 22, 2014 2:54 AM
  • I can't get your solution to work mke_Geek.

    I want the display to turn off at say 1 min idle time.
    Then I don't want to enter my password until maybe 10 min idle time.
    If the computer sleeps then I want it to require password.

    I have now set "Require a password on wakeup" to No.
    The screen saver set to "On resume, display logon screen" and wait 10 minutes.

    The computer turns off the display at 1 min and if I wake it up it doesn't require a password.
    But if I wait 10 minutes more it still doesn't require a password.

    Thursday, May 22, 2014 9:34 AM
  • I was able to get your scenario to work.

     

    Check out this link and see if it works for you. I think my domain policy blocks this setting.

    http://www.eightforums.com/tutorials/28485-password-require-after-display-off-windows-8-1-a.html

    Thursday, May 22, 2014 5:34 PM
  • Hi,

    I don't have that option in my settings.

    I have Windows 8.1 update.

    Thursday, May 22, 2014 7:18 PM
  • After joining a Windows 8 machine to a domain, you need to set the following registry key to continue using the "Require a password after the display is off for" feature under PC Settings -> Users

    Without the key, you will see the option greyed out.  The amount of time that you can choose to delay will also be limited by the amount of time you have set before your screensaver kicks in.  That is, only if you have your screen saver set to require a password, but if the screensaver doesn't require a password, then you can set the display lock to never require a password.

    If you don't see the option at all under PC Settings -> Users, then also make sure that you have your power options set to require a password when resuming from Standby.  From what I could tell, it seems like the option disappears if you don't have that set.

    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
    "AllowDomainDelayLock"=dword:00000001


    You also cannot have the policy set to require Ctrl+Alt+Del, which becomes "Hold down the Windows button, then press the power button" on Windows 8.  Enabling that policy also prevents the Delayed lock from being used.

    I wanted to chime in here and expand on this post.  I too, was having signficant problems preventing the computer from "locking" after the screen turned off.

    I have Windows 8.1.  Every time the screen turned off it would prompt for a password.

    If you turn off "require password on wakeup" it will stop, but this also disables the prompt when the system actually goes into standby.

    I discovered that Windows 8 has redefined what we computer users think of as "standby."  Now, if the screen turns off it is actually a form of standby.  I believe it is called "connected standby." Therefore, if the option to require password on wakeup is set it also locks when the screen simply turns off.

    However, for domain connected computers you can set the following group policy to stop this behavior.  It is the policy that controls the above listed registry key: [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\System]
    "AllowDomainDelayLock"=dword:00000001

    The policy is under [Computer\Administrative Templates\System\Logon] - Allow users to select when a password is required when resuming from connected standby - Enabled.

    I noticed that as part of my current GPO settings there is no way to adjust the lock time under PC settings as described above.  Instead it tells me it is controlled by an administrator and that the computer is set to display a password prompt when the computer wakes up. 

    However, it no longer requires a password when the screen turns off.

    Saturday, March 28, 2015 8:30 PM
  • Perfect, thank you.
    Tuesday, June 30, 2015 11:12 PM
  • How I do this in Windows 10?
    Wednesday, December 16, 2015 1:56 AM
  • How I do this in Windows 10?
    Did you find a way to make this work in Windows 10?
    Tuesday, March 8, 2016 1:34 PM
  • Worked for me, perfect solution
    Friday, March 31, 2017 3:13 AM