locked
UAC Prompts from Network Whenever a Network Connects RRS feed

  • Question

  • Just today I started getting strange UAC prompts from the program "Network" (with CLSID {E5A040E9-1097-4D24-B89E-3C730036D615}) whenever a network connects (plugging in Ethernet cable, connecting to a wireless network)...etc. It occurs on two Windows 8 machines (both domain-joined).

    According to the only thing I found on the Internet (http://www.itproffs.se/index.php?/topic/39631-windows-8-irriterande-uac-fraga-naetverksprofil/, non English content), it seems to be trigger by Set Network Location. Whether approving the UAC request or not seems have no difference. The UAC prompts pops-up next time a network connects.

    Has anyone seen this behavior?

    Wednesday, November 7, 2012 2:09 PM

All replies

  • I'm also getting this behaviour - and it's annoying the hell out of me seeing as I typically connect to at least 10 different networks a day...
    Wednesday, November 7, 2012 11:07 PM
  • Hi,


    Please help to check if the issue only occurs with the domain user accounts or the issue occurs with all user accounts (Both local account and Microsoft Account) in a local machine.


    Thanks.


    Jeremy Wu

    TechNet Community Support

    Friday, November 9, 2012 4:30 AM
  • Hi,

    Just did some test. I tested several accounts, domain admin, domain user and local admin. It only happens when a certain domain user logs in (the user who owns the two PCs). I suspect it might be caused by some user settings. I recall there was a setting that lets Windows automatically set Network Location, but I couldn't find the setting anymore.

    Thursday, November 15, 2012 4:26 AM
  • Same here on all Clients. Installed Windows 8 on all Clients and then joined my SBS 2011 Domain using Connect.

    Only appears after wake from energy saving modus. I will try Hot Fix 313997(http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2028749&kbln=de)

    Tuesday, November 27, 2012 1:56 PM
  • This patch is for Windows 7.

    I have the same Problem here with a view pc´s. I can´t use W8 for our users, if this bug don´t get fixed.

    Please help us, fixing the problem.

    Thank you.

    Wednesday, December 5, 2012 9:18 AM
  • I have the same problem. Any solution?
    Tuesday, December 18, 2012 10:15 PM
  • It's certainly related to individual users. We issued a new laptop to the affected user, and the exact issue came back the moment the user logs on to the new laptop.

    Is everyone experiencing this issue domain-joined? We couldn't reproduce this issue on a new user account (whether domain or local).


    @Compsupport, I doubt the hot fix will work (since it's only for Windows 7 and unattended installation). But would be happy to be proven wrong =)
    • Edited by J-Liu Friday, December 21, 2012 7:51 AM
    Friday, December 21, 2012 7:50 AM
  • I'm seeing the same thing when a regular domain user logs into one of the domain-joined win8 laptops. She gets the UAC prompt for "Networks" and it doesn't seem to matter whether she ignores it or enters in the local admin creds.

    Friday, December 21, 2012 11:16 PM
  • Does anyone know if there has been any progress on this issue? I am experiencing the same problem. The problem still occurs even after completely wiping the disk and rebuilding the OS. The odd piece is it is only happening for one domain user.
    Thursday, January 17, 2013 3:08 PM
  • Yes, I can´t believe, that this bug still exists...welcome in a worl of a consumer Windows...
    Thursday, January 17, 2013 3:14 PM
  • It's been three months and not any update from MSFT =(

    I also tried setting the group policy "Require domain users to elevate when setting a network’s location" to disabled (on domain and local computer), but has no effect.

    We still can't reproduce the issue on other domain users. But on all Windows 8 computers the affected user signs in, the UAC prompt follows. However, if the affected user signs in to a Windows Server 2012 machine, there's not UAC prompt.

    Wednesday, February 6, 2013 11:46 AM
  • It's been three months and not any update from MSFT =(

    I also tried setting the group policy "Require domain users to elevate when setting a network’s location" to disabled (on domain and local computer), but has no effect.

    We still can't reproduce the issue on other domain users. But on all Windows 8 computers the affected user signs in, the UAC prompt follows. However, if the affected user signs in to a Windows Server 2012 machine, there's not UAC prompt.


    Yes, MS seems to be not interested in Fixing this bug, at the Moment. We won´t buy any Windows 8 product, until this is fixed
    Wednesday, February 6, 2013 12:01 PM
  • I installed a new Windows 8 VM, logs in as the affected user, and hasn't seen the problem yet. I suspected it might have to do with some PC settings that synced with Microsoft account, so I linked the domain user to its Microsoft account. Still no prompt yet.

    Interestingly enough, on all physical computers I tested, the UAC is there. However, I tested on a Windows Server 2012 VM and now on the Windows 8 VM, the situation is gone completely.

    Thursday, February 7, 2013 1:45 PM
  • While I don't know why this is causing the issue, I was seeing it happen to me only while I had my domain user account connected to my Microsoft account via the Control Panel "Users" option.  When I disconnected the accounts and restarted, this went away.  My supervisor has the exact same deployment of Win 8 as me, never connected his MS account to his domain account, and never saw the issue.

    I'd recommend other users seeing this to check if their Microsoft account is connected to their domain account, and if so disconnecting to see if that resolves the issue.

    Thursday, February 14, 2013 4:22 PM
  • While I don't know why this is causing the issue, I was seeing it happen to me only while I had my domain user account connected to my Microsoft account via the Control Panel "Users" option.  When I disconnected the accounts and restarted, this went away.  My supervisor has the exact same deployment of Win 8 as me, never connected his MS account to his domain account, and never saw the issue.

    I'd recommend other users seeing this to check if their Microsoft account is connected to their domain account, and if so disconnecting to see if that resolves the issue.

    Hi N Lee Shelton,

    I think, everybody in this thread knows, that this issue only happens, when the Domain account and MS Live Account is paired ;-)

    So, we need a fix for this problem. I can´t deploy Win8 Tablets in my company until this is fixed, but MS seems not interested at the Moment.

    Thursday, February 14, 2013 4:27 PM
  • While I don't know why this is causing the issue, I was seeing it happen to me only while I had my domain user account connected to my Microsoft account via the Control Panel "Users" option.  When I disconnected the accounts and restarted, this went away.  My supervisor has the exact same deployment of Win 8 as me, never connected his MS account to his domain account, and never saw the issue.

    I'd recommend other users seeing this to check if their Microsoft account is connected to their domain account, and if so disconnecting to see if that resolves the issue.

    Hi N Lee Shelton,

    I think, everybody in this thread knows, that this issue only happens, when the Domain account and MS Live Account is paired ;-)

    So, we need a fix for this problem. I can´t deploy Win8 Tablets in my company until this is fixed, but MS seems not interested at the Moment.


    I certainly didn't until I realized it myself, and it's not referenced anywhere else in this thread. Not saying that it's not a problem, but as a temporary workaround it should at least be known.
    Friday, February 15, 2013 12:23 AM
  • Yes, you are right, sorry, so let´s do this now:

    It seems, the problem only happens, when a Domainuser connects the user to his MS Live Account.

    Somebody has this effects, without a connected MS Live Account?

    Monday, February 18, 2013 10:18 AM
  • Anyone ever find an answer to this?
    Monday, April 15, 2013 4:58 PM
  • Anyone got a solotion to this problem?

    Friday, May 3, 2013 9:10 AM
  • If you go into the Metro settings / Sync. Uncheck Save Passwords. So far I have been UAC free :-)

    Friday, May 10, 2013 8:22 PM
  • That works, unfortunately I dont think that this should be the solution as I would like to keep my stuff synced :)

    Monday, July 1, 2013 2:12 PM
  • If you go into the Metro settings / Sync. Uncheck Save Passwords. So far I have been UAC free :-)


    Yeah but then it doesn't save passwords.
    Monday, October 21, 2013 1:50 PM
  • This is for the time being by design. Either you leave the UAC prompting levels as the default, or you disable password syncing. For win8 and higher, the default uAC levels are the test configuration.
    Monday, October 21, 2013 8:54 PM
  • Sort of disappointing that a more permanent fix is not available.  I will note one other potential "solution".  I ran into this problem only after removing local administrator rights from a domain account on a system.  If I grant local administrator rights back to the domain account, the prompts immediately go away.

    Of course this also is not an ideal solution because you really should not be running as a local administrator if you do not absolutely have to.

    Tuesday, February 11, 2014 12:19 PM
  • I have just recreated this issue on a domain joined machine. Aside from any troubleshooting steps suggested in this thread I went to the UAC controls and found that the user had set the UAC to the highest setting rather than the default setting. I ticked this setting down to the 2/4 settings (the default) and it appears to have resolved the issue
    Monday, August 4, 2014 6:45 PM
  • This issue is what made me switch from OneDrive to Google Drive. 
    Wednesday, October 15, 2014 1:05 AM
  • For anyone still following this thread, this issue is finally fixed (hopefully) within the November 8.1 update that was released last night:

    http://support.microsoft.com/kb/3005346

    Wednesday, November 19, 2014 1:35 PM
  • Actually, the issue is still present in Windows 8.1 with Update, on a brand-new fresh install.

    First MS exam done! (70-271)

    Friday, February 6, 2015 5:56 PM
  • I can concur that this still exists for 8.1 tablets - We have Enterprise as well on them.
    Wednesday, February 18, 2015 5:05 PM