none
Can't access/delete Libraries folder after user account is deleted

    General discussion

  • I had the same issue as others have discussed here:

    http://social.technet.microsoft.com/Forums/en-US/w8itprogeneral/thread/3e1f8f92-2bd5-44b6-a33c-c6a402720d05

    The "answer" doesn't really answer nor solve the problem.

    Problem:

    With Windows 8 Pro (and likely Windows 8), if the Windows Media Player Network Sharing Service is running when a user is deleted (using the correct methods through the control panel, using "netplwiz", or using "Advanced user management") and the option to delete all of the user files and folders is selected, the folder "%userprofile%\AppData\Roaming\Microsoft\Windows\Libraries" fails to be deleted.

    Worse still, even after a reboot, the Windows Media Player Network Sharing Service continues to lock this folder so it cannot be manually deleted, nor can security settings be altered, nor can "takeown" be used to gain control.

    If a user with the same first name is later created, the user ends up with an altered %userprofile% path that includes several numbers after the name (which causes confusion to regular users when trying to figure out which folder is theirs).

    Solutions:

    One option is to manually shut down the Windows Media Player Network Sharing Service prior to deleting any users.

    A second option is to shut down the Windows Media Player Network Sharing Service after deleting any users followed by manually deleting the remaining user folders.

    A third option (that I have not tested but should work as most services do not start) is to boot into safe mode and delete the remaining user folders.

    Hopefully this will help others with this frustrating glitch.

    Saturday, May 04, 2013 1:39 PM

All replies

  • Thanks a lot, you've just saved my day (or my night)!


    Rgrds - M. Gy.


    • Edited by MGyHardSoft Friday, August 23, 2013 12:22 AM
    Friday, August 23, 2013 12:22 AM
  • you are awesome thank you thank you
    Friday, November 22, 2013 4:20 AM
  • A year after and your post still works wonders! That 3rd option did it for me. Come to think of it, that's usually where I would have gone first, like I've done in the past, but frustration got the best of me tonight. That said, a HUGE THANKS for the reminder. The best and easiest solution EVER!
    Tuesday, September 16, 2014 5:54 AM