none
hosted network is allowing only one client at a time.

    Question

  • Hi everyone,

    i created a hosted network on Windows 8 using below command

    netsh wlan set hostednetwork ssid=basitg key=****** mode=allow

    and started using below command

    netsh wlan start hostednetwork

    then i say my room mates to connect to this network and i noted that only one device can connect at a time. Then i use below command to view hosted network properties

    netsh wlan show hosted network

    this output as below;
    -----------------------
    Hosted network settings
    -----------------------
        Mode                   : Allowed
        SSID name              : "basitg"
        Max number of clients  : 1
        Authentication         : WPA2-Personal
        Cipher                 : CCMP

    Hosted network status
    ---------------------
        Status                 : Started
        BSSID                  : bc:77:37:3a:31:ae
        Radio type             : 802.11g
        Channel                : 11
        Number of clients      : 1
            8c:a9:82:7a:40:be        Authenticated

    please note 'Max number of clients : 1' in above output, actually this is preventing more than one device to connect.
    How can i change this to any number that i want, I need to connect 4-6 devices to my hosted network???

    Bundle thanks advance.

    [MBasit]
    Sunday, July 14, 2013 3:02 PM

Answers

  • That "maximum clients" is the smaller of two values: the hardware's capability, and the administrative configuration. It's most likely that your wireless hardware just doesn't support more than 1 client at a time.

    If you think that some program might have accidentally set the administrative maximum to 1, you can reset your hosted network settings by running these commands from an elevated command window.  Note that this will delete the SSID and passphrase that you've configured, so you'll have to re-apply them.

    net stop wlansvc
    reg delete hklm\system\currentcontrolset\services\wlansvc\parameters\hostednetworksettings /v hostednetworksettings
    net start wlansvc
    
    After doing that and re-starting hosted network, you can check if that increased the max-clients limit.  If the limit was not increased, you'll just have to buy a new wireless adapter.

    Monday, July 15, 2013 11:58 PM

All replies

  • That "maximum clients" is the smaller of two values: the hardware's capability, and the administrative configuration. It's most likely that your wireless hardware just doesn't support more than 1 client at a time.

    If you think that some program might have accidentally set the administrative maximum to 1, you can reset your hosted network settings by running these commands from an elevated command window.  Note that this will delete the SSID and passphrase that you've configured, so you'll have to re-apply them.

    net stop wlansvc
    reg delete hklm\system\currentcontrolset\services\wlansvc\parameters\hostednetworksettings /v hostednetworksettings
    net start wlansvc
    
    After doing that and re-starting hosted network, you can check if that increased the max-clients limit.  If the limit was not increased, you'll just have to buy a new wireless adapter.

    Monday, July 15, 2013 11:58 PM
  • This really does the trick,

    Thanx so much

    Tuesday, July 16, 2013 3:03 PM
  • Thanks this really worked..cheers mate

    Thursday, October 3, 2013 8:17 PM
  • Hello,

    I tried this in order to increase the number of connections, and now I'm unable to connect anymore: I re-created and re-started the hotspot, I see it, but an "identification" phase lasts very long (maybe 40s). After that phase, I try to connect with my client (android phone), but I cannot receive an IP on my client.

    What should I do?

    Thank you!

    Tuesday, November 5, 2013 12:25 PM
  • you are brilliant!

    and also i have a problem.

    i wanna change the max connections of the hostednetwork ,but i do not know to do it.

    could you help me >

    if possible ,may i have your email with the solutions ,this is my emai address :co.pangolin#gmail.com

    bundle thanks advance


    • Edited by nullne Tuesday, November 19, 2013 4:51 PM mail address
    Tuesday, November 19, 2013 4:49 PM
  • Yes that increased the maximum number of clients. Thanks Jeffrey. Can you please help with a related thread which was started by me No internet access through hosted network.
    Friday, November 22, 2013 7:01 AM
  • thx very much bro

    please can you help me by giving the procedure how to set it at maybe 20 clients????

    Monday, July 20, 2015 7:41 PM
  • But how to set it e.g- i want to set max clients to 10 or 15.
    Thursday, January 21, 2016 3:36 PM
    • Open Registry: local_machine\System\CurrentControlSet\Services\WlanSvc\Parameters\HostedNetworkSettings
    • Open HostedNetworkSettings (REG_BINARY)
    • Edit offset 64, (value 64 hex = 100 decimal) to any other value like 01 for one user only (or FF for 255 count of users)
    • Restart services: dot3svc, WlanSvc
    • Start hostednetwork again
    Tuesday, August 23, 2016 12:40 PM