Fix for Mail's "Account unavailable" message

    General discussion

  • It's entirely possible this is the wrong place for this note; please let me know where I should move it if necessary. But this is information I do feel should be out there somewhere.

    Seemingly at random throughout the process of moving from the various Pre-Release versions of Windows 8, I have had issues using the Mail app with one of my accounts. I'll sync between 3-5 accounts on each machine, but there's one Google Apps mail account that, until now, only worked on some iterations. When it doesn't work, it REALLY doesn't work - no folders are synched, no messages are synched, and uninstalling and reinstalling the app doesn't do anything, nor does removing and re-adding that account.

    Purely by accident, I discovered the solution this morning. Having upgraded from the Windows 8 Enterprise trial to Windows 8 Pro last week, I added all my usual accounts, and sure enough, that one account didn't work. I just left it there, hoping I'd figure out what was going on. Every time the app synchs, the dreaded message "[e-mail address] is unavailable" would appear for a few minutes. This morning, I absent-mindedly started a new message and told it to send from that unavailable account. This time, a new message popped up, something along the lines of "If you want to sync this account, you need to comply with account restrictions in place on the server. Click the button to learn more". I clicked the button, and it told me that I needed to make sure that all administrators on the machine had strong passwords.

    Suddenly, the light went on. Since Windows 8 doesn't offer to join a domain during the normal setup, I usually create an account called "temp" with a basic password that I intend to delete later. The first thing I do when the computer boots is to join the domain. Sometimes I forget to delete that account once I'm in, since I never have to see it again (bad admin, I know). Here's the key though; it doesn't have a strong password, so my entire machine is considered out of compliance with the EAS policy, and thus refuses to sync. I have no idea why it doesn't give a more helpful error than "account is unavailable" until you try to send a message, but there it is. Once I deleted the temporary account, my mail, calendar, etc all came right in without any further issues!

    I hope this helps someone!

    • Changed type mgarrison Tuesday, November 13, 2012 6:46 PM It's a fix, not a question
    Tuesday, November 13, 2012 6:39 PM

All replies

  • mgarrison, 

    I have tried what you said, but I never seem to get message to pop up. I did find that I had a couple of windows updates to install so I am holding out hope for that!

    It is people like you who lead me to believe that there is still hope! Haha, if I find anything after the update I will make sure to post it here.

    Thursday, November 15, 2012 3:48 AM