Networking, firewall and Diagnostic Policy Service all disabled. Errors 5 & 1068: Access denied


  • My computer has lost all of these functions:

     -          wired and wireless networking

    -          firewall

    -          System Restore

    -          Diagnostic Policy Service

     For firewall, I get two error messages. Under Control Panel > Windows Firewall I get Error code 0x6D9. Under Services.msc I get "Windows could not start the windows Firewall service on Local Computer. Error 1068: The dependency service or group failed to start"

    For Diagnostic Policy Service I get this error:

    Windows could not start the Diagnostic Policy Service service on Local Computer. Error 5: Access is denied

     I have tried the following solutions:

    - Power off and restart router, modem, and computer.

    - I disabled antivirus before trying all of the following:

    - System Restore: This too is broken. It starts running, shuts down computer, then computer restarts and there’s an error message saying it can’t restore the computer because antivirus might be interfering.

    - System File Checker twice. It found no errors.

    - Device Manager > Network adapters > Uninstall all of them, then restart computer. They all reappeared in Device Manager.

    - Services.msc  >  Confirmed that 'Network Connections' is set to Manual, and 'Windows Management Instrumentation' set to Automatic

    - Kaspersky TDSSKiller. It didn’t find anything.

    - Microsoft Firewall Diagnostic (also called “Fix It”) –  This won’t run at all. I just get error message saying “Troubleshooting cannot continue because an error has occurred… Code 80072EE7”

    - Changed registry permissions to “Full Control” and “Read”, for the following keys:







    • Edited by trottel1 Monday, August 13, 2012 9:15 PM added more error message info
    Monday, August 13, 2012 7:53 PM


All replies

  • backup your files and install windows fresh, this is a serious mess

    I was afraid someone would say that ;^)

    I'll do that if necessary. Any chance the 'Repair Install' function could help?

    All I know about Repair Install is that it is more or less the last thing to try before a total reinstall. The thing is, I don't have a license key. It's a 100% legit Thinkpad bought directly from Lenovo but it came with neither a Windows license number (on a sticker or what have you), nor a Windows CD - just the total nuclear 'Factory Restore' cds.

    Also, it seems Repair Install could run into major driver-related problems, based on what I'm reading online. I suppose because drivers can get messed up or deleted during the repair - I'm not really sure.

    Tuesday, August 14, 2012 12:37 AM
  • if you can get the repair up, try it first

    your machine has an OEM license

    So what do I do when it asks for the license number?
    Tuesday, August 14, 2012 2:26 AM
  • there should be a certificate on the bottom of the machine with it

    My mistake - it turned out to be under the battery, which I've never had occasion to remove.

    Thanks for the help! It's gonna be a couple of day until I can get around to trying the Repair Install.

    Thursday, August 16, 2012 12:52 AM
  • Click on RUN in Win 7, or search for CMD in Win 8


    Right click on it and select run as administrator and run these commands and press <ENTER>

    net localgroup administrators localservice /add
    net localgroup administrators networkservice /add

    Restart the PC

    Worked like a charm. Makes me wonder what these gamers are talking about. Why post if you don't care?

    Wednesday, November 06, 2013 5:10 PM