locked
How do you change Metro apps default install location? RRS feed

  • Question

  • I can't seem to find an answer for this any ware, I have a 120gb ssd drive that I use for my os, and some programs. I have another 1.5tb drive that has most of my applications and data. Since space is kind of limited on my ssd drive, I would like to change the default install location for metro apps (Microsoft store apps, or what ever it's called) to point to my larger hard drive. I don't see a way of doing this myself, so I figured I would ask here. I also work for a company that sells custom built computers, and this is a very popular setup, but I can see this quickly becoming a problem with this type of setup. Any help would be greatly appreciated :D
    Wednesday, August 22, 2012 5:44 AM

Answers

  • The registry key to set the directory for Metro apps is located at: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx

    You have the "PagckageRoot" key that sets the value.

    I don't know if it's supported to change that value and/or if it will break anything, if you want to try it, it's at your own risk.

    • Marked as answer by DarkIQ Sunday, August 26, 2012 7:46 AM
    Saturday, August 25, 2012 12:03 PM

All replies

  • Hi, 

    If you means the default app such as Music, Media and so on, there has no way since it's just like Document/Music in previous OS. If you meam some 3rd party application, please be assured that the main components' location depends on your decision when you install the application. The button in panel interface is just shortcut and will not take many place. 

    Thanks. 

    Kevin Ni


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Thursday, August 23, 2012 11:00 AM
  • I'm cool with the default apps, I'm would like the change the folder where future Metro app (or Microsoft store apps) are installed. Take for instance a game like nightmares of the deep, it's almost 500mb, I would prefer to install that on my larger hard drive, but I don't see an option to do that? I can see this being a problem with setups like mine. Do you know how you can specify what location those apps can be installed? Also thank you for the speedy response :D
    Saturday, August 25, 2012 6:58 AM
  • You could try using NTFS junction points to trick the system into installing the data somewhere else.  There is no oficially supported method though.
    Saturday, August 25, 2012 11:12 AM
  • The registry key to set the directory for Metro apps is located at: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx

    You have the "PagckageRoot" key that sets the value.

    I don't know if it's supported to change that value and/or if it will break anything, if you want to try it, it's at your own risk.

    • Marked as answer by DarkIQ Sunday, August 26, 2012 7:46 AM
    Saturday, August 25, 2012 12:03 PM
  • Hmmm, i'll try it out on a vm, nice find, thank you soooo much!!! :D
    Sunday, August 26, 2012 7:45 AM
  • Well everything worked fine on my vm, so I made the change on my pc, and so far so good! I did notice that the machine needs a reboot for it to fully work, but besides that, I've had no problems, you rock :D
    Tuesday, August 28, 2012 8:09 AM
  • Hi,

    Are there any Microsoft employees with information on this becoming configurable via the UI instead of relying on registry changes? I expect there will be a lot of users out there who don't want to fill up their OS drives with apps.

    Rob


    Microsoft Certified Technology Specialist (CRM) GAP Consulting Ltd Microsoft Community Contributor Award 2011

    Tuesday, August 28, 2012 12:19 PM
  • I had issues trying to update the PackageRoot key:


    Microsoft Certified Technology Specialist (CRM) GAP Consulting Ltd Microsoft Community Contributor Award 2011

    Tuesday, August 28, 2012 6:57 PM
  • Here is what I did. I must warn that I haven't had any issues on my own machine doing this, but you might, so proceed with caution. Also, it's always a good idea to create a restore point before starting.

    1. Create a folder on your other drive that you want the applications to install to. I used the same location on my system, only on the other drive. 
    2. Now open up regedit, and go to this location. 
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx
    3. Now right click on the "Appx" folder, and go to "Permissions"
    4. Click "Advanced", and click "Change" at the top to change the owner.
    5. Type in "Administrators" for the owner, and click ok, then ok again.
    6. This should take you back to the regular permissions window. From here make sure "Administrators" or your user name have "Full Control", and click ok.
    7. Now double click on "PackageRoot", This should bring up the String Editor.
    8. Change the "Value Data" to the new folder you created, and hit ok, and close the registry editor.
    9. Lately, give your machine a reboot, and you should be all set.
    Give me a click if you found this helpful :D 
    Wednesday, August 29, 2012 4:50 AM
  • problem with the regedit method is when trying to update the default pre-installed apps they will not update. you can install and update new apps but the ones like email music will no longer update, I had this problem and switched back the the default dir and the default apps then updated. 

    edit: uninstall all the apps like mail and what not that were pre-installed, change the dir using regedit and then re-install all the apps you uninstalled. it works perfect now.

    Thanks DarkIQ

    • Edited by js2021 Monday, October 29, 2012 5:06 AM
    Monday, October 29, 2012 4:56 AM
  • I had the same issue and I was about to start uninstalling all my apps after doing a system backup but then I ran into a problem.

    You can't uninstall Internet Explorer, what happens when this applications has an update? There are two likely scenarios here:

    1. An update comes out and you can't update it because you can't uninstall it.

    2. It can be updated because it's a core application to Windows.

    Once an update is released for Internet Explorer if someone can update us on what happens it would be appreciated.

    Wednesday, October 31, 2012 3:49 AM
  • problem with the regedit method is when trying to update the default pre-installed apps they will not update. you can install and update new apps but the ones like email music will no longer update, I had this problem and switched back the the default dir and the default apps then updated. 

    edit: uninstall all the apps like mail and what not that were pre-installed, change the dir using regedit and then re-install all the apps you uninstalled. it works perfect now.

    Thanks DarkIQ

    I tried this method after Finance would not update. I changed the packageroot back to the default directory, restarted windows, uninstalled finance, changed the packageroot to my desired location, restarted windows then installed finance. It seemed to Install properly but when I tried to launch it it quit back to the start page.  Am I missing something from your method?  
    Wednesday, October 31, 2012 6:43 AM
  • problem with the regedit method is when trying to update the default pre-installed apps they will not update. you can install and update new apps but the ones like email music will no longer update, I had this problem and switched back the the default dir and the default apps then updated. 

    edit: uninstall all the apps like mail and what not that were pre-installed, change the dir using regedit and then re-install all the apps you uninstalled. it works perfect now.

    Thanks DarkIQ

    I changed the install directory and then uninstalled the apps. I probably should have done it the other way around, because now the Mail/Messaging/People/Calendar app doesn't work. Won't update, and won't run either...

    Can someone please share where the default install location is so I can get rid of them in the same order js2021 did? 

    Any idea why all this is messing up otherwise?

    Wednesday, October 31, 2012 1:50 PM
  • Here is what I did. I must warn that I haven't had any issues on my own machine doing this, but you might, so proceed with caution. Also, it's always a good idea to create a restore point before starting.

    1. Create a folder on your other drive that you want the applications to install to. I used the same location on my system, only on the other drive. 
    2. Now open up regedit, and go to this location. 
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx
    3. Now right click on the "Appx" folder, and go to "Permissions"
    4. Click "Advanced", and click "Change" at the top to change the owner.
    5. Type in "Administrators" for the owner, and click ok, then ok again.
    6. This should take you back to the regular permissions window. From here make sure "Administrators" or your user name have "Full Control", and click ok.
    7. Now double click on "PackageRoot", This should bring up the String Editor.
    8. Change the "Value Data" to the new folder you created, and hit ok, and close the registry editor.
    9. Lately, give your machine a reboot, and you should be all set.
    Give me a click if you found this helpful :D 

    I did this to no avail.  I am getting error message "this app couldn't be installed" error code 0x80073cfd.

    I am doing this on a Windows Surface RT.  Here is what I did:

    1. refreshed Surface to original setup
    2. uninstalled all preinstalled metro apps (could not uninstall store and IE)
    3. updated all windows updates (there's 3 and they are time consuming)
    4. Created the same folders on my SD Card (\Program Files\WindowsApps\)
    5. took ownership over appropriate registry item (HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx)
    6. Changed the drive letter for the "PackageRoot" (from C to D on my device)
    7. Shut down (full shut down) and restarted my device

    When I got back in, I tried to install the metro apps and I got the above error.

    Any thoughts as to why?

    Sunday, December 16, 2012 6:58 PM
  • Hi

    I got the same error code when I tried this. I have a Iconia w510. But maybe it could be because my other "drive" is a SD memory card. Either way this is really really annoying and this stops me from bying new apps because i dont have the space for it!! Tthat would be a big reason why Microsoft should change this NOW!

    Monday, December 31, 2012 5:33 PM
  • Has this issue been solved yet?

    I have the exact same setup and I can't install any Apps because my SSD is full
    But, I have 2, 1TB HD's that are practically empty.
    Monday, January 7, 2013 11:52 PM
  • This message appears if it is FAT32, you must convert your hard disk to NTFS format
    This message appears "0x80073cfd"if it is FAT32, you must convert your hard disk to NTFS format.
    • Proposed as answer by SSAquarius Thursday, January 10, 2013 8:29 AM
    Thursday, January 10, 2013 8:28 AM
  • check your file permissions on the folder your trying to installing to.


    Regards, Bill

    Monday, November 4, 2013 10:37 PM
  • How about with windows 8.1? I can't find PackageRoot in the same location...
    Tuesday, November 12, 2013 4:48 AM
  • The registry key to set the directory for Metro apps is located at: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx

    You have the "PagckageRoot" key that sets the value.

    I don't know if it's supported to change that value and/or if it will break anything, if you want to try it, it's at your own risk.

    Attn 8.1 Users:  Do NOT do this or else you will not be able install any further Apps and all the built-in Apps will cease to function.  Undoing the change will not fix it either.  Only restoring from a System Restore Point or re-install will work.
    Sunday, April 13, 2014 8:56 PM